Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema Wine con Vector Linux 7
#1
Ciao a tutti, oggi vi posto un problema che forse non e' un problema nel senso che non ha proprio una risoluzione.

Intanto per chi non sa' in che pesche mi trovo vi basta leggere il primo post di questa discussione li' spiego tutto:
http://www.istitutomajorana.it/forum2/Th...tor-Linux7

Per gli altri passo ad illustrare la problematica.
Dunque ho una docente di terza elementare che vorrebbe avviare un progetto di lavoro con la classe nell'aula di informatica ed essendosi innamorata di un programmino "Primi libri 7" mi ha chiesto se era possibile averlo sui pc che hanno pero' sistema operativo VectorLinux7.
Ora gli spiego che quel programma e' un .exe di windows ma che provero' ad emulare l'ambiente win su Vector utilizzando l'applicativo Wine.

Ora filo per segno vi dico cosa ho fatto:
Dal sito ufficiale di wine scarico:
 http://dl.winehq.org/wine/source/2.0/wine-2.0.tar.bz2
in realta ne esisterebbe una versione piu' nuova questa:
http://dl.winehq.org/wine/source/2.x/wine-2.1.tar.xz
solo che la 2.1 e' un archivio xz?!? e Xarchiver non ne vuole sapere di scompattarla.

Procedo quindi a scompattare la 2.0
Xarchiver mi crea una cartella vi entro e scelgo l'opzione apri il terminale qui'. Quindi;
$ su
password
# ./configure (scrive tante belle cose sul monitor)
# make (anche qui' scrive ma stavolta ci mette una vita)
# make install
sembra che abbia finito quindi lancio la configurazione
# winecfg
fa' un po di robe poi piange che non c'e' Mono e mi chiede se puo' installarlo per me' anche se sarebbe consigliato farlo da soli scaricando la versione piu adatta alla propria release ?!? seee.... e dove e quando la trovo! rispondo fai tu grazie!
Poi non trova Gecko e allora faccio come sopra.
Alla fine pare aver tutto e mi si apre l'interfaccia di configurazione
I parametri sono tanti e astrusi, quindi mi limito a dirgli di emulare l'ambiente grafico win10
fine credo quindi chiudo il terminale.

Per testarlo prima scarico da qui'
https://notepad-plus-plus.org/download/v7.3.3.html
quindi doppio click sul file npp.7.3.3.installer.exe 
mi chiede con quale applicazione aprirlo scrollo l'elenco e in fondo trovo Wine! bene forza.
Eseguite le instruzioni mi trovo il collegamento sul desk. Doppio click e voila' notepad++ in azione!!!

Mi faccio coraggio e scarico primi libri da qui:
http://vbscuola.it/pagine/primilibri.htm
Una volta ottenuto l'installer ripeto le operazioni come per notepad e alla fine mi trovo con due collegamenti sul desk?!
uno classico file di configurazione desk
l'altro con estensione .Ink

Gia' butta male, penso, infatti se clicco su uno non succede nulla sull'altro parte l'orologino come se stesse pensando ma alla fine non parte nulla.  Disperato

Non so' se e' colpa del fatto che notepad e' scritto in C++ mentre Primi Libri in VB, o se io non sappia configurare bene wine, oppure i due gnomi sopra (Momo e Gecko) installati in automatico non gli piacciano... o forse mancano semplicemente delle librerie non saprei.

NB: So' benissimo che usare linux per simulare Win e' un po' come martellarsi le noci... se qualcuno conosce un programma nativo linux che faccia qualcosa di simile a primi libri.....

Grazie per la pazienza.
Cita messaggio
Grazie da:
#2
Probabilmente il programma non funziona con wine...non tutti i software funzionano.
Cita messaggio
Grazie da:
#3
Novita!!!!
Allora ho guardato su win 10 nelle info del programma e dice che gli servono queste librerie:
-a) le librerie del runntime di VB6 (Caspita' quant'e' vecchio!!!)
-b) le librerie SAPI 4 o sapi 5
-c) la libreria GDIPlus.ddl

La prima e' ovviamente indispensabile le altre non ne impediscono l'avvio.
Allora sono andato sul sito della Microsoft e ho scaricato il pacchetto:
VB6.0-KB209887-x86.exe
L'ho dato in pasto a Wine che mi ha chiesto dove estrarlo. Ho creato una cartella Temp e l'ho messo li'
Quindi in temp mi trovo il runntime vbrun60sp6.exe
Do di nuovo questo file in pasto a Wine, parte l'orologino non sembra accadere nulla ma vedo che l' HD lavora.
Torna il cursore a freccia, provo a sculo di lanciare PrimiLibri e ora VA!!!

Adesso appena posso provo con gli altri pc che ho a scuola e vi faccio sapere se si e' trattato di una botta di c... o se funziona!
Per ora Grazie!
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)