Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problemi con VLC in visualizzazione con Ubuntu 14 04 (linuxp 64 bit)
#1
Ciao a tutti,
questa volta tocca a VLC che non vuole fare il suo dovere:
alcuni filmati li apre senza problemi, su altri crasha, cioe' si apre per un attimo e poi
si richiude la finestra immediatamente.
Ho provato a scaricare una pletora di altri player e quasi tutti hanno lo stesso comportamento,
l'unico che riesce ad aprirmeli tutti correttamente e'
Xine .
Io pero' mi trovo meglio con l'interfaccia di VLC, usandolo da tanto tempo, qualcuno puo' consigliarmi
cosa fare per poterlo ripristinare correttamente?

Grazie!!
Cita messaggio
Grazie da:
#2
che versioni usi di vlc, il tuo sistema è aggiornato? che estensione hanno i file che vanno in crasch?
Cita messaggio
Grazie da:
#3
Fallo partire da terminale e apri uno di quei file che vanno in crash e poi posta il log e quanto scritto.
Cita messaggio
Grazie da:
#4
Ecco qua dopo aver dato il comando: vlc nomefile.wmv

VLC media player 2.1.6 Rincewind (revision 2.1.6-0-gea01d28)
[0x2080118] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
[wmv3 @ 0x7f1250c5b160] Extra data: 8 bits left, value: 0
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
[0x7f1240001248] main vout display error: Failed to resize display
Errore di segmentazione
Cita messaggio
Grazie da:
#5
non sembra un errore di facile interpretazione, ma viene suggerito :

reinstallazione completa, a causa di conflitti con dei plug-in non funzionanti.
cancellazione dei file delle impostazioni personali, specie hai installato una nuova skin.

magari prova subito la più semplice.
Cita messaggio
Grazie da: wfrcrd , wfrcrd
#6
l'ho gia' reinstallato un tot di volte, ma ripeto anche tutti gli altri eccetto uno non vanno, skin non mi risulta averne installate... Scappo
Cita messaggio
Grazie da:
#7
I codec per il wmv sono nelle librerie di VLC. Il problema potrebbe derivare forse da aver installato qualche programma antagonista che confligge con le sue librerie

Comunque prova ad installare la versione del PPA:
http://ubuntuhandbook.org/index.php/2015...ntu-14-04/

nel caso di problemi, installa ppa-purge per eliminarlo.

Leggi bene nel terminale le cose che fa, in maniera da poter eventualmente ripristinare la situazione.
Cita messaggio
Grazie da: wfrcrd
#8
(23-10-2015,14:12 )supertuxkart Ha scritto: I codec per il wmv sono nelle librerie di VLC. Il problema potrebbe derivare forse da aver installato qualche programma antagonista che confligge con le sue librerie

Comunque prova ad installare la versione del PPA:
http://ubuntuhandbook.org/index.php/2015...ntu-14-04/

nel caso di problemi, installa ppa-purge per eliminarlo.

Leggi bene nel terminale le cose che fa, in maniera da poter eventualmente ripristinare la situazione.

Ho installato la versione che mi hai indicato ma non e' cambiato molto ,
allora do dato lo stesso comando ma con un autoremove al posto di install, poi  
ho provato a disinstallare del software che avevo installato dopo la creazione del sistema operativo:
ho rimosso avidemux e le librerie ( si chiamano cosi? ) a lui associate, poi ho ri installato il pacchetto indicatomi da te e non funzionava ancora, solo che non funzionava nemmeno Xine, l'unico che prima andava.
A questo punto ho fatto un bel restore e sono al punto di partenza.

Magari posso indicare quale software e' installato provando a togliere qualcosa, ma per me inesperto e' facile togliere qualcosa che serve...
E invece provare a fare un downgrade di vlc? Ma come si fa?

Ps allo stato attuale vlc a volte parte ma con schermo nero , l'errore che da' e' il seguente:

Codice:
VLC media player 2.1.6 Rincewind (revision 2.1.6-0-gea01d28)
[0x2478118] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
Fontconfig warning: FcPattern object size does not accept value "0"
[0x7f0938001248] main vout display error: Failed to resize display
[0x7f0938001248] main vout display error: Failed to resize display
Cita messaggio
Grazie da:
#9
Se hai installato la versione indicata dal ppa le cose da fare erano queste, da terminale :
Codice:
sudo add-apt-repository ppa:mc3man/trusty-media
Codice:
sudo apt-get update
Codice:
sudo apt-get install vlc vlc-plugin-*

Al momento dell'installazione da terminale viene specificato se viene eliminato qualche pacchetto, per poter fare l'installazione.
Avevi preso nota ?
Nel caso devi vedere in
Codice:
/var/log/apt/term.log

o aprire il/i precedente/i term.log.1.gz o altra numerazione con gestore archivi.

Per disinstallarlo non è sufficiente :
Codice:
apt-get remove vlc vlc-plugin-*
perchè nella prossima infornata ti verrà nuovamente upgradato il pacchetto.

Devi fare come scritto :
Codice:
sudo apt-get install ppa-purge
Codice:
sudo ppa-purge ppa:mc3man/trusty-media
perchè ti rimuove il ppa e ti riconverte il pacchetto alla versione precedente e rimette i repo di Ubuntu.

Questo per la prossima volta, invece di reinstallare il backup per ritornare alla situazione precedente.

Se invece vuoi provare a fare il downgrade di VLC, per vedere qual'è la situazione :

Apri Gestore Pacchetti.
Digiti VLC nella Casella di Ricerca.
Selezioni VLC.
Dal menù Pacchetti, scegli "Forza versione".
Scegli la versione precedente(2.1.2), se c'è, dal nottolino del form che ti si apre.
Poi vai su Applica.
Prendi accuratamente nota se viene disinstallato qualche altro pacchetto che non ha niente a che fare con VLC.
Poi una volta completato l'aggiornamento riselezioni VLC.
Sempre da Pacchetto stavolta scegli "BLOCCA VERSIONE".
Non ti preoccupare se poi lo ritrovi in Gestore Aggiornamenti, tanto non te lo reinstalla, ma viene segnalato a meno che tu non lo nasconda.
Verrà reinstallata la versione più recente solo se scegli di avanzare di versione.
Cita messaggio
Grazie da: wfrcrd
#10
Grazie del supporto,
pero' la faccenda si stava cominciando a complicare troppo per le mie conoscenze per cui, a mali estremi estremi rimedi:
siccome non mi sembra di avere delle grandi pretese da ubuntu ho deciso di installare la xubuntu 14 04 da zero ed ho incominciato ad installare solo cio' che mi serve, compreso vlc ..
Per ora non ho avuto grossi problemi, ma le cose piu' difficili da installale ( sopcast e acestream per esempio) le tengo per ultime.
Pensavo erroneamente che installare una distro preconfezionata rendesse tutto piu' rapido ed agevole, ma purtroppo nel mio caso non e' cosi'.
Scusate se vi ho fatto perdere un po' di tempo, ma i vostri consigli mi sono comunque serviti per trovare la direzione giusta.
Tanto tra poco torno a rompere per qualche altro motivo, statene certi!
Grazie ancora...
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)