Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problemi con matplotlib v.1.5
#1
iao a tutti,

vi espongo subito il mio problema e spero che possiate essermi di aiuto.
Con alcuni ragazzi gestiamo un plugin per Qgis, che usa diverse librerie python. Una di queste è matplotlib (v.1.2).
Da quando ho aggiornato Ubuntu alla v.16.04., mi si è aggiornata anche matplotlib all'ultima versione, la 1.5.
Inoltre, quando la rimuovo sia da terminale che da synaptic, si disinstalla anche Qgis (come se Qgis, dipendesse da una libreria di python). Stessa cosa quando installo Qgis aggiorna in automatico matplotlib.


Ho provato disinstallare tutto, installare la versione 1.2 e a bloccarla con il comando "sudo apt-mark hold matplotlib", ma mi dice che il pacchetto non esiste.

Questo è il primo errore:

ImportError: cannot import name NavigationToolbar2QTAgg

e questo è il secondo:

ImportError: No module named requests



Spero che qualcuno di voi possa consigliarmi cosa fare. Mi arrendo

Grazie in anticipo a tutti.


Giuseppe
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)