Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problemi di avvio UEFI, Bios etc
#1
Salve ragazzi, un saluto caloroso e problemi per me irrisolvibili.
Ho preso un computer nuovo e ho inizializzato il disco usando il gparted di partition magic, mentre ho effettuato le operazioni tutto è andato come da manuale, ho prima cancellato il disco, che non era nuovo, c'erano dei dati da eliminare, perciò ho usato la opzione erase disk che ha viaggiato per un'pora buona, senza dare alcun segnale per vedere il progredire dell'operazione, questo è un bug che non correggono, perciò in principio non avevo modo di capire se l'operazione fosse partita o meno, tutto al buio! Comunque alla fine è apparso finalmente un messaggio di operazione conclusa, sollevandomi dalla incertezza che avevo. Ho avviato subito dopo gparted ed ho cominciato creando la tabella partizioni, che è stata creata senza errori. Ho quindi creato metà disco (un tera di capacità) la partizione estesa, dove avrei poi cominciato a creare le partizioni. Cominciai con una soltanto, logica, che doveva ospitare debian 9.1. Tutto è andato bene, nessun errore di boot e d'altro, tutto bene. Da debian ho avviato gparted e ho creato alte due partizioni logiche che hanno ospitato PclinuxOs e openmandriva, ultime edizioni di entrambi, molto bellini, come debian del resto. In principio e per qualche giorno non fu segnalato alcuna anomalia nel boot, ma i problemi nacquero come l'erba cattiva Debian non veniva più avviato, andava in kernel panic. Le ho provate tutte ma inutilmente, si fermava sempre all'inizio della caricatura del sistema, sempre allo stesso punto con dei parametri che parlavano di kernel pèanic. Perchè? Non avevo fatto niente di diverso e non ho capito cosa accade. In contemporanea ha cominciato ad apparire, come primo messaggio prima di caricare quelsivoglia, un alert rosso, in inglese, che parlava di modalità uefi, da sistemare entrando nel bios, e correggendo l'errore (che non ho capito cosa fosse: il messaggio da quel che ho potuto capire diceva di correggere la modalità UEFI, altrimenti non sarebbe partito più il sistema operativo. Adesso guarda caso io non ne so un'accidente di modalità UEFI e forzatura del bios, perciò non so attribuire la colpa ai programmi in UEFI da correggere nell'altra modalità (non ricordo il nome, ma chi se ne capisce dovrebbe capire di cosa parla questo messaggio. Quindi diceva di entrare nel bios per settare la modalità da UEFI a ......la sola alternativa a UEFI, merd ho dimenticato il nome e il messaggio in rosso non è più apparso così non ho potuto prendere dati certi. Come si può settare l'altrnativa a UEFI? Cosa è ?
Comunque, so che è quasi impossibile avere un quadro esaudiente della situazione con così pochi e imprecisi dati, ma sto tentando l'impossibile. Fatto sta che debian non è più partito, mentre pclos e mandriva sì. Ho ptrovato a creare un'altra partizione in sda, primaria, sullo spazio libero che c'è, ed è stata creata come sda2; debian invece è su sda5 e pclos e mandriva in sda6 e sette, beh, lì, sulla primaria sda2 ho reinstallato debian, cancellando e disallocando sda5, dove stava prima, ma non è servito. E tra l'altro è rimasta in memoria nel grub la posizione sda5, non considerando la sda2, anche se la 5 non esisteva più, perciò ha cominciato a ricaricare il nuovo debian sulla nuova partizione, come fosse la sda5, rievocando lo stesso errore di kernel panic. Insomma, ss qualcuno ha capito qualcosa in questo casino, forse può consigliarmi e spiegarmi qualcosina, data la mia ignoranza in UEFI e relativi. Vi saluto, resto in attesa anche se chiedo un miracolo, mi affido a coi . (credo nei miracoli!) Per favore Per favore Per favore
Cita messaggio
Grazie da:
#2
Ciao
Di che computer stiamo parlando? Marca e modello. potremmo risalire al bios ed essere più precisi.
L'alternativa è tra Bios in modalità Uefi o in modalita Legacy.
E' questa che devi attivare.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#3
è scontato che hai partizionato il disco in modalità mbr visto che parli di partizione estesa e logica, strano che Debian ti vada in kernel panic dopo alcuni giorni, quoto quanto detto da D-BARTO, prova nel bios a impostarlo in modalità Legacy e vedi cosa succede Tongue
Cita messaggio
Grazie da:
#4
Grazie D-Barto, è legacy infatti, l'alternativa a uefi. Ma non ho capito come attivare questa benedetta, e non conosco il modo di operare, di queste due unità. Il computer è un assemblato, scheda madre Asus A68HM series, SX protection il disco è un sata. Il bioso della scheda madre è molto ben fatto, con una marea di opzioni che quasi interamente non ne conosco l'utilità. Comunque so che la faccenda va sistemata sul bios, basterebbe una indicazione, per capire come e cosa fare senza errori. Fino ad ora ho studiato le funzionalità del boot, in modalità Advance. Il messaggio rosso di cui parlavo diceva più o meno : Andare su boot > advanced > e lì operare il cambiamento o attivazione che metterebbe tutto in pace. Sì, perchè ad occhi chiusi mi trovo in difficoltà
Cita messaggio
Grazie da:
#5
Il tuo bios è simile a questo?


Allegati Anteprime
       
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#6
vedi se hai pure una impostazione simile launch csm e mettila su enabled ... riguarda sempre il bios legacy mode
Cita messaggio
Grazie da:
#7
tanto per schiarire le idee, Efi (Uefi) e Legacy sono due modalità in cui la scheda madre viene impostata per gestire il bios.
certamente usando una modalità oppure l'altra dovrai installare i sistemi secondo la scelta. non è possibile avere un sistema in Legacy ed un altro in Efi.
per come hai tu detto sicuramente hai installato in Legacy ( con Efi non è possibile creare partizioni logiche in quanto le tabelle delle stesse vanno scritte in GPT ). circonderei il problema a debian che purtroppo non conosco e non sottovaluterei la problematica grub. molte sono le distribuzioni che vengono installate ma una sola gestisce l'avvio. la butto li per come mi viene in mente, se hai installato in debian il grub2 e nelle altre installate in seguito lo stesso dovrebbe rilevarlo senza problemi, se invece le altre installano grub potrebbe non avviarsi più debian.
adesso un po di info da parte tua: quale distribuzione gestisce l'avvio?
le distribuzioni partono tutte da grub2?
cosa farei io........ con supergrubdisk avvierei debian e da lei aggiornerei, reinstallerei il grub. tieni presente che ogni volta che aggiornrai un kernel di una distribuzione dovrai aggiornare il grub da quella che gestisce l'avvio.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)