Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Adobe Reader chiede continuamente di accettare condizioni di licenza
#1
Su Ubuntu 12.04, dopo aver avviato il sistema, ogni volta che apro Adobe Reader (Acroread) mi chiede di accettare le condizioni di licenza.
Viene fuori la finestrella dove bisogna cliccare su yes ma non rimane memorizzato e alla prossima sessione lo richiede.

Siccome la trovo una cosa fastidiosa, ho modificato il file acroread che si trova in /opt/Adobe/Reader9/bin eliminando le righe dalla 159 alla 179 (aprendo come amministratore con editor di testo)

riavviato il sistema operativo e aperto un pdf: la richiesta non c'è più, si apre immediatamente il file.

Fatto questa prova altre 2 volte e Acroread apre direttamente il pdf!


Edit: ho trovato un'altra soluzione, vedete direttamente l'ultimo post

NB Ho eliminato dal post n° 3 una seconda "soluzione "  che poi si è rivelata inutile.
Marilù
Cita messaggio
Grazie da:
#2
ottimo, quale versione hai installato? La 9.55?
Cita messaggio
Grazie da:
#3
Thumbs Up 
Sì 9.5.5-1 nel gestore pacchetti

 Sleepy

Mi scuso ma pensavo di aver risolto.
Ha funzionato 2 giorni, però poi ha ripreso a chiedere l'accettazione dopo che ho fatto pulizie con bleachbit.
Ad esempio stamattina Adobe Reader non mi ha chiesto niente, poco fa ho aperto un pdf e mi sono ritrovata la richiesta di accettazione un'altra volta (sicuramente la pulizia settimanale con Bleachbit ha fatto ritornare alla situazione di default).
Per ritornare come prima ho ricopiato il file originale in opt/adobe reader /bin poi ho copiato nuovamente quello modificato nella stessa cartella e riavviato.

Edit: è la pulizia della cache di adobe Reader che annulla l'effetto della modifica, documenti recenti e file temporanei si possono lasciare selezionati.


Allegati Anteprime
   
Marilù
Cita messaggio
Grazie da:
#4
Intanto ho eliminato il Risolto, nel frattempo siccome avevo provato ad installare Adobe Reader anche su Pclinuxos, mi hanno suggerito di usare invece MasterPdfEditor che oltre a servire da lettore pdf funziona bene anche per modificarli, il pacchetto  si trova  in synaptic (sia su Ubuntu che Pclinuxos) e a dire la verità come programma è molto più avanzato di Adobe Reader.
D'altra parte il lettore pdf di Mate non offre un gran che.
Sarà una mia fissa ma trovo molto fastidioso che quando magari si ha fretta o  si parla con delle persone e nel frattempo devo consultare un pdf quello rimane bloccato li.
Marilù
Cita messaggio
Grazie da:
#5
Ho trovato questa discussione sul forum di Adobe:
https://forums.adobe.com/thread/418253?start=0&tstart=0

dove dicono che il problema accade perché non si hanno i permessi di scrittura sul file  .adobe/Acrobat/9.0/Preferences/reader_prefs

quindi non memorizza che si è già accettato le condizioni di licenza.

In quella discussione propongono di eliminare il file (ma in questo modo basta una pulizia della cache che al successivo avvio di adobe reader tutto ritorna come prima perché ritorna il default),

allora ho fatto così:

da terminale dare i permessi di scrittura al suddetto file
Citazione:sudo chmod 777 .adobe/Acrobat/9.0/Preferences/reader_prefs


Se il terminale vi dice che non c'è il file vuol dire che è stato cancellato con la pulizia di Bleachbit e per farlo ritornare basta riavviare Adobe Reader e ridare il comando da terminale, dopo accettare la licenza.
A questo punto,

nelle preferenze di Bleachbit (Modifica -> preferenze) click su Non Eliminabili e seguire il percorso fino al file (ricordarsi CTRL H per far apparire le cartelle nascoste)
   


Dopo la pulizia il file è stato omesso, quindi l'accettazione della licenza è ancora memorizzata
   
Marilù
Cita messaggio
Grazie da: esabatad
#6
Su Ubuntu 14.04 questo problema non si è più verificato
Marilù
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)