Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Aggiornamento os-prober grub non rileva altri sistemi
#1
Oggi ho aggiornato PCLinuxOS e ho trovato l'aggiornamento per os-prober

os-prober (1.74-1pclos2017) to 1.76-1pclos2017

Al riavvio, grub2 non rileva gli altri sistemi installati


Allora ho montato tutti gli altri sistemi dal file manger e riavviato l'update di grub e ha rilevato tutto, quindi, se avete più sistemi e il grub che comanda è quello di PCLinuxOS e avete il problema:

1 ° Montare dal file Manager tutti i sistemi presenti
2 ° eseguire l'update di grub

Codice:
su -
password di root

Codice:
update-grub2
e riavviare

EDIT, comunque cè da sperare che correggano, con prossimi aggiornamenti, perchè comunque cè secondo me un'anomalia, se si riesegue l'update di grub senza i sistemi montati si torna da capo, e non dovrebbe succederese, almeno, mai successo con nessun sistema che le partizioni degli altri sistemi devono essere montate...ci dev'essere qualche problema con lo script di configurazione di grub /etc/grub.d/30_os-propber....almeno credo
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: D-BARTO , sharksux
#2
Vero ho fatto l'aggiornamento e avevo notato al riavvio l'anomalia.
Grazie. At At

PS ora verifico la tua seconda parte.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#3
ciao D-BARTO ho fatto un edit, come vedi se uno ridà l'update di grub con le partizioni smontate , non vengono nuovamente rilevati.
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#4
Confermo il problema.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#5
si, è minimo , perchè una volta fatto con le partizioni montate a meno di nuove proprie modifiche al file di grub, non serve un update, però se risolvono è meglio
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#6
Però non so se ricordo male ma ha me sembrava che prima le partizioni venivano montate in automatico all'avvio.
O sbaglio.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....
Cita messaggio
Grazie da:
#7
solo le ntfs , windows, per esempio e la dati ntfs, ma io le avevo rimosse anche quelle dal montaggio automatico, e come tutte le altre linux non sono state rilevate da grub
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#8
cè stato un aggiornamento di os-prober , ma non ha sortito effetti, il problema persiste senza le partizioni dei sistemi montate
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#9
confermo. io ho dualboot seven/pclos, nel fstab ho dovuto levare il cancelletto alla riga della partizione ntfs di boot ( quella da 100 mb ) di seven.
mi è arrivato un ennesimo aggiornamento os-prober. ora anche con le partizioni smontate mi rileva seven, però mi elenca ancora nel grub le voci di pclos nelle partizioni ( poi io con grubcustomizer le levo ). credo si dovrà attendere ancora. texstar è sul pezzo, speriamo risolva
Cita messaggio
Grazie da:
#10
Fixato con l'ultimo aggiornamento di os-prober
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)