Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Avviare programma su desktop virtuale a scelta in Mint MATE
#1
Rebus per esperti e/o smanettoni con capacita' tecniche.
Nella mia Mint Mate 17.3 ho due desktop virtuali, naturalmete con la stessa immagine di sfondo e stessi oggetti, perche', a quanto pare, solo KDE permette di avere immagini e oggetti diversi per ogni desktop.
E' un po' che cerco di trovare il modo di rendere differenti questi desktop, in modo da riconoscerli a colpo d'occhio, perche' per me il selettore spazio di lavoro non e' abbastanza evidente (scusate, e' l'eta').
Ieri per caso ho trovato una soluzione con Cairo-Clock di MacSlow. Questo orologio, se lo apri sul desktop 2 (ad es) e poi lo metti tra le applicazioni d'avvio, si aprira' sempre sul desktop 2, diversamente da come fanno le altre applicazioni messe in avvio automatico che si aprono o sul 1° desktop o ad icona su tutti.
Ora vorrei trovare di fare lo stesso con Trasmission: cioe' fare in modo che si apra in avvio automatico all'accensione del Pc solo sul desktop 2, che diventerebbe il desktop del P2P ed immediatamente identificato, appunto a colpo d'occhio.
Ovviamente la soluzione trovata servirebbe per diversificare i desktop con qualsiasi altra app, un po' come succede con i desktop diversificati per attivita' in KDE.
Qualcuno e' cosi' curioso da cimentarsi nell'impresa?
Cita messaggio
Grazie da:
#2
Ho fatto un po' di ricerche, visto che mi hai suscitato curiosità, e ho trovato questa soluzione.
Installa il pacchetto devilspie

Codice:
sudo apt-get install devilspie

Poi nella home crei una cartella .devilspie, all'interno della quale crei un file denominato nome_applicazione.ds, lo apri e ci incolli il seguente testo (nel mio esempio ho provato a far aprire la calcolatrice di mate nel secondo desktop)

Codice:
(if (is (application_name) "mate-calc") (set_workspace 2))

Sostituisci il comando tra virgolette con quello che vuoi lanciare tu (lo ricavi in /usr/bin) e sostituisci il numero del workspace con quello che preferisci.
Salva il file, poi apri applicazioni d'avvio e aggiungine una per devilspie e una per l'applicazione che hai scelto.

.png   Screenshot_1.png (Dimensione: 19,44 KB / Download: 95)  
.png   Screenshot_2.png (Dimensione: 19,35 KB / Download: 95)
Fonte  http://guide.debianizzati.org/index.php/...il%27s_Pie
Cita messaggio
Grazie da:
#3
Graciis eu66.

Ho dapprima creato il file   nome_applicazione.ds (con il contenuto: [if (is (application_name) "transmission-gtk") (set_workspace 2))], ma siccome al riavvio Transmission mi si e' avviato sul desktop 1, ho rinominato il file in trasmission.ds, e successivamente in trasmission-gtk.ds; pero' al riavvio non e' cambiato niente: transmission continua ad avviarsi nel 1°desktop.
Mi viene la domanda: Siccome ai miei 2 desktop ho dato i nomi Mint e Vbox, questo non fa funzionare devilspie?

P.S. Ho provato a non mostrare i nomi dei desktop nel selettore workspace. Tutto invariato. Tu che nome hai dato al file?
Cita messaggio
Grazie da:
#4
Hai creato la cartella .devilspie, nella home, dentro la quale inserire il file? Il nome per il file lo metti come vuoi, importante è l'estensione .ds.
Per quanto riguarda i nomi che hai dato ai desktop non so quanto influiscono, io il programma l'ho scoperto oggi pomeriggio e non lo conosco benissimo.
Cita messaggio
Grazie da:
#5
(29-03-2016,19:36 )eu66 Ha scritto: Hai creato la cartella .devilspie, nella home, dentro la quale inserire il file?...

Ovviamente.

Da quel che ho letto della fonte che hai citato, dovrebbe funzionare tutto alla perfezione, ma resta che devilspie non sembra riconoscere transmission. Domani provero' a cercare la guida in inglese cui fa menzione il tuo link a fine post; e magari rifaccio la prova che hai fatto tu con calc: forse e' proprio un problema con transmission
Cita messaggio
Grazie da:
#6
ciao. ho provato ( la curiosità..... ) sul mio pclos-mate. quanto proposto da eugenio, funziona perfettamente. solo ti chiedo di verificare come hai impostato preferenze di elenco finestre, devi avere il flag come il mio altrimenti ti appare su tutti i desktop.


.png   Preferenze di Elenco finestre_001-thumb.png (Dimensione: 60,53 KB / Download: 68)
Cita messaggio
Grazie da:
#7
Benritrovato dxgiusti.
Le "preferenze di elenco finestre," che tu hai allegato sono di pclos, come hai specificato.
Ma io non riesco a trovarle in Mint MATE: del resto Pclos non e' la 1a volta che si rivela piu' preciso dei suoi.. concorrenti.
P.S. Tu hai provato con transmission?
Cita messaggio
Grazie da:
#8
click dx sulla barra, aggiungi elenco finestre, magari lo hai già....... click dx sulla barretta che delimita, preferenze.
è di mate, non di pclos.
Cita messaggio
Grazie da:
#9
(29-03-2016,20:40 )dxgiusti Ha scritto: click dx sulla barra, aggiungi elenco finestre, magari lo hai già....... click dx sulla barretta che delimita, preferenze.
è di mate, non di pclos.

Scusa, forse e' colpa della birra che ho bevuto, ma non riesco a capire.
clic dx su quale barra?  click dx su quale  barretta?
Cita messaggio
Grazie da:
#10
il tuo mate ha una barra? in alto, in basso a dx, a sx, dove la metti tu. io l'ho in alto. in quella barra ho inserito elenco finestre ( un click sulla barra, aggiungi ) ora un click sulla barretta che delimita:

   
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)