SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Cambiare percorso alle cartelle della home in ubuntu 16.04
#11
Ci sono altre mosse da tentare?

Grazie
Cita messaggio
Grazie da:
#12
(30-01-2017,11:43 )luchetto Ha scritto: Purtroppo tutto come prima

Allora vuol dire che la partizione in NTFS non si monta all'avvio, 

io ad esempio per far montare la mia partizione dati nel file fstab (dentro etc) ho una riga come questa

#Entry for /dev/sda3 :

UUID=XXXXXXXXXX /media/nomeutente/DATI ntfs-3g defaults,rw,nosuid,nodev,allow_other,default_permissions,uid=1000,gid=1000,umask=000,locale=it_IT.UTF-8,x-gvfs-show 0 0

Le parti in blu le devi personalizzare 
  • numero uuid lo trovi facendo click destro sulla partizione -> proprietà
  • media è il mio punto di mount, Se hai seguito la guida dovresti averlo lì anche te
    (PS Come ha fatto notare Dxgiusti nel post successivo, nella schermata di gparted è montato in /mnt quindi nel file fstab deve non esserci media ma mnt)
  • nomeutente e Dati es: /mnt/luchetto/documenti
In questa maniera la partizione Dati si monta all'avvio, mi compare nel pannello laterale del file manager.
Siccome non mi interessa avere le icone anche sul desktop, dalle impostazioni di Mate avevo deselezionato Mostra volumi montati . Oppure si può fare da g-conf deselezionando volumes-visible.

Eventualmente prima di modificare il tuo file fstab, fai una copia di quello che hai adesso.

Oppure da interfaccia grafica tramite l'applicazione dischi:
   

nella riga c'è scritto: 
defaults,rw,nosuid,nodev,allow_other,default_permissions,uid=1000,gid=1000,umask=000,locale=it_IT.UTF-8,x-gvfs-show

NB uso ubuntu 14.04 ma credo sia lo stesso per il 16.04
Cita messaggio
#13
http://www.chimerarevo.com/linux/montare...tu-133712/
guardando la tua immagine da gparted, vedo che monti la partizione in /mnt , come mai?
hai sicuramente fatto qualche strana operazione. gentilmente posta il tuo fstab. ( il testo non l'immagine )
Cita messaggio
Grazie da:
#14
Ciao e grazie ad entrambi per le risposte. Sicuramente avrò fatto pasticci all'inizio.

Ecco il copia e incolla del file "Fstab":

"# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda5 during installation
UUID=6b74281d-af7b-404c-8990-073ea969fa98 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda6 during installation
UUID=f041df89-bb27-4fdc-abe7-008cd4effef3 none swap sw 0 0
#UUID=C024F58F24F588A4 /media/PuntoDiMontaggio ntfs-3g silent,umask=000,utf8 0 0
/dev/disk/by-uuid/FCD0D308D0D2C7D2 /mnt/FCD0D308D0D2C7D2 auto nosuid,nodev,nofail 0 0"

Grazie
Cita messaggio
Grazie da:
#15
scasa mi sono dimenticato una lista:

sudo blkid

invio, ecc.
Cita messaggio
Grazie da:
#16
/dev/sda1: LABEL="Riservato per il sistema" UUID="EEB4B7F8B4B7C17F" TYPE="ntfs" PARTUUID="c47978c1-01"
/dev/sda2: UUID="C024F58F24F588A4" TYPE="ntfs" PARTUUID="c47978c1-02"
/dev/sda3: LABEL="Documenti" UUID="FCD0D308D0D2C7D2" TYPE="ntfs" PARTUUID="c47978c1-03"
/dev/sda5: UUID="6b74281d-af7b-404c-8990-073ea969fa98" TYPE="ext4" PARTUUID="c47978c1-05"
/dev/sda6: UUID="f041df89-bb27-4fdc-abe7-008cd4effef3" TYPE="swap" PARTUUID="c47978c1-06"
Cita messaggio
Grazie da:
#17
Al posto delle ultime due righe 
#UUID=C024F58F24F588A4 /media/PuntoDiMontaggio ntfs-3g silent,umask=000,utf8 0 0
/dev/disk/by-uuid/FCD0D308D0D2C7D2 /mnt/FCD0D308D0D2C7D2 auto nosuid,nodev,nofail 0 0"

farei così:

#Entry for dev/sda1 Riservato per il sistema
UUID=EEB4B7F8B4B7C17F   /media/luchetto71/Riservato per il sistema auto nosuid,nodev,nofail,noauto 0 0
#Entry for dev/sda2 Windows
UUID=C024F58F24F588A4   /media/luchetto71/C024F58F24F588A4 auto nosuid,nodev,nofail,x-udisks-auth,noauto 0 0
#Entry for dev/sda3 Documenti
UUID=FCD0D308D0D2C7D2 /mnt/FCD0D308D0D2C7D2 ntfs-3g defaults,rw,nosuid,nodev,allow_other,default_permissions,uid=1000,gid=1000,umask=000,locale=it_IT.UTF-8,x-gvfs-show 0 0

Le prime due partizioni sda1 e sda2 di Windows non vengono montate all'avvio, invece sda3 Documenti sì.

Prima fai una copia del tuo vecchio file fstab per backup, poi lo apri come amministratore e cancella solo le ultime due righe e incolla le modifiche, salva e riavvia.
E poi speriamo bene!

Nel caso qualcosa vada storto, ti tieni a portata di mano un cd o pennina con una live per copiare il vecchio file fstab (quello salvato per backup) in etc. Ma io credo che non ce ne sia di bisogno, Ubuntu dovrebbe partire lo stesso perché le righe del file fstab riguardanti Ubuntu non sono state modificate. Al limite documenti continuerà a non montarsi all'avvio.
Cita messaggio
Grazie da: luchetto
#18
Ciao Marilù, grazie per il consiglio ma purtroppo non è andato a buon fine: ho copiato il file fstab sulla partizione dati (per fortuna) e ho proceduto alla modifica delle ultime righe con quelle suggerite da te. Ho riavviato e non mi è partito più ubuntu, inviandomi vari messaggi di errori che ora non saprei ridire. Per fortuna sono rientrato con live e ho rimesso a posto il fle.

Altri consigli ? Grazie ancora di vero cuore
Cita messaggio
Grazie da:
#19
questo è il tuo fstab che hai postato:
Citazione:# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda5 during installation
UUID=6b74281d-af7b-404c-8990-073ea969fa98 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda6 during installation
UUID=f041df89-bb27-4fdc-abe7-008cd4effef3 none swap sw 0 0
#UUID=C024F58F24F588A4 /media/PuntoDiMontaggio ntfs-3g silent,umask=000,utf8 0 0
/dev/disk/by-uuid/FCD0D308D0D2C7D2 /mnt/FCD0D308D0D2C7D2 auto nosuid,nodev,nofail 0 0

metti un # davanti all'ultima riga che diventerà cosi:
#/dev/disk/by-uuid/FCD0D308D0D2C7D2 /mnt/FCD0D308D0D2C7D2 auto nosuid,nodev,nofail 0 0

salva prima di chiudere e riavvia.
ora apri il terminale e scrivi:
Citazione:sudo mkdir /media/Documenti
invio ecc.ecc. questo ti creerà il collegamento nella cartella con la tua partizioe > Documenti.
adesso apri il tuo fstab come amministratore > sudo gedit /etc/fstab , e incolla sotto l'ultima riga questa:
Citazione:UUID= FCD0D308D0D2C7D2 /media/Documenti ntfs-3g silent,umask=000,utf8 0 0
salva prima di chiudere. riavvia ora il tuo sistema.
tu hai chiamato la tua partizione > Documenti, questo è il nome di una cartella di sistema. per evitare eventuali conflitti, io chiamerei la partizione ARCHIVIO, da gparted è semplice farlo. ovviamente dovrai nella procedura sopra descritta, sostituire la parola Documenti con la dicitura ARCHIVIO. se non ti piace quella che io ho scritto, puoi mettere un nome che vuoi tu anche ..... inter se ti garba. l'importante che non contenga spazi, esempio se scrivi grande inter, devi inserire il trattino basso > grande_inter
Cita messaggio
Grazie da:
#20
Premetto che non uso unity, ma quando si apre la cartella "utente" è all'interno della home e non la home stessa. Uso mate è quelle cartelle le vedo nella mia cartella, con il nome da me impostato e all'interno della "home".
Cita messaggio
Grazie da: luchetto


Vai al forum:


Utenti che stanno guardando questa discussione: