Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Disconnessione wifi
#1
Dopo il mio precedente thread
http://www.istitutomajorana.it/forum2/Th...i-fi-lenta
apparentemente risolto, almeno dal punto di vista della velocità di connessione, si è presentato un problema ulteriore: quando il sistema va in stand-by, al successivo sblocco spesso (ma non sempre) la connessione wifi non si riattiva automaticamente e nemmeno manualmente; l'unico modo è riavviare il sistema. Pclinuxos KDE.
Grazie a chi vorrà suggerirmi un rimedio.
Cita messaggio
Grazie da:
#2
Poi, anche se non credo abbia a che vedere col problema segnalato, scompare anche l'icona nel pannello inferiore.
Cita messaggio
Grazie da:
#3
premetto che non sono un utente PClinuxOS;
su Windows questo problema a volte accade perché la scheda wifi va in modalità risparmio energetico e non riesce a "risvegliarsi";
non so se possa entrarci qualcosa nel tuo caso, una controllatina la darei
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
VERSIONE QUANTISTICA DELLA LEGGE DI MURPHY: TUTTO VA MALE CONTEMPORANEAMENTE
Cita messaggio
Grazie da: mask , mask
#4
(02-11-2016,17:55 )BAT Ha scritto: premetto che non sono un utente PClinuxOS;
su Windows questo problema a volte accade perché la scheda wifi va in modalità risparmio energetico e non riesce a "risvegliarsi";
non so se possa entrarci qualcosa nel tuo caso, una controllatina la darei

Sapessi dove guardare...... Grazie comunque della dritta.
Cita messaggio
Grazie da:
#5
penso dovresti guardare nelle impostazioni per il risparmio energetico e disabilitare la "modalità risparmiosa" per la scheda wifi
Il mio blog: ZEROZEROCENT.BLOGSPOT.COM
LEGGE DI MURPHY: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
VERSIONE QUANTISTICA DELLA LEGGE DI MURPHY: TUTTO VA MALE CONTEMPORANEAMENTE
Cita messaggio
Grazie da: mask , mask
#6
(02-11-2016,21:12 )BAT Ha scritto: penso dovresti guardare nelle impostazioni per il risparmio energetico e disabilitare la "modalità risparmiosa" per la scheda wifi

Già tentato, ma non c'è. Peccato.
Cita messaggio
Grazie da:
#7
Per vedere le caratteristiche della tua scheda wifi apri un terminale, diventa root (con il comando su, e dai la password di root) e dai il comando 'iwconfig' (senza le virgolette).  Ora sono su un computer senza wifi e quindi non posso darti il risultato del comando, ma dovresti ottenere qualche cosa del tipo

Citazione:iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"AJ_Home"  
         Mode:Managed  Frequency:2.412 GHz  Access Point: 00:26:F2:FD:92:F4  
         Bit Rate=65 Mb/s   Tx-Power=16 dBm  
         Retry short limit:7   RTS thr:off   Fragment thr:off
         Power Management:on
         Link Quality=55/70  Signal level=-55 dBm  
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:53   Missed beacon:0

lo        no wireless extensions.

Controlla se hai il 'Power Management' on (cioe' attivo) o off (cioe' disattivo).

Per attivare/disattivare il power management usa il comando (sempre da root. Il realta' il comando iwconfig funziona anche da utente normale)

Citazione:iwconfig wlan0 power off

dove al posto di wlan0 devi mettere la denominazione della tua scheda come risulta dal comando iwconfig (potrebbe essere wlan0 o wlan1).  Ridai il comando iwconfig per vedere se ora la scheda ha il power management cambiato.

Se questo ti risolve il problema dovrai fare in modo che il comando venga eseguito ad ogni boot della macchina... ma questo e' un altro problema e ne parliamo dopo.  Intanto controlla sia proprio il power management della scheda il problema.

Ciao, Mauro
Cita messaggio
Grazie da:
#8
Codice:
IEEE 802.11  ESSID:"NETGEAR11"  
         Mode:Managed  Frequency:2.432 GHz  Access Point: E4:F4:C6:DC:B5:06  
         Bit Rate=150 Mb/s   Tx-Power=16 dBm  
         Retry short limit:7   RTS thr:off   Fragment thr:off
         Power Management:off
         Link Quality=43/70  Signal level=-67 dBm  
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:77   Missed beacon:0
Cita messaggio
Grazie da:
#9
Quindi NON e' un problema di power management... peccato!  Undecided

Come fai a riattivare la connessione wifi?  La prossima volta che ti capita prova ad aprire un terminale, dai la password di root (tramite su) e poi dai il comando

Citazione:service network restart

e vedi se ci sono messaggi di errore (eventualmente postali).  Prova inoltre a postare l'output del comando 'dmesg' (dato senza virgolette), in cui vengono mostrate le informazioni sullo stato del sistema.

Ciao, Mauro
Cita messaggio
Grazie da: mask
#10
(04-11-2016,08:45 )footstep11 Ha scritto: Quindi NON e' un problema di power management... peccato!  Undecided

Come fai a riattivare la connessione wifi?  La prossima volta che ti capita prova ad aprire un terminale, dai la password di root (tramite su) e poi dai il comando

Citazione:service network restart

e vedi se ci sono messaggi di errore (eventualmente postali).  Prova inoltre a postare l'output del comando 'dmesg' (dato senza virgolette), in cui vengono mostrate le informazioni sullo stato del sistema.

Ciao, Mauro

Grazie del consiglio, proverò. Fino ad ora risolvevo riavviando il pc, poi ho disattivato il risparmio energetico.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)