Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] - Dual boot : Mint 13 Maya Mate 64bit non vede più Windows 7 64bit
#1
Buonasera a tutti.

Il mio problema : ho 2 hd sda e sdb con installati rispettivamente Windows 7 Ultimate 64bit e Mint 13 Mate Maya 64bit e da quando ho aggiornato Windows non riesco più a vederlo nel boot loader all'avvio.

In passato con il buon GIUS avevamo affrontato e risolto un problema analogo editando le righe del grub sub 40-custom con l'uiid dello hd ... cosa che ho fatto anche questa volta (cfr. righe in rosso) ma che sembra non aver sortito effetto alcuno.

Posto in allegato il mio grub.cfg (cfr. all.to).

Ho anche, ripetutamente, eseguito il grub install e update su entrambi gli hd e questo è il risultato :

[sudo] password for fetonte:
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.2.0-113-generic
Found kernel: /boot/vmlinuz-3.2.0-97-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Sarei molto grato a chi mi potesse dare una mano; grazie anticipate.

Fetonte


Allegati
.docx   grub cfg.docx (Dimensione: 16,83 KB / Download: 4)
Cita messaggio
Grazie da:
#2
sei sicuro dei comandi e/o del tipo di grub che stai usando?
te lo dico perchè la configurazione del file che hai editato appartiene al grub2, mentre il terminale cerca un file "menu.lst" che invece appartiene al vecchio grub, di solito chiamato grub-legacy (non so su mint). Penso che quindi l'errore sia dovuto a questo. I comandi che hai dato sono p. es.:
Codice:
sudo grub-install /dev/sda
e poi
Codice:
sudo update-grub
Undecided
se invece usi la versione legacy devi editare solo il file menu.lst.
controlla la versione del grub installata.
Linux User # 207701 - L'intelligenza non è non commettere errori, ma scoprire subito il modo di trarne profitto.
Cita messaggio
Grazie da: fetonte , fetonte
#3
per cortesia, per file cosi lunghi usa il codice: https://pcloscloud.com/nextcloud/index.p...QT0KLiq2pC
oppure: http://www.istitutomajorana.it/forum2/Th...67#pid4667
correggi il tuo post grazie
Cita messaggio
Grazie da: fetonte , fetonte
#4
DXGiusti : modificato post ...spero ora vada bene...
Cita messaggio
Grazie da:
#5
(20-11-2016,20:52 )m3nhir Ha scritto: sei sicuro dei comandi e/o del tipo di grub che stai usando?
te lo dico perchè la configurazione del file che hai editato appartiene al grub2, mentre il terminale cerca un file "menu.lst" che invece appartiene al vecchio grub, di solito chiamato grub-legacy (non so su mint). Penso che quindi l'errore sia dovuto a questo. I comandi che hai dato sono p. es.:
Codice:
sudo grub-install /dev/sda
e poi
Codice:
sudo update-grub
Undecided
se invece usi la versione legacy devi editare solo il file menu.lst.
controlla la versione del grub installata.

Mi sembra di aver installato grub2 ma, nell'incertezza, ho provato a reinstallarlo con sudo mount /dev/sdXY /mnt
e poi sudo grub-install --root-directory=/mnt/ /dev/sdX dove la mia partizione Mint è sdb5 e la root dir è sdb ... purtroppo non è cambiato proprio niente.

Che debbo fare, ora?
Consigli?

Grazie.
Cita messaggio
Grazie da:
#6
se dai solamente:
sudo update grub
cosa ti dice?
Cita messaggio
Grazie da: fetonte
#7
(22-11-2016,12:12 )dxgiusti Ha scritto: se dai solamente:
sudo update grub
cosa ti dice?

Ecco:

fetonte@fetonte-Mint13Maya64 ~ $ sudo update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.2.0-113-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done
Cita messaggio
Grazie da:
#8
secondo me hai fatto dei casini, quel file non esiste da parecchio sulle versioni di ubuntu/mint, non credo ci sia di default su mint 13, lo devi aver creato tu.
sia /boot/grub/menu.lst nè /boot/grub/default

comunque io ho provato su ubuntu 16.04 e ho aggiunto questo a /etc/grub.d/40_custom io il loader di windows ce l'ho su sda1 (hd0,1) e funziona

Codice:
menuentry "Windows 7" {
set root=(hd0,1)
chainloader +1
}

inoltre , tra pochi mesi mint13 sarà fuori supporto, quindi ti consiglio il backup dei tuoi dati e poi reinstalla altra distro LTS , se vuoi restare su mint, cè mint18
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: fetonte
#9
(24-11-2016,19:40 )tuxino Ha scritto: secondohai fatto dei casini, quel file non esiste da parecchio sulle versioni di ubuntu/mint, sicuramente non cè di default su mint 13, lo devi aver creato tu

Sono assolutamente d'accordo con te, Tuxino, è MOLTO probabile che abbia io fatto casino : sono un semplice utente di linux  ... ma, apposta per questo, chiedo aiuto a chi ne sa più di me ...

Anch'io ho sda1 Windows 7 perciò posso provare a modificare il custom_40 come mi consigli; vado tranquillo?
Cita messaggio
Grazie da:
#10
non saprei, potresti provare a cancellare i due file in questione e provare a rifare le cose, ma non so se ti può creare casini, questi che dicono?

Codice:
ls -l /boot/grub

e

Codice:
cat /etc/grub.d/40_custom

comunque avevo editato il post precedente , vedi riguardo al fatto che mint 13 tra pochi mesi sarà fuori supporto
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: fetonte


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)