Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Errore: BrokenCount > 0
#1
Ciao,
sono un principiante di Xubuntu (17.10). Mi da come errore ( BrokenCOunt > 0) e non mi permette di eseguire gli aggiornamenti. 

Inserendo i tre comandi utilizzati classicamente per risolvere il problema ottengo ciò.

Codice:
paolo@paolo-Extensa-5620:~$ sudo apt-get update
Trovato:1 http://archive.canonical.com/ubuntu artful InRelease
Trovato:2 http://it.archive.ubuntu.com/ubuntu artful InRelease
Scaricamento di:3 http://it.archive.ubuntu.com/ubuntu artful-updates InRelease [65,4 kB]
Trovato:4 http://security.ubuntu.com/ubuntu artful-security InRelease          
Trovato:5 http://it.archive.ubuntu.com/ubuntu artful-backports InRelease      
Recuperati 65,4 kB in 1s (60,2 kB/s)                  
Lettura elenco dei pacchetti... Fatto
paolo@paolo-Extensa-5620:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
cups : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
cups-bsd : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
cups-client : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
cups-core-drivers : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
cups-daemon : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
cups-ipp-utils : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
hplip : Dipende: printer-driver-hpcups (= 3.17.7+repack0-3) ma la versione 3.16.11+repack0-2 è installata
        Raccomanda: printer-driver-postscript-hp ma non è installato
libcupscgi1 : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
libcupsimage2 : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
libcupsmime1 : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
libcupsppdc1 : Dipende: libcups2 (= 2.2.4-7ubuntu2) ma la versione 2.2.2-1ubuntu1 è installata
sane-utils : Dipende: libsane (>= 1.0.24) ma non è installabile
simple-scan : Dipende: libsane (>= 1.0.24) ma non è installabile
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
paolo@paolo-Extensa-5620:~$ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
 flashplugin-installer gcc-6-base:i386 libatk1.0-0:i386 libavahi-client3:i386
 libavahi-common-data:i386 libavahi-common3:i386 libbsd0:i386 libcairo2:i386
 libcups2:i386 libdatrie1:i386 libdbus-1-3:i386 libdrm-amdgpu1:i386
 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386
 libedit2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libfontconfig1:i386
 libfreetype6:i386 libgail-common:i386 libgail18:i386 libgdk-pixbuf2.0-0:i386
 libgfortran3 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
 libglib2.0-0:i386 libglu1-mesa:i386 libgmp10:i386 libgnutls30:i386
 libgraphite2-3:i386 libgssapi-krb5-2:i386 libgtk2.0-0:i386 libgtkglext1
 libgtop-2.0-10 libharfbuzz0b:i386 libhogweed4:i386 libice6:i386
 libidn11:i386 libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386
 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
 libllvm4.0:i386 libllvm5.0:i386 libnettle6:i386 libopencv-calib3d2.4v5
 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4-deb0
 libopencv-objdetect2.4v5 libopencv-video2.4v5 libp11-kit0:i386
 libpango-1.0-0:i386 libpango1.0-0 libpangocairo-1.0-0:i386
 libpangoft2-1.0-0:i386 libpangox-1.0-0 libpciaccess0:i386 libpcre16-3
 libpixman-1-0:i386 libpng16-16:i386 libsensors4:i386 libsm6:i386
 libstdc++6:i386 libtasn1-6:i386 libthai0:i386 libtiff5:i386
 libtxc-dxtn-s2tc:i386 libx11-6:i386 libx11-xcb1:i386 libx265-110
 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
 libxcb-present0:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb-sync1:i386
 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
 libxrandr2:i386 libxrender1:i386 libxshmfence1:i386 libxxf86vm1:i386
 linux-headers-4.10.0-19 linux-headers-4.10.0-19-generic
 linux-headers-4.10.0-35 linux-headers-4.10.0-35-generic
 linux-image-4.10.0-19-generic linux-image-4.10.0-35-generic
 linux-image-extra-4.10.0-19-generic linux-image-extra-4.10.0-35-generic
 oxideqt-codecs-extra
Usare "sudo apt autoremove" per rimuoverli.
The following additional packages will be installed:
 libcups2 libcups2:i386 printer-driver-hpcups sane-utils simple-scan
Pacchetti suggeriti:
 hplip-doc unpaper
I seguenti pacchetti saranno aggiornati:
 libcups2 libcups2:i386 printer-driver-hpcups sane-utils simple-scan
5 aggiornati, 0 installati, 0 da rimuovere e 3 non aggiornati.
21 non completamente installati o rimossi.
È necessario scaricare 0 B/1.035 kB di archivi.
Dopo quest'operazione, verranno occupati 129 kB di spazio su disco.
Continuare? [S/n] s
Preconfigurazione dei pacchetti in corso
(Lettura del database... 276686 file e directory attualmente installati.)
Preparativi per estrarre .../libcups2_2.2.4-7ubuntu2_amd64.deb...
De-configurazione di libcups2:i386 (2.2.2-1ubuntu1)...
Estrazione di libcups2:amd64 (2.2.4-7ubuntu2) su (2.2.2-1ubuntu1)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_amd64.deb (--unpack):
impossibile copiare i dati estratti per "./usr/lib/x86_64-linux-gnu/libcups.so.2" in "/usr/lib/x86_64-linux-gnu/libcups.so.2.dpkg-new": fine del file o dello stream inattesa
Preparativi per estrarre .../libcups2_2.2.4-7ubuntu2_i386.deb...
De-configurazione di libcups2:amd64 (2.2.2-1ubuntu1)...
Estrazione di libcups2:i386 (2.2.4-7ubuntu2) su (2.2.2-1ubuntu1)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_i386.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_i386.deb (--unpack):
impossibile copiare i dati estratti per "./usr/lib/i386-linux-gnu/libcups.so.2" in "/usr/lib/i386-linux-gnu/libcups.so.2.dpkg-new": fine del file o dello stream inattesa
Preparativi per estrarre .../printer-driver-hpcups_3.17.7+repack0-3_amd64.deb...
Estrazione di printer-driver-hpcups (3.17.7+repack0-3) su (3.16.11+repack0-2)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/printer-driver-hpcups_3.17.7+repack0-3_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/printer-driver-hpcups_3.17.7+repack0-3_amd64.deb (--unpack):
impossibile copiare i dati estratti per "./usr/lib/cups/filter/hpcups" in "/usr/lib/cups/filter/hpcups.dpkg-new": fine del file o dello stream inattesa
Preparativi per estrarre .../sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb...
Estrazione di sane-utils (1.0.27-1~experimental2ubuntu1) su (1.0.25+git20150528-1ubuntu4)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb (--unpack):
impossibile copiare i dati estratti per "./usr/sbin/saned" in "/usr/sbin/saned.dpkg-new": fine del file o dello stream inattesa
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
       Preparativi per estrarre .../simple-scan_3.26.1-0ubuntu1_amd64.deb...
Estrazione di simple-scan (3.26.1-0ubuntu1) su (3.24.0-0ubuntu1)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/simple-scan_3.26.1-0ubuntu1_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/simple-scan_3.26.1-0ubuntu1_amd64.deb (--unpack):
il sottoprocesso dpkg-deb --fsys-tarfile ha restituito lo stato di errore 2
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
       Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_amd64.deb
/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_i386.deb
/var/cache/apt/archives/printer-driver-hpcups_3.17.7+repack0-3_amd64.deb
/var/cache/apt/archives/sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb
/var/cache/apt/archives/simple-scan_3.26.1-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Potreste dirmi come si risolve il problema e spiegarmi come si fa e perché?

Molte grazie, buona giornata Big Grin
Cita messaggio
Grazie da:
#2
Avresti dovuto eseguire il comando indicato:
Codice:
apt --fix-broken install
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#3
Mi da questi errori. Grazie per aver risposto 

Codice:
paolo@paolo-Extensa-5620:~$ sudo apt --fix-broken install
[sudo] password di paolo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
 flashplugin-installer gcc-6-base:i386 libatk1.0-0:i386 libavahi-client3:i386
 libavahi-common-data:i386 libavahi-common3:i386 libbsd0:i386 libcairo2:i386
 libcups2:i386 libdatrie1:i386 libdbus-1-3:i386 libdrm-amdgpu1:i386
 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386
 libedit2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libfontconfig1:i386
 libfreetype6:i386 libgail-common:i386 libgail18:i386 libgdk-pixbuf2.0-0:i386
 libgfortran3 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
 libglib2.0-0:i386 libglu1-mesa:i386 libgmp10:i386 libgnutls30:i386
 libgraphite2-3:i386 libgssapi-krb5-2:i386 libgtk2.0-0:i386 libgtkglext1
 libgtop-2.0-10 libharfbuzz0b:i386 libhogweed4:i386 libice6:i386
 libidn11:i386 libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386
 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386
 libllvm4.0:i386 libllvm5.0:i386 libnettle6:i386 libopencv-calib3d2.4v5
 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4-deb0
 libopencv-objdetect2.4v5 libopencv-video2.4v5 libp11-kit0:i386
 libpango-1.0-0:i386 libpango1.0-0 libpangocairo-1.0-0:i386
 libpangoft2-1.0-0:i386 libpangox-1.0-0 libpciaccess0:i386 libpcre16-3
 libpixman-1-0:i386 libpng16-16:i386 libsensors4:i386 libsm6:i386
 libstdc++6:i386 libtasn1-6:i386 libthai0:i386 libtiff5:i386
 libtxc-dxtn-s2tc:i386 libx11-6:i386 libx11-xcb1:i386 libx265-110
 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
 libxcb-present0:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb-sync1:i386
 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
 libxrandr2:i386 libxrender1:i386 libxshmfence1:i386 libxxf86vm1:i386
 linux-headers-4.10.0-19 linux-headers-4.10.0-19-generic
 linux-headers-4.10.0-35 linux-headers-4.10.0-35-generic
 linux-image-4.10.0-19-generic linux-image-4.10.0-35-generic
 linux-image-extra-4.10.0-19-generic linux-image-extra-4.10.0-35-generic
 oxideqt-codecs-extra
Usare "sudo apt autoremove" per rimuoverli.
The following additional packages will be installed:
 libcups2 libcups2:i386 printer-driver-hpcups sane-utils simple-scan
Pacchetti suggeriti:
 hplip-doc unpaper
I seguenti pacchetti saranno aggiornati:
 libcups2 libcups2:i386 printer-driver-hpcups sane-utils simple-scan
5 aggiornati, 0 installati, 0 da rimuovere e 3 non aggiornati.
21 non completamente installati o rimossi.
È necessario scaricare 0 B/1.035 kB di archivi.
Dopo quest'operazione, verranno occupati 129 kB di spazio su disco.
Continuare? [S/n] s
Preconfigurazione dei pacchetti in corso
(Lettura del database... 276686 file e directory attualmente installati.)
Preparativi per estrarre .../libcups2_2.2.4-7ubuntu2_amd64.deb...
De-configurazione di libcups2:i386 (2.2.2-1ubuntu1)...
Estrazione di libcups2:amd64 (2.2.4-7ubuntu2) su (2.2.2-1ubuntu1)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_amd64.deb (--unpack):
impossibile copiare i dati estratti per "./usr/lib/x86_64-linux-gnu/libcups.so.2" in "/usr/lib/x86_64-linux-gnu/libcups.so.2.dpkg-new": fine del file o dello stream inattesa
Preparativi per estrarre .../libcups2_2.2.4-7ubuntu2_i386.deb...
De-configurazione di libcups2:amd64 (2.2.2-1ubuntu1)...
Estrazione di libcups2:i386 (2.2.4-7ubuntu2) su (2.2.2-1ubuntu1)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_i386.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_i386.deb (--unpack):
impossibile copiare i dati estratti per "./usr/lib/i386-linux-gnu/libcups.so.2" in "/usr/lib/i386-linux-gnu/libcups.so.2.dpkg-new": fine del file o dello stream inattesa
Preparativi per estrarre .../printer-driver-hpcups_3.17.7+repack0-3_amd64.deb...
Estrazione di printer-driver-hpcups (3.17.7+repack0-3) su (3.16.11+repack0-2)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/printer-driver-hpcups_3.17.7+repack0-3_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/printer-driver-hpcups_3.17.7+repack0-3_amd64.deb (--unpack):
impossibile copiare i dati estratti per "./usr/lib/cups/filter/hpcups" in "/usr/lib/cups/filter/hpcups.dpkg-new": fine del file o dello stream inattesa
Preparativi per estrarre .../sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb...
Estrazione di sane-utils (1.0.27-1~experimental2ubuntu1) su (1.0.25+git20150528-1ubuntu4)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb (--unpack):
impossibile copiare i dati estratti per "./usr/sbin/saned" in "/usr/sbin/saned.dpkg-new": fine del file o dello stream inattesa
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
       Preparativi per estrarre .../simple-scan_3.26.1-0ubuntu1_amd64.deb...
Estrazione di simple-scan (3.26.1-0ubuntu1) su (3.24.0-0ubuntu1)...
dpkg-deb (sottoprocesso): impossibile copiare il componente dell'archivio da "/var/cache/apt/archives/simple-scan_3.26.1-0ubuntu1_amd64.deb" alla pipe di estrazione: lettura non riuscita (Errore di input/output)
dpkg-deb (sottoprocesso): estrazione componente dell'archivio: errore di lzma: file dell'input inattesa
dpkg-deb: errore: il sottoprocesso <decompressione> ha restituito lo stato di errore 2
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/simple-scan_3.26.1-0ubuntu1_amd64.deb (--unpack):
il sottoprocesso dpkg-deb --fsys-tarfile ha restituito lo stato di errore 2
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
       Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_amd64.deb
/var/cache/apt/archives/libcups2_2.2.4-7ubuntu2_i386.deb
/var/cache/apt/archives/printer-driver-hpcups_3.17.7+repack0-3_amd64.deb
/var/cache/apt/archives/sane-utils_1.0.27-1~experimental2ubuntu1_amd64.deb
/var/cache/apt/archives/simple-scan_3.26.1-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Cita messaggio
Grazie da:
#4
ora sono su Manjaro e non posso verificare con precisione perche non usa apt, ma da terminale digita
Codice:
man apt
e controlla se c'è un comando e/o relativa opzione per svuotare la cache di apt.
Una volta fatto questo dirai i comandi:
Codice:
sudo apt-get update
e
Codice:
sudo apt-get upgrade
e verifica se ti da ancora errori
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da: paolpucci
#5
Ho scritto nel terminale 
Codice:
sudo apt-get clean

 non è successo nulla però. Su internet ho letto che questo comando potrebbe ripulire la cache.
Inoltre non mi va internet, nel senso che si disconnette ogni 10 minuti e devo per forza riavviare. Non so se i due problemi sono collegati; in ogni caso i dispositivi che ho all'interno del PC sono questi, fatemi sapere se sapete come risolvere almeno uno dei due problemi. Grazie
Codice:
paolo@paolo-Extensa-5620:~$ lspci | grep Network
04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
paolo@paolo-Extensa-5620:~$ iwconfig
wlp4s0    IEEE 802.11  ESSID:"InfostradaWiFi-f29b86"  
         Mode:Managed  Frequency:2.462 GHz  Access Point: BC:F6:85:F2:9B:87  
         Bit Rate=54 Mb/s   Tx-Power=15 dBm  
         Retry short limit:7   RTS thr:off   Fragment thr:off
         Power Management:on
         Link Quality=56/70  Signal level=-54 dBm  
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:157   Missed beacon:0

lo        no wireless extensions.

enp2s0    no wireless extensions.

irda0     no wireless extensions.

paolo@paolo-Extensa-5620:~$
 
Scrivendo
 
Codice:
sudo dpkg --configure -a

 
mi esce questo
Codice:
paolo@paolo-Extensa-5620:~$ sudo dpkg --configure -a
dpkg: problemi con le dipendenze impediscono la configurazione di hplip:
hplip dipende da printer-driver-hpcups (= 3.17.7+repack0-3); comunque:
 La versione di printer-driver-hpcups nel sistema è 3.16.11+repack0-2.

dpkg: errore nell'elaborare il pacchetto hplip (--configure):
problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per ureadahead (0.100.0-20)...
dpkg: problemi con le dipendenze impediscono la configurazione di cups-ipp-utils:
cups-ipp-utils dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto cups-ipp-utils (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups:
cups dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto cups (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libcupsmime1:amd64:
libcupsmime1:amd64 dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto libcupsmime1:amd64 (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups-daemon:
cups-daemon dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.
cups-daemon dipende da libcupsmime1 (>= 1.5.0); comunque:
 Il pacchetto libcupsmime1:amd64 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto cups-daemon (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups-core-drivers:
cups-core-drivers dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.
cups-core-drivers dipende da cups-daemon (>= 2.2.4-7ubuntu2); comunque:
 Il pacchetto cups-daemon non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto cups-core-drivers (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libcupsppdc1:amd64:
libcupsppdc1:amd64 dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto libcupsppdc1:amd64 (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libcupsimage2:amd64:
libcupsimage2:amd64 dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto libcupsimage2:amd64 (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups-bsd:
cups-bsd dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto cups-bsd (--configure):
problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per libc-bin (2.26-0ubuntu2)...
Elaborazione dei trigger per systemd (234-2ubuntu12)...
dpkg: problemi con le dipendenze impediscono la configurazione di cups-filters-core-drivers:
cups-filters-core-drivers dipende da libcupsimage2 (>= 1.4.0); comunque:
 Il pacchetto libcupsimage2:amd64 non è ancora configurato.
cups-filters-core-drivers dipende da cups-ipp-utils; comunque:
 Il pacchetto cups-ipp-utils non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto cups-filters-core-drivers (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libgs9:amd64:
libgs9:amd64 dipende da libcupsimage2 (>= 1.4.0); comunque:
 Il pacchetto libcupsimage2:amd64 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto libgs9:amd64 (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups-client:
cups-client dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.
cups-client dipende da libcupsimage2 (>= 1.4.0); comunque:
 Il pacchetto libcupsimage2:amd64 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto cups-client (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libcupscgi1:amd64:
libcupscgi1:amd64 dipende da libcups2 (= 2.2.4-7ubuntu2); comunque:
 La versione di libcups2:amd64 nel sistema è 2.2.2-1ubuntu1.

dpkg: errore nell'elaborare il pacchetto libcupscgi1:amd64 (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di printer-driver-gutenprint:
printer-driver-gutenprint dipende da libcupsimage2 (>= 1.4.0); comunque:
 Il pacchetto libcupsimage2:amd64 non è ancora configurato.
printer-driver-gutenprint dipende da cups (>= 1.3.0); comunque:
 Il pacchetto cups non è ancora configurato.
printer-driver-gutenprint dipende da cups-client (>= 1.3.0); comunque:
 Il pacchetto cups-client non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto printer-driver-gutenprint (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups-browsed:
cups-browsed dipende da cups-daemon; comunque:
 Il pacchetto cups-daemon non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto cups-browsed (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di bluez-cups:
bluez-cups dipende da cups; comunque:
 Il pacchetto cups non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto bluez-cups (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di cups-ppdc:
cups-ppdc dipende da libcupsppdc1 (>= 1.4.0); comunque:
 Il pacchetto libcupsppdc1:amd64 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto cups-ppdc (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di ghostscript:
ghostscript dipende da libgs9 (= 9.21~dfsg+1-0ubuntu3); comunque:
 Il pacchetto libgs9:amd64 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto ghostscript (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di ghostscript-x:
ghostscript-x dipende da ghostscript (= 9.21~dfsg+1-0ubuntu3); comunque:
 Il pacchetto ghostscript non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto ghostscript-x (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di xubuntu-desktop:
xubuntu-desktop dipende da ghostscript-x; comunque:
 Il pacchetto ghostscript-x non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto xubuntu-desktop (--configure):
problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di xubuntu-core:
xubuntu-core dipende da ghostscript-x; comunque:
 Il pacchetto ghostscript-x non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto xubuntu-core (--configure):
problemi con le dipendenze - lasciato non configurato
Si sono verificati degli errori nell'elaborazione:
hplip
cups-ipp-utils
cups
libcupsmime1:amd64
cups-daemon
cups-core-drivers
libcupsppdc1:amd64
libcupsimage2:amd64
cups-bsd
cups-filters-core-drivers
libgs9:amd64
cups-client
libcupscgi1:amd64
printer-driver-gutenprint
cups-browsed
bluez-cups
cups-ppdc
ghostscript
ghostscript-x
xubuntu-desktop
xubuntu-core


Allegati Anteprime
   
Cita messaggio
Grazie da:
#6
e possibile che i due casi siano collegati. Se ti disconnette in fase di scaricamento dei pacchetti e/o aggiornamenti questo tipo di errori dovuti alla presenza di files parziali e/o corrotti è comune. Mi sembra di capire che ti connetti via wifi. Se puoi connetti il pc con un cavo al router e riprova ad aggiornare. Le fequenti disconnessioni potrebbero avere origine da driver mancanti per la sheda wifi.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#7
Il problema con gli aggiornamenti e tutto ciò che è collegato ad essi l'ho risolto un po' a fortuna, eseguendo alcuni comandi trovando su internet e riavviando il PC. Il problema con il Wifi rimane però. Ho provato a collegare con l'ethernet e non si disconnette. Ho postato prima i dati inerenti alla scheda, fatemi sapere se ne servono altri, ho visto che alcune persone hanno risolto il problema ignorando l'iPv6 e modificando alcuni dati che variano di caso in caso.

PS: appena riesco invio i comandi che ho eseguito per risolvere il problema (Errore: BrokenCount >0)

Modifica: ho riavviato, inserito questi comandi e riavviato.

sudo apt-get --fix-broken install
sudo rm /var/lib/apt/lists/* -vf   
sudo apt-get update
sudo apt-get clean  
sudo apt-get autoclean 
sudo apt-get autoremove
sudo dpkg --configure -a 
sudo apt-get update
Cita messaggio
Grazie da:
#8
prova ad eseguire nel terminale:
Codice:
lshw -C network
fornira maggiori info sulla scheda di rete e wifi, compresi i driver in uso. Controlla anche nei repo se sono presenti dei driver per la tua scheda operando la ricerca sulla base dei risultati dei comandi precedenti
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#9
Ciao a tutti!
Sebbene non sia riuscito ancora a risolvere il problema con internet, ho modificato il titolo scrivendo RISOLTO, in quanto il problema principale è sparito eseguendo quella batteria di comandi postata da me prima. Il problema con internet resta, magari provo a fare un nuovo posto e se avete qualche soluzione vi prego di scriverla li. Molte grazie
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)