Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Errore "Remove" - Libre Office
#1

.txt   Errore_Remove .txt (Dimensione: 30,66 KB / Download: 5) Buongiorno,

avendo intenzione di installare la nuova versione di Libre Office 4.4 .... ho intrapreso l'esecuzione, spero ordinata, dei seguenti passi:

1) sudo apt-get remove --purge libreoffice*;

2) Aprire la home, ‘ctrl+h’ per visualizzare le cartelle nascoste, cercare ‘.config’, al suo interno la cartella ‘libreoffice’, quindi eliminare;

3) installazione con i file 'deb' della nuova versione scaricati direttamente dal sito ufficiale di Libre Office.

Ho la versione Majorana di Ubuntu 14.04.02 con Libre Office 4.3.
Nessun PPA di LO inserito.

Eseguo per l'appunto:

"sudo apt-get remove --purge libreoffice*"

e ricevo l'errore (in allegato il dettaglio):

"Si sono verificati degli errori nell'elaborazione:
libreoffice-base
E: Sub-process /usr/bin/dpkg returned an error code (1)"

Ho eseguito anche la funzione "pulisci" con Ubuntu-Tweack ma il programma trova un 'pacchetto obsoleto' che non riesce a rimuovere.
Cosa posso fare per poter risolvere la situazione ?
Come posso eseguire quindi con successo la versione di "remove" della versione di Libre Office che intendo sostituire ?

(N.BSmile Per ordine della procedura che comunque intendo concludere, ho riportato il sistema alla condizione originale.
Come spesso consigliato in questo Forum, prima di qualsiasi operazione che posso considerare critica, salvo sempre lo stato del sistema con "SystemBack". Una volta preso l'errore ho eseguito il ripristino del SO e tutto è tornato come prima.

Grazie  Undecided  Tux
Cita messaggio
Grazie da:
#2
qui hanno risolto con:
sudo rm /var/lib/dpkg/info/libreoffice-base.postrm
fonte: vedi
Cita messaggio
Grazie da:
#3
Grazie DxGiusti,

avevo visto anch'io il link che mi hai indicato.

Pero' avevo preso le distanze da quei comandi perchè i messaggi presenti nel log di cui l'autore offre la soluzione in rete differiscono, non poco, da quelli che invece riporto nel mio log.
Alla fine mi sembra di capire che qualsiasi sia l'origine dell'errore il SO tramite il componente "dpkg" riporta sempre questo msg:

E: Sub-process /usr/bin/dpkg returned an error code (1)

di natura molto, molto generica.

Speriamo sia il mio caso ... no ?
Di solito il forum del sito IstMajorana mi ha sempre portato fortuna !

In questi giorni applichero' la soluzione che mi hai indicato e ti faro' sapere.

Idea sbagliataPer favorePinguino
Cita messaggio
Grazie da:
#4
ma libreoffice base lo hai installato? prova a verificare in gestore pacchetti ( synaptic ).
Cita messaggio
Grazie da:
#5
se scorri l'allegato che hai postato, vedi che l'errore che hai è lo stesso, sul post-removal di quel pacchetto
dai il comando che ti diceva dxgiusti e poi
Codice:
sudo apt-get update && sudo apt-get upgrade
e vedi se hai errori
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#6
Allora DXgiusti,

ho intenzione di provare la strada che mi hai indicato.

Solo per chiarire ...

Ho la versione che di Libre Office che è contenuta di default in Ubuntu 14.04 versione Majorana Remix.
NON HO fatto altro.

Ho solo tentato di rimuovere la versione in uso (4.3) per poter installare la nuova (4.4).
Avendo preso l'errore con il comando "remove" oggetto del post ho riportato il tutto allo stato originale con SystemBack.
Quindi ad oggi è come se avessi la versione immacolata di Ubuntu 14.04 comprensiva degli aggiornamenti permessi dai PPA specificati sempre di default poichè non ne ho mai aggiunto nessuno.

Ringrazio anche l'utente "Tuxino" per il completamento dei comandi.

Credo di aver esaminato i 2 tipi di log quello che in rete propone la soluzione ed il mio.
Sono simili ma l'errore è sostanzialmente diverso.

Infatti nel primo l'origine è:

Nessuna deviazione "deviazione di /usr/lib/libreoffice/share/basic/dialog.xlc in /usr/lib/libreoffice/share/basic/dialog.xlc.noaccess da libreoffice-base", nessuna rimossa.
Nessuna deviazione "deviazione di /usr/lib/libreoffice/share/basic/script.xlc in /usr/lib/libreoffice/share/basic/script.xlc.noaccess da libreoffice-base", nessuna rimossa.
/var/lib/dpkg/info/libreoffice-base.postrm: 31: /var/lib/dpkg/info/libreoffice-base.postrm: Syntax error: end of file unexpected (expecting "fi")
dpkg: errore nell'elaborare libreoffice-base (--remove):
il sottoprocesso vecchio script di post-removal ha restituito lo stato di errore 2


mentre nel mio:

dpkg: attenzione: nel rimuovere libreoffice-common, la directory "/usr/share/icons/gnome/128x128/apps" è risultata non vuota e non viene rimossa
dpkg: attenzione: nel rimuovere libreoffice-common, la directory "/usr/share/icons/gnome/128x128/mimetypes" è risultata non vuota e non viene rimossa


Entrami poi restituiscono il msg d'errore GENERICO:

E: Sub-process /usr/bin/dpkg returned an error code (1)
Cita messaggio
Grazie da:
#7
è lo stesso, il problema è sul file libreoffice-base.postrm dai quei comandi
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#8
vuol dire che hai qualche cosa dentro la cartella ( sul mio ubu 64 bit non è presente ). comunque dai il comando:
sudo apt-get update
e vedi cosa ti dice.
Cita messaggio
Grazie da:
#9
Ho eseguito la sequenza dei comandi indicata nel link segnalato da dxgiusti.
Non ricevuto nessun codice di errore dai comandi di aggiornamento del sistema !
Quindi tutto sembra essere OK e sono riuscito ad installare LO 4.4.0.3 -
Tra l'altro è vero di quello che si legge in rete ... questa versione è nettamente migliore della 4.3 !

Grazie
a
dxgiusti At
tuxino At


Tux
Cita messaggio
Grazie da:
#10
ottimo Smile
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)