Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Errore apt-get: non trova pacchetto ed archivio
#1
Salve ragazzi,
questa mattina, durante l'aggiornamento di sistema, mi si è bloccato tutto e ho dovuto riavviare il pc.
Al riavvio, il sistema funziona, ma se provo ad eseguire
- apt-get + opzioni ,  mi restituisce sempre lo stesso errore:  E: Il pacchetto libpam-systemd deve essere reinstallato, ma non è possibile trovarne un archivio.
- synapitic , oltre a quanto detto per apt-get, mi comunica anche:  E: errore interno nell'aprire la cache (1). Segnala l'errore
Il comando "sudo apt-get update" non mi restituisce errori.
Ho scaricato il pacchetto libpam-systemd.deb ma l'installazione con GDebi si ferma immediatamente con l'avviso: L'indice dei programmi è rovinato.
A questo punto non mi resta che chiedere il vostro aiuto in quanto la mia conoscenza ha ancora dei limiti.
Sistema Operativo installato: Ubuntu 14.04 plus Remix
Allego immagini dei comandi dati con gli errori. (più piccole non erano leggibili)
Sin da ora grazie di tutto.
Geo


Allegati Anteprime
               
Cita messaggio
Grazie da:
#2
In qualche modo ho risolto ed ora non riscontro più l'errore.
Di seguito quanto fatto.

Mi sono accorto che all'interno della cartella /etc/apt non era presente il file souces.list
Quindi
$ sudo software-properties-gtk
ed ho "flaggato" le prime due caselle in "Scaricabile da Internet" Poi chiuso programma.

$ sudo apt-get update
Eseguito senza errori


$ cat -n /etc/apt/souces.list
Visualizzato correttamente il file


$ sudo apt-get upgrade
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Eseguito
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
 linux-headers-3.13.0-78 linux-headers-3.13.0-78-generic
 linux-image-3.13.0-78-generic linux-image-extra-3.13.0-78-generic
Usare "apt-get autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 25,5 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] s
Scaricamento di:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpam-systemd amd64 204-5ubuntu20.18 [25,5 kB]
Recuperati 25,5 kB in 3s (8.264 B/s)      
dpkg: errore nell'elaborare il pacchetto libpam-systemd:amd64 (--configure):
il pacchetto libpam-systemd:amd64 non è pronto per la configurazione
impossibile configurarlo (stato corrente "half-installed")
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt-get autoremove
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
 linux-headers-3.13.0-78 linux-headers-3.13.0-78-generic
 linux-image-3.13.0-78-generic linux-image-extra-3.13.0-78-generic
0 aggiornati, 0 installati, 4 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/25,5 kB di archivi.
Dopo quest'operazione, verranno liberati 271 MB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 268126 file e directory attualmente installati.)
Rimozione di linux-headers-3.13.0-78-generic (3.13.0-78.122)...
Rimozione di linux-headers-3.13.0-78 (3.13.0-78.122)...
Rimozione di linux-image-extra-3.13.0-78-generic (3.13.0-78.122)...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-78-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
run-parts: executing /etc/kernel/postinst.d/zz-extlinux 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.13.0-80-generic...
P: Writing config for /boot/vmlinuz-3.13.0-78-generic...
P: Writing config for Windows 7 (loader) on /dev/sda1...
P: Installing debian theme... done.
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
Generating grub configuration file ...
Found background image: splash-image.png
Trovata immagine linux: /boot/vmlinuz-3.13.0-80-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-80-generic
Trovata immagine linux: /boot/vmlinuz-3.13.0-78-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-78-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Trovato Windows 7 (loader) su /dev/sda1
fatto
Rimozione di linux-image-3.13.0-78-generic (3.13.0-78.122)...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
dkms: removing: virtualbox 4.3.36 (3.13.0-78-generic) (x86_64)

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 4.3.36
Kernel:  3.13.0-78-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
- Uninstallation
  - Deleting from: /lib/modules/3.13.0-78-generic/updates/dkms/
- Original module
  - No original module was found for this module on this kernel.
  - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
- Uninstallation
  - Deleting from: /lib/modules/3.13.0-78-generic/updates/dkms/
- Original module
  - No original module was found for this module on this kernel.
  - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
- Uninstallation
  - Deleting from: /lib/modules/3.13.0-78-generic/updates/dkms/
- Original module
  - No original module was found for this module on this kernel.
  - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
- Uninstallation
  - Deleting from: /lib/modules/3.13.0-78-generic/updates/dkms/
- Original module
  - No original module was found for this module on this kernel.
  - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
update-initramfs: Deleting /boot/initrd.img-3.13.0-78-generic
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.13.0-80-generic...
P: Updating /boot/extlinux/linux.cfg...
P: Writing config for Windows 7 (loader) on /dev/sda1...
P: Installing debian theme... done.
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.13.0-78-generic /boot/vmlinuz-3.13.0-78-generic
Generating grub configuration file ...
Found background image: splash-image.png
Trovata immagine linux: /boot/vmlinuz-3.13.0-80-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-80-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Trovato Windows 7 (loader) su /dev/sda1
fatto
The link /vmlinuz.old is a damaged link
Removing symbolic link vmlinuz.old
you may need to re-run your boot loader[grub]
The link /initrd.img.old is a damaged link
Removing symbolic link initrd.img.old
you may need to re-run your boot loader[grub]
dpkg: errore nell'elaborare il pacchetto libpam-systemd:amd64 (--configure):
il pacchetto libpam-systemd:amd64 non è pronto per la configurazione
impossibile configurarlo (stato corrente "half-installed")
Si sono verificati degli errori nell'elaborazione:
libpam-systemd:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo update-grub
Codice:
Generating grub configuration file ...
Found background image: splash-image.png
Trovata immagine linux: /boot/vmlinuz-3.13.0-80-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-80-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Trovato Windows 7 (loader) su /dev/sda1
fatto

$ sudo apt-get autoremove
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/25,5 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
dpkg: errore nell'elaborare il pacchetto libpam-systemd:amd64 (--configure):
il pacchetto libpam-systemd:amd64 non è pronto per la configurazione
impossibile configurarlo (stato corrente "half-installed")
Si sono verificati degli errori nell'elaborazione:
libpam-systemd:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
Errore ancora presente


$ sudo apt-get install -f
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/25,5 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
dpkg: errore nell'elaborare il pacchetto libpam-systemd:amd64 (--configure):
il pacchetto libpam-systemd:amd64 non è pronto per la configurazione
impossibile configurarlo (stato corrente "half-installed")
E: Sub-process /usr/bin/dpkg returned an error code (1)
Errore ancora presente

$ sudo apt-get install --reinstall libpam-systemd
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 1 reinstallati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/25,5 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
(Lettura del database... 238484 file e directory attualmente installati.)
Preparativi per estrarre .../libpam-systemd_204-5ubuntu20.18_amd64.deb...
Estrazione di libpam-systemd:amd64 (204-5ubuntu20.18) su (204-5ubuntu20.18)...
Elaborazione dei trigger per man-db (2.6.7.1-1ubuntu1)...
Elaborazione dei trigger per ureadahead (0.100.0-16)...
Configurazione di libpam-systemd:amd64 (204-5ubuntu20.18)...
il file libpam-systemd si è installato correttamente.

$ sudo apt-get upgrade
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Eseguito
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

$ sudo apt-get autoremove
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
Ora i comandi apt-get funzionano correttamente ed anche Synaptic.
Grazie a tutti.
Saluti
Geo
Cita messaggio
Grazie da:
#3
ciao. non uso ubuntu e non ti so aiutare, comunque su google se cerco:

libpam-systemd error

trovo una miriade di pagine. in attesa di chi conosce il problema, inizia a leggere, hai visto mai che trovi....?
Cita messaggio
Grazie da:
#4
Ciao dxgiusti,
ben trovato.
Tra il primo ed il secondo post, ho avuto modo di cercare con google possibili soluzioni, ma il mio inglese "basic" non mi ha consentito di capire al 100% quanto trovato.
Quindi mi sono rimboccato le maniche, ...mi sono tirato su anche i peli delle braccia... ed ho provato a risolvere in quasi autonomia.
Ci sono riuscito? Si.
Per c..o? Molto probabile....

E' sempre un piacere leggervi.
Un saluto a tutti.
Geo
Cita messaggio
Grazie da:
#5
si, quando cè un
Codice:
"half-installed"

bisogna reinstallare il pacchetto dell'errore con quel comando

Codice:
sudo apt-get install --reinstall nome-pacchetto
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#6
Ciao tuxino,
confermo quanto da te scritto.
Inizialmente avevo provato a reinstallare il pacchetto da riga di comando, da synaptic ed anche scaricando il relativo pacchetto deb, il tutto con esito negativo.
L'errore che mi dava apt-get e che, oltre a bloccare le operazioni, non capivo era la parte relativa alla mancanza dell'archivio: "...ma non è possibile trovarne un archivio".
Sicuramente quando ho dovuto resettare il pc, in quanto tutto bloccato, ho creato problemi all'archivio software.
Mi ci è voluto un po' di tempo per capire, ma poi ho ripristinato l'archivio software con il comando "sudo software-proprieties-gtk" e dopo sono riuscito ad eseguire il comando "apt-get + opzioni" compresa la installazione del pacchetto libpam-systemed.
Saluti e grazie a tutti.
Geo
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)