Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Errore dpkg: warning: parsing file ... mantainer mancante
#1
Un saluto a tutti e ben ritrovati.
Sono diversi giorni che non riesco a portare a termine l'aggiornamento del sistema in quanto mi trovo questo errore:
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 4444 package 'libvorbisfile3:i386':  missing maintainer
Il problema mi si presenta con "Ubuntu software" (durante aggiornamento di Dike6) sia con "Aggiornamenti software" (aggiornamento del sistema) e sicuramente anche con GDebi durante la installazione di pacchetti .deb (l'installazione non va mai a buon fine).
Ho appena provato ad installare un pacchetto con "Ubuntu software" e questa è la risposta:
installArchives() failed: dpkg: warning: parsing file '/var/lib/dpkg/status' near line 4444 package 'libvorbisfile3:i386': missing maintainer
dpkg: error: parsing file '/var/lib/dpkg/available' near line 35324: missing package name
Error in function:
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 4444 package 'libvorbisfile3:i386': missing maintainer
Stessa cosa anche con Synaptic.
Ho provato ad eliminare staus dalla cartella /var/lib/dpkg/ e recuperato status da /var/backups/ ma nulla è cambiato
Qualcuno ha qualche idea?
Saluti
Geo

Edit: Ubuntu 14.04 plus
Cita messaggio
Grazie da:
#2
prova a usare il file status-old che dovresti avere in /var/lib/dpkg rinomina 
Codice:
sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-old1

Codice:
 sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status

Codice:
sudo dpkg --configure -a

Codice:
sudo apt-get upgrade
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#3
Ciao Tuxino,
avevo già provato senza risultato.
Ma ora ha funzionato al 90%, nel senso che sono riuscito ad aggiornare il sistema e non solo, mi ha anche aggiornato il programma per la firma digitale Dike.
Scrivo al 90% perchè mi riname l'avviso

Codice:
dpkg: attenzione: analisi del file "/var/lib/dpkg/status" vicino alla riga 4444 pacchetto "libvorbisfile3:i386":
maintainer mancante
Di seguito riporto la parte del file status "incrimata", nella riga 4444 non c'è scritto niente (riga vuota prima di "Package: libmono-messaging2.0-cil


Codice:
Package: libvorbisfile3
Status: deinstall ok config-files
Priority: optional
Section: libs
Installed-Size: 81
Architecture: i386
Multi-Arch: same
Source: libvorbis
Version: 1.3.2-1.3ubuntu1
Config-Version: 1.3.2-1.3ubuntu1
Replaces: libvorbis0 (<< 1.0.0)
Depends: libc6 (>= 2.4), libogg0 (>= 1.1.0), libvorbis0a (= 1.3.2-1.3ubuntu1)
Pre-Depends: multiarch-support
Conflicts: libvorbis0 (<< 1.0.0)
Description: The Vorbis General Audio Compression Codec (High Level API)
Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
general-purpose compressed audio format for audio and music at fixed
and variable bitrates from 16 to 128 kbps/channel.
.
The Vorbisfile library provides a convenient high-level API for decoding
and basic manipulation of all Vorbis I audio streams.
Original-Maintainer: Debian Xiph.org Maintainers <pkg-xiph-maint@lists.alioth.debian.org>

Package: libmono-messaging2.0-cil
Se si riesce a risolvere anche questo sono più felice.
Geo
Cita messaggio
Grazie da:
#4
come dice l'errore, manca la riga (campo) Maintainer, prova ad aggiungerla

Codice:
sudo gedit /var/lib/dpkg/status
e raggiungi le righe che hai trovato, riferite al pacchetto libvorbisfile3 e aggiungi la riga Maintainer

Codice:
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
la aggiungi tra

Citazione:Installed-Size: 81
e

Citazione:Architecture: i386
praticamente fai divetare così quella parte

Codice:
Installed-Size: 81
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
fatta la modifica, salva il file e chiudi e ridai

Codice:
sudo dpkg --configure -a


Codice:
sudo apt-get upgrade
EDIT: come dice il messaggio, il problema non è la riga 4444 (dove non cè niente ) ma "vicino alla riga 4444" e nel tuo caso, come ti dice il terminale è il Package libvorbisfile3


Citazione:dpkg: attenzione: analisi del file "/var/lib/dpkg/status" vicino alla riga 4444 pacchetto "libvorbisfile3:i386":
maintainer mancante
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: geovign , geovign , Blackstar
#5
Ora sono felice al 100% ed oltre ...
Grazie Tuxino.
Geo
Cita messaggio
Grazie da:
#6
Prego, ciao
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)