Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Errore montaggio partizione
#1
Ciao a tutti,
ho un po'di partizioni sul disco interno e cercavo di fare in modo che le partizioni venissero montate automaticamente, ho utilizzato il programma "disk" ma qualcosa non ha funzionato:
all'avvio il sistema rileva un errore di montaggio su una partizione e se non lo faccio "skippare" non va avanti.
Andando avanti mi monta le altre partizioni ma una no  non la monta nemmeno se provo a farlo manualmente (vedi schermata errore).
L'unico che per fortuna risce a montarla e' gparted vedi schermata (la partizione e' quella nominata Datum_ext)

Cosa posso fare?
Grazie ciao e buon we!


Allegati Anteprime
       
Cita messaggio
Grazie da:
#2
controlla che le impostazioni per quella partizione nel file /etc/fstab siano corrette (tipo di filesystem, indicazione del device o UUID, opzioni di montaggio, punto di montaggio) controlla anche che la partizione e/o Hd non abbia problemi o settori difettosi.
Linux User # 207701 - L'intelligenza non è non commettere errori, ma scoprire subito il modo di trarne profitto.
Cita messaggio
Grazie da: wfrcrd
#3
Purtroppo non conosco i comandi ....
HO provato a riformattare la partizione, sempre problemi all'avvio ma almeno si riusciva a montare manualmente, ma solo per una volta, poi ha smesso di funzionare e sono nella situazione iniziale...
Cita messaggio
Grazie da:
#4
verifica la partizione con
Codice:
sudo fdisk -l
 se è sempre rilevata come sda4 e poi con partizione smontata prova

Codice:
sudo e2fsck -f /dev/sda4
e

Codice:
sudo resize2fs /dev/sda4
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: wfrcrd
#5
(14-11-2015,09:21 )tuxino Ha scritto: verifica la partizione con
Codice:
sudo fdisk -l
 se è sempre rilevata come sda4 e poi con partizione smontata prova

Codice:
sudo e2fsck -f /dev/sda4
e

Codice:
sudo resize2fs /dev/sda4

Ecco l'output del primo comando :

Codice:
Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 testine, 63 settori/tracce, 121601 cilindri, totale 1953525168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Identificativo disco: 0x00082a67

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   212264959   106131456    7  HPFS/NTFS/exFAT
/dev/sda2       212264960   434657279   111196160    5  Esteso
/dev/sda3       976771072  1953523711   488376320    7  HPFS/NTFS/exFAT
/dev/sda4       434659328   976771071   271055872   83  Linux
/dev/sda5       225921024   434657279   104368128   83  Linux
/dev/sda6       212267008   225918975     6825984   82  Linux swap / Solaris

Le voci nella tabella delle partizioni non sono nello stesso ordine del disco

sembra ci sia un problema nell'ordine...
Cita messaggio
Grazie da:
#6
secondo comando:

Passo 1: Controllo di inode, blocco(i) e dimensioni
Passo 2: Analisi della struttura delle directory
Passo 3: Controllo della connettività di directory
Pass 4: Controllo del numero dei riferimenti
Pass 5: Checking gruppo summary information
DATUM_ext: 11/16941056 files (0.0% non-contiguous), 1111101/67763968 blocks

sembra tutto ok
Cita messaggio
Grazie da:
#7
e il terzo:

resize2fs 1.42.9 (4-Feb-2014)
The filesystem is already 67763968 blocks long. Nothing to do!
Cita messaggio
Grazie da:
#8
hai riprovato a montarla?
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#9
Guarda e' incredibile....

Ho provato a cancellarla riformattarla....

In pratica se uso il programma "dischi" (riformattando etc .. poi riesco a montarla manualmente cliccandoci sopra) ma se apro gparted la voce di "monta" non e' cliccabile

Se invece cancello, ricreo e riformatto da gparted se poi provo a montarla normalmente mi da quell'errore, mentre gparted la monta/smonta tranquillamente

Il problema piu' grosso comuqnue al momento e' che in fase di boot mi da due errori su due UID e se non spingo manualmente la S (skippa) il sistema non parte.

Questa e' la situazione attuale :
/dev/sda1: UUID="4B428150217FA54F" TYPE="ntfs"
/dev/sda3: LABEL="DATUM_ntfs" UUID="2FD16CFB6E12B064" TYPE="ntfs"
/dev/sda4: LABEL="DATUM_ext" UUID="47385ddf-80a9-4e63-a723-1aed4380bad7" TYPE="ext4"
/dev/sda5: UUID="93cff153-8669-4161-9ba8-0cd4f6210525" TYPE="ext4"
/dev/sda6: UUID="76771a8c-4107-435f-9cd0-ec968b90c37e" TYPE="swap"

Il sistema mi da errore su due UUID che non sono presenti tra queste, mi sa che dovro' mettere mano al fstab o come si chiama, dico bene ?

Altra cosa che non capisco... perche' alcune vengono indicate con la label ed altre con la uuid?
Secondo me puo' essere sta cosa della label che incasina , anche perche' se cambio la label mi pare che cambi anche il punto di mount
Cita messaggio
Grazie da:
#10
Questo e' il contenuto di fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda6 during installation
# swap was on /dev/sda5 during installation
UUID=1a645d37-4bbf-4f71-9f25-5472697f1901 none swap sw 0 0
/dev/disk/by-uuid/4B428150217FA54F /mnt/4B428150217FA54F auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
LABEL=DATUM_ntfs /mnt/DATUM_ntfs auto nosuid,nodev,nofail,x-gvfs-show 0 0
UUID=ce03b471-71f0-4d23-9f86-d996b784d0f3 /mnt/ce03b471-71f0-4d23-9f86-d996b784d0f3 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/47385ddf-80a9-4e63-a723-1aed4380bad7 /mnt/47385ddf-80a9-4e63-a723-1aed4380bad7 ext4 nosuid,nodev,nofail,x-gvfs-show,noauto 0 0
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)