Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Files per installazione Virtualbox in Mint 17,3
#1
Prima di mettermi ad installare Virtualbox nella Mint 17.3, prendendoli dal sito della Oracle, ho dato una guardata in Synaptic e li trovo 3 voci: virtualbox-nonfree, virtualbox, e virtualbox-qt.
Le domande che mi vengono sono:
E' meglio prendere i files dal sito di Oracle, o da Synaptic?
Ed in Synaptic bisogna installare tutti  e tre?
E l'extension Pack?

Io pensavo che ricorrendo a Synaptic fosse tutto piu' sicuro e facile, ma mi sembra il contrario.
Grazie a chiunque possa chiarirmi le idee
Cita messaggio
Grazie da:
#2
(15-12-2015,09:47 )dante5351 Ha scritto: E' meglio prendere i files dal sito di Oracle, o da Synaptic?
Di solito la versione presa dal sito del produttore è più aggiornata
Chi sa capire tutto è molto infelice (Maksim Gor'kij)
[Immagine: http://www.istitutomajorana.it/forum2/at...p?aid=7740]
Cita messaggio
Grazie da: dante5351
#3
Grazie per la risposta.
Ma mi incuriosisce capire anche la funzione di Syanptic. Perche' quei 3 files? E poi quando gli sviluppatori mettono dei files nei repositories, non fanno dei controlli? Ovvero i files in Synaptic non sono piu' "sicuri"? O forse piu' compatibili col SO in cui saranno installati?
Cita messaggio
Grazie da:
#4
non saprei, le poche volte che ho provato virtualbox, ho sempre scaricato tutto da qui, la versione piu aggiornata, al link trovi le varie versioni e scelta la versione, ci trovi il deb , le guest addition e l'extension pack.

la versione stabile piu recente che trovi nel link è 5.0.10

la versione che trovi nei repo quasi sicuramente e' piu vecchia.

http://download.virtualbox.org/virtualbox/
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
(15-12-2015,10:23 )dante5351 Ha scritto: Grazie per la risposta.
Ma mi incuriosisce capire anche la funzione di Syanptic...

Il fatto che uno stesso programma venga diviso in più pacchetti è molto frequente in Linux perchè permette di riutilizzare le singole parti del programma in più contesti. Ad esempio virtualbox-qt penso si riferisca ai componenti di VirtualBox che permettono una integrazione con KDE (che usa le librerie QT). Se la tua distro non usa KDE quel pacchetto probabilmente non ti serve.

In tema di sicurezza tra Synaptic ed il sito *ufficiale* del produttore non credo ci siano molte differenze. Invece è vero che la versione che trovi in Synaptic è sicuramente testata ed ottimizzata per il tuo sistema operativo.
Chi sa capire tutto è molto infelice (Maksim Gor'kij)
[Immagine: http://www.istitutomajorana.it/forum2/at...p?aid=7740]
Cita messaggio
Grazie da:
#6
mah, secondo me non è tanto questione di ottimizzazione, in una distro come mint, che usa i repo di ubuntu , che è una distro fixed, cioè che a un certo punto dello sviluppo, non vengono più inseriti pacchetti nei repo, e a parte qualche programma, tutto il resto rimane alla versione ultima inserita e non si aggiorna, è solo un fatto di come è sviluppato il sistema operativo, secondo me è tanto usabile quella del sito quanto quella dei repo, anzi, credo che usare quella del sito, permetta di avere versioni piu recenti e migliorate.

comunque se hai mint, per vedere la versione dei repo
Codice:
apt-cache policy virtualbox
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
(15-12-2015,10:49 )Blackstar Ha scritto: ...In tema di sicurezza tra Synaptic ed il sito *ufficiale* del produttore non credo ci siano molte differenze. Invece è vero che la versione che trovi in Synaptic è sicuramente testata ed ottimizzata per il tuo sistema operativo.
Grazie, questa e' la risposta che mi serve.

Io ho come SO Mint (Mate) 17.3 che e' basato su Ubuntu 14.4; per cui  mi serve la versione di Virtualbox, virtualbox-5.0_5.0.10-104061~Ubuntu~trusty_amd64.deb, che bisogna cercare con un po' di pazienza in quella pagina linkata, o piu' facilmente in quella https://www.virtualbox.org/wiki/Downloads cui si accede dal sito di https://www.virtualbox.org/.
Da Synaptic non c'e' il rischio di sbagliare, pero' la versione e' meno recente, il che normalmente non da' problemi, perche' tanto ci sono gli aggiornamenti.
Visto che ci sono, abuso della tua pazienza con un'ultima domanda: Io ho installato in Windows7 delle VM che risiedono sul disco dati condiviso con Linux. Secondo te le posso usare anche nella VirtualBox che installero' in Mint 17.3, anche se queste Vm sono state create in Windows da una versione ovviamente precedente  di VirtualBox, cioe' una 4.xx.xx?
A naso direi di si', ma certo un parere piu' informato mi sarebbe gradito.
Grazie
Cita messaggio
Grazie da:
#8
la versione dei repo, come ti dicevo non viene aggiornata, resta quella che  e'
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#9
(15-12-2015,11:26 )tuxino Ha scritto: la versione dei repo, come ti dicevo non viene aggiornata, resta quella che  e'

Scusa, ma non ho capito. Io vedo che spesso i pacchetti hanno delle versioni: tant'e' che Synaptic ha due colonne: versione installata e ultima versione, per cui esiste la possibilita' di forzare la versione. Al pacchetto virtualbox corrispondono le versioni  5.0.4, 4.3.34 e 4.3.10
Cita messaggio
Grazie da:
#10
di norma vengono usati ppa esterni per aggiornare VB all'ultima versione ( questo in casa ubuntu, con mint non so come funziona ). io installerei quella di oracle, l'ultima disponibile. come ti ha detto tuxino nei repo il programma non viene aggiornato. cosa diversa per le distribuzioni "rolling" dove anche i programmi ricevono aggiornamenti all'ultima versione disponibile se inseriti in synaptic. se questa politica fosse adottata anche dalle distribuzioni "normali" diventerebbero anche loro in pratica rolling.
edit: googlando ho trovato
http://ubuntuhandbook.org/index.php/2015...-04-12-04/
dovresti riuscire ad aggiornare dai tuo repo VB all'ultima versione.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)