Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Funzione le parentesi danno errore
#1
Ciao

perchè (OpenOffice) se nel testo da cercare ci sono parentesi da risultato errore #N/D  ??

allegato esempio


Allegati
.ods   Errore Parentesi.ods (Dimensione: 14,99 KB / Download: 4)
caldo è bello, dolce è buono se ci metti anche un sorriso sei perfetto
Cita messaggio
Grazie da:
#2
Non ne sono sicuro, ma credo che sia perchè sono simboli riservati alle formule, a me è capitata una cosa simile con il+.
Prova a sostituire la tua formula con questa. In F4 da copiare in basso

Codice:
=SE(SOSTITUISCI(SOSTITUISCI(E4;"(";"");")";"")="";"";CERCA.VERT(SOSTITUISCI(SOSTITUISCI(E4;"(";"");")";"");SOSTITUISCI(SOSTITUISCI($B$3:$C$24;"(";"");")";"");2;0))
È una formula matriciale e va confermata con ctrl+maiuscolo+invio (non con il solo invio)
mandi...Eugenio
Cita messaggio
#3
Forse ho trovato il problema. Te lo dico come l'ho risolto in Libreoffice, non so se è uguale in openoffice. Vai su strumenti>opzioni>libreoffice>calcola e spunta permetti caratteri Jolly nelle formule.
Così facendo vedrai che si aggiustano tutti tranne i primi due, dove il testo non coincide.


Allegati Anteprime
   
mandi...Eugenio
Cita messaggio
Grazie da: Alessandro Moroni
#4
GRAZIE, EU66
Con la spunta funzione perfettamente Smile Smile
caldo è bello, dolce è buono se ci metti anche un sorriso sei perfetto
Cita messaggio
Grazie da:
#5
Ottimo!
mandi...Eugenio
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)