Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Gestire permessi
#1
Buonasera.
Mi sono appena accorto di questo problema:
Ho i dati su un disco separato formattato in ntfs al quale posso accedere tanto da Windows7 che da Mint Mate plus remix 17.1, il quale viene montato automaticamente all'avvio in mnt/sdb1. Il problema e' che tutti i file e le cartelle risultano con root come proprietario e tutti con la spunta su "consenti l'esecuzione del file come programma", il che ha come conseguenza che per tutti i files di testo che ci vado a salvare, quando li apro, anziche' aprirsi immediatamente, si apre la finestra che chiede se eseguire il file nel terminale o solamente mostrarlo; per cui devo dire di mostrarlo solamente.
E' solo una seccatura che ho cercato di eliminare aprendo la cartella superiore come amministartore, levare la spunta e chiudere le proprieta'.
Pero' alla successiva riapertura tutto e' come prima, cioe' Mint non accetta la modifica, cosi' come non accetta modifiche al proprietario. Io credo che questo dipenda dal fatto che il disco e' montato all'avvio.
Pero' mi resta la domanda: come fare a modificare i permessi in questa situazione? E vorrei cogliere l'occasione per imparare qualcosa in piu' di Linux, per cui grazie a chi potra' fornirmi lumi
Cita messaggio
Grazie da:
#2
se li mostra vuol dire che i permessi li hai. se questo succede con i file di testo .txt e tu hai mint con mate, il gestore è caja.
vai in sistema, centro controllo, gestione file, comportamento. in permessi metti mostra quando li apri.
questo con il mio pclinuxos-mate, dovrebbe essere simile al tuo ( se hai mate )
Cita messaggio
Grazie da:
#3
Grazie per la risposta dxgiusti.
Ho messo la spunta su mostra, e il file di testo si e' aperto. Pero' in questo modo ho ottenuto che si apre in modalita' testo anche qualsiasi file eseguibile (ho provato con un file .sh).
Io volevo invece eliminare la spunta che rende eseguibile quel file che contiene testo non eseguibile, che oltretutto mi sembra la soluzione piu' pulita. Inoltre ho notato che se io creo un file di testo nel desktop, cioe' in Linux, questo file non ha la spunta come eseguibile; se poi lo sposto sul disco dati, allora acquista la spunta, e cambia proprietario, come tutti gli altri 38.000 files dell'HD. Francamente mi sembra un comportamento incomprensibile e poco giustificabile.
Percio' chiedevo come si puo' fare a cambiare i permessi. Forse agendo da terminale? Con quali comandi?
Cita messaggio
Grazie da:
#4
come ti ho già detto se puoi copiare, aprire, cancellare, incollare i file come utente normale vuol dire che i permessi li hai.
a me chiede solamente se il file è un eseguibile ( .sh ) se è un file di testo ( .txt ) lo apre senza problemi. i tuoi che estensione hanno?
puoi anche andare su di un file con una determinata estensione, click dx proprietà, apri con ed imposti il programma per aprire. tutti i file con quella estensione useranno quanto hai scelto.
Cita messaggio
Grazie da:
#5
Dante, da terminale prova
sudo caja
Poi scrivi la pass e dai invio.

Apri il file qui e accederai ai permessi.
Freedom isn't free-La libertà non è gratuita.
Per cercare su questo forum: site:istitutomajorana.it/forum2/ [termini della ricerca]
oppure http://www.istitutomajorana.it/informati...lo-forum-2
Cita messaggio
Grazie da:
#6
@ dxgiusti: certo che i permessi li ho. Il problema e' che anche i file di testo non eseguibili hanno in proprieta' la spunta di eseguibili, e quindi vengono trattati allo stesso modo. I file su cui ho fatto la prova sono .txt e .sh, entrambi si aprono con un editor di testo, pluma, notepad e LO writer. E quindi hanno stesso comportamento che io definisco: apri con editor, esegui o chiedi (naturalmente il file .txt non esegue niente). Poi tu dici: "tutti i file con quella estensione useranno quanto hai scelto" questo mi sa tanto di Windows; Linux non gli importa un granche' dell'estensione, riconosce l'applicazione con cui aprire i files dalla loro struttura, mi sembra.
Pero', se riuscissi ad eliminare quella spunta ai file .txt risolverei.

@ berto: ho provato ad aprire come amministratore la cartella superiore a quella dove' il file .txt, ed anche la direstory mnt; ho provato a dare da terminale  sudo chmod -x file.txt ma non c'e' stato niente da fare, non mi fa levare la caratteristica di eseguibile. Quando potro' spegnere Windows7 che sto usando adesso per registare uno streaming, faro' la prova che mi hai consigliato; ma sinceramente penso che, siccome chiaramente il problema nasce dal fatto che il disco e' montato all'avvio, i permessi sono stabiliti dalla root e sono immodificabili finche' il SO lavora. Forse se mi creassi un utente root....
Cita messaggio
Grazie da:
#7
non è che hai sbagliato qualcosa nelle impostazioni di montaggio automatico della partizione dati? in ntfs non dovrebbe darti problemi anche perchè per quanto ne so, linux non gestisce i permessi su ntfs (file system propietario) 

Avvia mint e posta l'output di questi

Codice:
sudo blkid


Codice:
cat /etc/fstab


Codice:
ls /media
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#8
inizia con impostare
   
come ti ho detto tu hai gia tutti i permessi. non serve nessun chmod e nessun chown. lascia stare i flag di esegui come programma. va bene come li trovi. prova con il file .txt, poi passiamo ai file .sh
Cita messaggio
Grazie da:
#9
@ dxgiusti: o tu hai la bacchetta magica o io ieri devo aver fatto una gran confusione (probabile, anzi certo. Chiedo venia).
Ho messo la spunta su Mostrare... e i file di testo li apre immediatamente, cosi' come i file .sh, per eseguire i quali bisogna dare ./ nel terminale (correggimi se sbaglio); oppure, usando per prova gli scripts di Caja che si trovano in /home/dan/.config/caja/scripts, fare clic dx sul file sul quale si vuole usare lo script.
Quindi e' tutto a posto, il che ha come conseguenza che ieri dovevo aver fatto confusione tra i file .bat di Windows, che si eseguono con 2click su file.bat, con i file .sh di Linux. Non e' neanche escluso che possa aver fatto le mie prove su un file .sh (o .py che dovrebbe essere lo stesso) non funzionante.
Pero' scusa la cocciutaggine: non e' anomalo che se io creo un file di testo es prova, con o senza .txt, in una directory di Mint, quindi formattata in ext4, il file non ha i permessi di esecuzione; se invece lo creo nel 2° Hd, formattato in ntfs, allora li ha', cioe' ha la spunta maledetta?
2a cocciutaggine: il file /home/dan/.config/caja/scripts/Cerca nella cartella corrente, che ho usato per fare delle prove stamane; se seleziono Mostrare.... si apre con gedit; se invece seleziono una cartella e poi lo script, non succede niente; se ci clicco sopra idem; se apro un terminale nella cartella scripts, il risultato e' :   dan@dan ~/.config/caja/scripts $ ./Cerca nella cartella corrente
bash: ./Cerca: File o directory non esistente
.  Se seleziono Eseguire.. il terminale mi da'  dan@dan ~/.config/caja/scripts $ ./"Cerca nella cartella corrente"
./Cerca nella cartella corrente: riga 3: gnome-search-tool: comando non trovato.
 P.S. Questo l'ho risolto da solo: gnome-search-tool non era installato

@tuxino: allego il file coi comandi da terminale che hai chiesto, se serve ancora
@berto: fatta la prova: non funziona


Allegati Anteprime
   
Cita messaggio
Grazie da:
#10
prova così, smonta la partizione sdb1 se è montata, poi crea il punto di mount in /media

Codice:
sudo mkdir /media/Dati
poi apri /etc/fstab con privilegi

Codice:
sudo pluma /etc/fstab
e metti il cancelletto # all'inizio della riga /dev/sdb1 e poi aggiungi questa in fondo al  file

Codice:
UUID=76D410C5D410898F /media/Dati ntfs-3g uid=1000,silent,umask=000,locale=it_IT.utf8 0 0

Fatte le modifiche, salva il file e chiudilo e dai

Codice:
sudo mount -a
dovresti avere sdb1 montata, in caso prova anche un riavvio
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)