Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Grub (molto) capriccioso
#1
Buongiorno. Chiedo il vostro aiuto per risolvere un problema con l'avvio del sistema operativo, in particolare con il grub.
In sda1 ho una partizione dedicata di boot tipo UEFI. In sda2 è installato Ubuntu 15.04, cui ho affiancato sullo stesso disco sda altri sistemi operativi linux, senza avere problemi fino a quando ho eseguito un upgrade di Linux Mint da 17.1 a 17.2.
All'accensione del PC esce infatti ora la scritta  "grub minimal bash-like..." su sfondo nero, e l'unica cosa che posso fare è dare "reboot".
Ho provato a dare il comando "boot" ma mi dice che il sistema deve prima caricare il kernel.
Dopo il reboot comunque premendo il tasto F11, sulla finestra di scelta posso quindi posizionarmi sulla indicazione Ubuntu (ovvero se preferisco su penna USB etc.) e di seguito ottenere il "grub" di Ubuntu in sda2 e scegliere tra i sistemi installati.
Ho effettuato vari tentativi con boot-repair-disk e con l'operazione di "chroot" da live, seguendo le indicazioni dei forum, senza risultato!
Poichè Boot Info Script di Boot-Repair mi fornisce questo Info Summary  => No boot loader is installed in the MBR of /dev/sda e se dò il comando "boot" mi chiede un kernel, mi è venuto il dubbio che la soluzione possa essere in una risposta che ho letto qui [http://askubuntu.com/questions/546839/gnu-grub-minimal-bash-like-line-editing-screen-displays-before-the-usual-grub-s] quella indicata come "meno probabile", e che riporto completa
Citazione:You've got two GRUB instances; one of the (boots first) is broken, the other one is OK.
Two possible scenarios.
   Each of HDDs has GRUB installed. System firmware trying to boot from one HDD (order usually defined by firmware settings), but it's GRUB installation is broken (you got just GRUB shell). After you exiting (typing exit) this GRUB instance, firmware gets control back and try to boot from another HDD, which has working GRUB installation (boot menu shown).
   (Less probable) Both GRUB instances located at one HDD: one is started from "EFI System partition", the other one - from "BIOS boot partition".
Common solution is to set firmware to start boot from the other GRUB (or HDD depending on your firmware settings). (In case you need more detailed steps to change boot order, please describe how your system firmware boot order settings look like.)

As a supplement, I'd recommend to cleanup removing broken GRUB instance and make sure that working GRUB is located at HDD with Ubuntu. (In case you need more detailed steps, please post each HDD partition table.)
Ammesso che sia così, come faccio a settare il firmware per far partire il boot dal grub "operativo"?
Grazie dell'attenzione!
Cita messaggio
Grazie da:
#2
premetto che non ho nessuna esperienza di avvi con sistemi gestiti da uefi. ti dico solo casa farei se fosse il mio. cercherei di avviare usando supergrubdisk:
http://www.supergrubdisk.org/super-grub2-disk/
se riesci ad entrare ed avviare il tuo sistema ( mint ) nel terminale proverei ad aggiornare il grub:
sudo update-grub
questa è la procedura che con le tabelle msdos ( avvio su mbr ) funzionava. con tabelle gpt ed avvio gestito da uefi non saprei. prova
Cita messaggio
Grazie da:
#3
Grazie dxgiusti. Come accennato riesco in realtà ad entrare nei sistemi operativi  installati (da tastiera all' avvio premo F11 che mi porta ad una schermata con varie opzioni, compresa una "Ubuntu" che mi consente di accedere a sua volta al grub del sistema principale montato e mi da' di conseguenza la possibilità di scegliere se avviare questo o gli altri). Ho provato quanto da te suggerito senza risultato. Credo che il problema stia più ... a monte. Spero che qualche esperto del Grub Uefi passi da queste parti e mi dica la sua! Intanto grazie a te per l'attenzione.
Cita messaggio
Grazie da:
#4
Secondo me è sufficiente impostare dalla pagina di Setup del BIOS il disco con Linux come disco di BOOT
Cita messaggio
Grazie da:
#5
Grazie Patel. No, niente da fare ... certo se Linux ha qualcosa di antipatico, quello è il GRUB!
Cita messaggio
Grazie da:
#6
(07-07-2015,17:27 )frananc Ha scritto: Dopo il reboot comunque premendo il tasto F11, sulla finestra di scelta posso quindi posizionarmi sulla indicazione Ubuntu (ovvero se preferisco su penna USB etc.) e di seguito ottenere il "grub" di Ubuntu in sda2 e scegliere tra i sistemi installati.
non ho capito se da lì puoi avviare quello che desideri, se così è il mio consiglio rimane valido
Cita messaggio
Grazie da:
#7
Scusa Patel se sono stato poco chiaro. Confermo che riesco ad entrare (premendo F11) in una finestra che mi permette di posizionarmi (mi vengono mostrate varie opzioni, tra cui Windows e Fedora, che non ho installati ....) su una stringa "Ubuntu" cliccando la quale mi viene mostrato il grub di Ubuntu da me utilizzato come Sistema Operativo principale. Del pari tra le altre stringhe c'è quella del set up. Sono quindi riuscito a provare quanto da te suggerito, senza ottenere il ripristino del grub UEFI
Cita messaggio
Grazie da:
#8
F11 permette di scegliere la periferica di boot, ma questa scelta non viene memorizzata, per ottenere una scelta definitiva devi entrare nel setup premendo il tasto Canc all'avvio invece di F11.
Cita messaggio
Grazie da: frananc
#9
               
Innanzitutto grazie della pazienza ... Poiché una immagine vale più di mille parole, io ci provo così!
Cita messaggio
Grazie da:
#10
Uefi harddisk ubuntu deve diventare la opzione 1
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)