Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Installare LibreOffice
#1
Ciao, buona serata a tutti!
Ho un problema con LibreOffice sul mio pc Dell, qualcuno può darmi una mano a risolverlo?

Penso che raccontarvi com'è andata la cosa potrebbe aiutarvi a capire il problema.
Alcuni giorni fa LibreOffice ha iniziato a darmi dei problemini. Per esempio, quando volevo cambiare a font diverso, scegliendo dal menu a tendina, il programma si chiudeva e poi non riuscivo più ad aprirlo, a meno che non riavviassi il pc (e allora continuava a fare sempre lo stesso tiro).
La versione che avevo installata era 5.2, ma Synaptic non mi offriva aggiornamenti (il che mi è sembrato strano, visto che ora c'è la versione 6.1.2). Ho pensato di rimuoverlo e reinstallarlo, magari installando la versione più recente. E qui sicuramente ho sbagliato, ho fatto così:ho digitato libreoffice nel cerca di Synaptic, e tutti i file che mi sono venuti relazionati con libreoffice gli ho rimossi...   non so come abbia potuto procedere così, ora mi rendo conto che è stato un errore, ma al momento mi è sembrato che così avrei rimosso il programma che stava dando problemi e i suoi diversi plug-in, ecc, e che dopo sarebbe bastato reinstallarli...
Il problema è che libreoffice non c'è più tra i pacchetti che Synaptic mi offre, e nemmeno gli altri pacchetti che ho rimossi, e non capisco perché. L'archivio dei pacchetti o repositori selezionato in Synaptic è il primo, quello ...ftp.nluung.nl.... che è quello che veniva segnato in modo predefinito.


Visto che non sapevo come risolvere questo problema, ho cercato di tagliare la testa al toro, scaricandolo direttamente dal sito di libreoffice: https://it.libreoffice.org/download/libreoffice-fresh/, ma dopo il download quando procedeva all'installazione, qualcosa andava storto e non riusciva ad installarlo. La stessa cosa accadeva quando tentavo di installarlo da LibreOffice Manager.

Allego le schermate di alcuni dei messaggi di errore che sono venuti fuori, magari vi può aiutare a capire come fare.
Vi ringrazio dai suggerimenti. Ho letto la discussione in questo forum su un problema analogo al mio qui:
http://www.istitutomajorana.it/forum2/Th...ibreoffice
Non ho capito il suggerimento dato in quella discussione da dxgiusti. Non so cosa vuol dire ne come si fa a "commentare le righe", visto che anche a me da quel messaggio di comando errato per quei comando alle righe 3 e 4.
Scusate che sia stato prolisso, ma ho voluto mettere insieme tutta l'informazione.


Allegati Anteprime
           
Cita messaggio
Grazie da:
#2
Gli errori nospoof bloccano l'arrivo di alcuni pacchetti in PcLinuxOs.

Qui avevo scritto come risolvere passo-passo, e il significato su commentare/decommentare una riga.
> http://www.istitutomajorana.it/forum2/Th...#pid128684

Prima risolviamo questo, poi vediamo per il resto.
Cita messaggio
Grazie da: damaso , damaso
#3
Benissimo, l'ho scaricato con il Manager ed è andato tutto a buon fine.
Ora anche su Synaptic mi segna i pacchetti di libreoffice che sono stati installati. Mi domando però, se in futuro mi offrirà gli aggiornamenti...
Grazie mille!
Cita messaggio
Grazie da:
#4
Prego, tanto meglio se hai risolto tutto subito.

Si è normale che Synaptic ti segnali l'installazione, lo fa sia che tu lo installi con l'apposito plug lomanager, sia che fai un'installazione manuale.

Per gli aggiornamenti dipende appunto da come l'hai installato e dal sistema che usi:
per Uplos (cioè PCLinuxOs a 32-bit)
l'ultima versione sarà comunque la 6.2, poi fine supporto.***
per PCLinuxOs:
-  con LibreOffice installato con lomanager gli aggiornamenti saranno sempre proposti.
- per PCLinuxOs con LibreOffice installato manualmente, dovrai installare gli aggiornamenti manualmente. Non ci saranno aggiornamenti proposti, ma il programma rimarrà sempre quello. Naturalmente basta cancellare la versione installata e usare il plug che gli aggiornamenti torneranno a farsi "sentire".

fonte*** https://www.lffl.org/2018/10/libreoffice...2-bit.html
Cita messaggio
Grazie da:
#5
Quindi se è il caso, ricordo il
http://www.istitutomajorana.it/forum2/Th...nel-Titolo
Cita messaggio
Grazie da: damaso
#6
Quando c'e' un aggiornamento di libreoffice in synaptic ti verra' presentato un aggiornamento per lomanager. Una volta uscito da synaptic, lancia lomanager (in KDE lo trovi in Software Center->LibreOffice Manager). Il programma si accorge se esiste una nuova versione, rimuove la precedente ed installa la nuova.

Ciao, Mauro
CPU: Intel Core i7-5820K (Haswell rev.2)
nVidia GeForce GTX 750 (drv 390.87),  16GB DDR4 RAM
‎Intel C610/X99 HD Audio Controller
Intel I210 Gigabit Network Connection
Supermicro C7X99-OCE MBoard
KDE Plasma:5.14.3 Frameworks:5.52.0 Apps:18.08.3
X.org:1.19.6 Qt:4.8.7/5.11.2
Kernel 4.18.18-pclos1
Cita messaggio
Grazie da: damaso , damaso
#7
Ok, grazie mille ragazzi! Avevo bisogno di risolvere presto questo problema perché devo lavorare con LO.
Ora ho capito anche quello che riguarda gli aggiornamenti. Il mio SO è a 64 bit, quindi spero che sia aggiornato ancora a lungo.
Metterò [RISOLTO]. Grazie anche del link perché non mi ricordavo più come si faceva ad inserirlo!
Ho alcuni altri problemini da risolvere, ma saranno oggetto di un'altra discussione. Forza Linux e Pclinuxos!
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)