Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Installare almeno 2 SO su un portatile con UEFI
#1
Buonasera a tutto il forum,

in passato alcuni di voi mi aiutarono a risolvere altre situazioni e spero che anche stavolta possiate darmi una mano.
Premetto che ho già chiesto aiuto ad altro forum, ma senza aver risolto almeno per ora.
Il problema consiste nel non riuscire a installare 2 sistemi operativi su un unico HD meccanico: da oltre un mese sto cercando di mettere sia lubuntu 18.04 lts che Debian9, ma ogni volta salta fuori un problema diverso; in passato ho già installato versioni più vecchie di entrambi i SO su un'altra macchina e non ho avuto tutti questi grattacapi!! Il vecchio computer aveva il bios, questo nuovo usa l'UEFI e pertanto mi sono letto a più riprese le varie guide in proposito e le raccomandazioni nel disabilitare i vari secureboot e modalità csm, prima di procedere all'installazione. Ho tentato in vari modi ,manuale/automatica, ma alla fine il miglior risultato l'ho ottenuto installando solo Debian 9 in modalità automatica(prima però ho fatto parecchi tentativi e molte formattazioni). In questo modo ho comunque degli errori in avvio ma almeno il SO funziona. Per quanto riguarda Lubuntu invece pare che non ci sia verso, perchè ad ogni mio tentativo di installarlo in una partizione dedicata e in manuale, il SO viene installato si, ma al riavvio nessuno dei 2 può essere scelto!! Problemi di grub sembrerebbe, e allora giù di nuovo con altre guide che parlano di questo, ma alla fine mi ritrovo sempre da capo: o un solo SO o 2 installati ma inutilizzabili.
Se adesso inserisco il cd live di lubuntu, in avvio (prima di caricarlo) mi mostra 2 errori che mi dava anche quando l'avevo installato e precisamente questi:

Nov 07 10:30:57 lubuntu kernel: Couldn't get size: 0x800000000000000e
Nov 07 10:30:57 lubuntu kernel: MODSIGN: Couldn'
t get UEFI db list
Nov 07 10:30:57 lubuntu kernel: Couldn't get size: 0x800000000000000e


quindi mi sono anche chiesto se potesse essere una non compatibilità tra questa versione di lubuntu e l'UEFI....voi che dite?
Cita messaggio
Grazie da:
#2
Bisogna che acquisti familiarità con le opzioni che l'UEFI offre, cioè guardare nel BIOS come sono messe le opzioni relative al boot (uefi o mbr) e la priorità degli HD.

Tieni presente che ci sono differenze anche sostanziali su come l'UEFI viene implementato nel BIOS dei vari PC. Differenze fra marca e marca e pure fra modello e modello della stessa marca.

Alcuni (pochi) prevedono addirittura che il "secure boot" debba essere disabilitato da Windows (che di regola è preinstallato) e non basta disabilitarlo dal BIOS. Potrebbe essere il tuo caso.

Avvia una live (qualunque) oppure dal sistema operativo funzionante e posta
Codice:
sudo fdisk -l
sudo efibootmgr -v
inxi -Fxz
Il pacchetto inxi lo dovrai installare.

E posta anche marca e modello del PC.
Cita messaggio
Grazie da:
#3
(14-11-2018,17:37 )andrea111 Ha scritto: Bisogna che acquisti familiarità con le opzioni che l'UEFI offre, cioè guardare nel BIOS come sono messe le opzioni relative al boot (uefi o mbr) e la priorità degli HD.

Tieni presente che ci sono differenze anche sostanziali su come l'UEFI viene implementato nel BIOS dei vari PC. Differenze fra marca e marca e pure fra modello e modello della stessa marca.

Alcuni (pochi) prevedono addirittura che il "secure boot" debba essere disabilitato da Windows (che di regola è preinstallato) e non basta disabilitarlo dal BIOS. Potrebbe essere il tuo caso.

Avvia una live (qualunque) oppure dal sistema operativo funzionante e posta
Codice:
sudo fdisk -l
sudo efibootmgr -v
inxi -Fxz
Il pacchetto inxi lo dovrai installare.

E posta anche marca e modello del PC.

Dunque

Codice:
root@dhcppc1davenz:/home/davenz# sudo fdisk -l
Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: AB6CA96E-9510-4D00-A272-CD40F77B637A

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1050623   1048576   512M EFI System
/dev/sda2    1050624 968579071 967528448 461,4G Linux filesystem
/dev/sda3  968579072 976771071   8192000   3,9G Linux swap


Codice:
root@dhcppc1davenz:/home/davenz# sudo efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000
Boot0000* debian    HD(1,GPT,df16ccc3-38ab-4e2b-ae2a-123999f41a3e,0x800,0x100000)/File(\EFI\DEBIAN\GRUBX64.EFI)


Codice:
root@dhcppc1davenz:/home/davenz# inxi -Fxz
System:    Host: dhcppc1davenz Kernel: 4.9.0-8-amd64 x86_64 (64 bit gcc: 6.3.0)
          Desktop: Xfce 4.12.3 (Gtk 2.24.30)
          Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: laptop System: ASUSTeK product: X540SAA v: 1.0
          Mobo: ASUSTeK model: X540SAA v: 1.0
          UEFI: American Megatrends v: X540SAA.304 date: 01/20/2017
Battery    BAT0: charge: 31.7 Wh 100.0% condition: 31.7/33.2 Wh (96%)
          model: ASUSTeK X550A26 status: Full
CPU:       Dual core Intel Celeron N3060 (-MCP-) cache: 1024 KB
          flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
          clock speeds: max: 2480 MHz 1: 2240 MHz 2: 2223 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
          bus-ID: 00:02.0
          Display Server: X.org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
          tty size: 80x24 Advanced Data: N/A for root
Audio:     Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
          driver: snd_hda_intel bus-ID: 00:1b.0
          Sound: Advanced Linux Sound Architecture v: k4.9.0-8-amd64
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
          driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
          IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
          Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
          driver: ath9k bus-ID: 03:00.0
          IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (1.7% used)
          ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB temp: 28C
Partition: ID-1: / size: 454G used: 4.4G (2%) fs: ext4 dev: /dev/sda2
          ID-2: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 60.0C mobo: 49.0C
          Fan Speeds (in rpm): cpu: 3400
Info:      Processes: 141 Uptime: 3:15 Memory: 724.1/3860.2MB
          Init: systemd runlevel: 5 Gcc sys: N/A
          Client: Shell (bash 4.4.121) inxi: 2.3.5


N.B: il portatile è stato comprato senza windows, ossia freedos.
Il portatile è un ASUS x540sa
Cita messaggio
Grazie da:
#4
Dal tuo errore postato sopra e il fatto che hai un UEFI American Megatrends, ho trovato questo:

Citazione:The errors seem to be related to an attempt to import UEFI keys for Secure Boot.
I do not have Secure Boot enabled in my BIOS but do only boot in UEFI.
I have a SuperMicro board with American Megatrends BIOS Version 2.2
I was able to stop the errors simply by changing a setting in the BIOS from [Customized] to [Standard] for Secure Boot Mode.
The Customized setting allows you to modify the secure boot keys manually. The Standard just sets the default keys.
Note: This fixed my error even though I previously had Secure Boot [Disabled] in BIOS settings.

Security -> Secure Boot -> Secure Boot Mode -> [Standard]

che in almeno 2 casi ha risolto il problema.

via:
https://ubuntuforums.org/showthread.php?t=2380700


In altri casi (con Bios/Uefi differenti), col kernel superiore al 4.12 richiede la disabilitazione del Secure Boot, a causa di un noto bug.

da:
https://medium.com/@maniac.tw/linux-bug-...a014b7ed54
Cita messaggio
Grazie da:
#5
Da quel che hai postato tutto è OK. Sembra certo che il problema sia il secure boot che ti resta attivo.

Verificato quanto dice sharksux?

Ho passato in rassegna un paio di installazioni di linux su quel portatile e nessuna segnalava problemi. Ma potrebbero esserci differenze fra una versione e l'altra.
La modalità CSM mantienila disabilitata e installa sempre in UEFI.

Tieni presente anche che alcuni BIOS UEFI, per rendere effettiva la disabilitazione del "secure boot", richiedono la creazione di una password per entrare nel BIOS .

Ti direi di tentare l'installazione della 16.04, ubuntu, non lubuntu, su quel portatile dovrebbe girare alla grande.
Cita messaggio
Grazie da:
#6
Intanto grazie ad entrambi per l'interessamento, poi riguardo il secure boot avendolo già disabilitato, posso provare a cambiare l'mpostazione in standard e poi in personalizzata se non dovesse andare. Posso poi verificare se tutto va bene inserendo sempre il cd live, quindi senza installarlo, e notando se i 2 errori spariscono. Ho scelto debian per la stabilità e la sicurezza, e l'utilizzo di lubuntu mi è necessario quando devo fare alcune operazioni bancarie, tipo bonifici o cose del genere: i componenti java a volte mi creano problemi su debian, mentre su lubuntu non mi abbandonano mai. Il mio portatile non è potente e mi piace tenerlo il più leggero possibile, per questo utilizzo sempre ubuntu con lxde (lubuntu).
Cita messaggio
Grazie da:
#7
Il secure boot disabilitato non mi permette di accedere ad altre schermate; abilitandolo invece arrivo fino a qui, ma poi non so come muovermi....temo qualche disastro. Osservate le immagini


Allegati Anteprime
           
Cita messaggio
Grazie da:
#8
L'opzione di impostare il secure boot in standard non c'è?

Quale è la successione delle schermate?
Si parte da quella con "secure boot menu" e poi come prosegue.

La prima prova da fare è la più semplice, rapida e indolore: imposta una passwor amministratore e salvi -- rientri nel BIOS (dovrai dare la password) e controlli che il secure boot sia sempre disabilitato -- chiudi e tenta il riavvio di una live: se non ti dà il solito errore hai risolto, altrimenti si procede con qualcos'altro.
Cita messaggio
Grazie da:
#9
(15-11-2018,22:46 )andrea111 Ha scritto: L'opzione di impostare il secure boot in standard non c'è?

Quale è la successione delle schermate?
Si parte da quella con "secure boot menu" e poi come prosegue.

La prima prova da fare è la più semplice, rapida e indolore: imposta una passwor amministratore e salvi -- rientri nel BIOS (dovrai dare la password) e controlli che il secure boot sia sempre disabilitato -- chiudi e tenta il riavvio di una live: se non ti dà il solito errore hai risolto, altrimenti si procede con qualcos'altro.

Il tentativo passw amministratore non ha funzionato, ma credo sia normale perchè per l'ordine delle schermate dopo "secure boot menù" viene quella con in cima la scritta in bianco "Enroll all Factory Default Keys".
Vedo di togliere la passw amministratore e poi come proseguo?
Cita messaggio
Grazie da:
#10
(16-11-2018,09:36 )Davidecaffe Ha scritto:
(15-11-2018,22:46 )andrea111 Ha scritto: L'opzione di impostare il secure boot in standard non c'è?

Quale è la successione delle schermate?
Si parte da quella con "secure boot menu" e poi come prosegue.

La prima prova da fare è la più semplice, rapida e indolore: imposta una passwor amministratore e salvi -- rientri nel BIOS (dovrai dare la password) e controlli che il secure boot sia sempre disabilitato -- chiudi e tenta il riavvio di una live: se non ti dà il solito errore hai risolto, altrimenti si procede con qualcos'altro.


Il tentativo passw amministratore non ha funzionato, ma credo sia normale perchè per l'ordine delle schermate dopo "secure boot menù" viene quella con in cima la scritta in bianco "Enroll all Factory Default Keys".
Vedo di togliere la passw amministratore e poi come proseguo?

Come non detto: una volta impostata la password non si può più togliere a meno di intervenire via software o via hardware:
tramite "cmospwd",programma di facile uso, sarebbe possibile ma ahimè la sua efficacia è valida solo per pc fissi (l'ho anche provato)
La strada hardware è semplice, perchè basterebbe aprire il laptop e rimuovere una piccola batteria piatta che alimenta il cmos......
....peccato che il computer sia nuovo e così facendo perderei la garanzia dei 2 anni, quindi preferisco tenermi il bios così, in fondo è sufficiente ricordarsi la passw Sfascio 
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)