SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Installare e configurare plank
#31
Perfetto.
E' per aggiungere "configura your computer" alla dock
Cita messaggio
Grazie da:
#32
guarda su kde plank non ce l'avevo, ho provato a installarla e in effetti se si lancia configure your computer, va si nella dock, ma ci resta solo fino a quando è aperto il tool e non compare "mantieni sulla dock", non so il perchè non venga gestito come gli altri programmi, comunque ho risolto copiando il .desktop di "configure your computer" in /home/utente/.local/share/applications e ti trovi l'icona in quel percorso e poi la trascini sulla dock.

in quel modo me la fa fissare

loggati come root
Codice:
su -
e poi copia pclinuxos-drakconf.desktop nel percorso che ti dicevo
Codice:
cp /usr/share/applications/pclinuxos-drakconf.desktop /home/tuonomeutente/.local/share/applications
al posto di "tuonomeutente" metti il nome del tuo utente
e poi esci da root con
Codice:
exit
e chiudi il terminale.

fatto questo esplora la tua /home visualizzando i file nascosti e segui .local/share/applications e trascina l'icona di "configure your computer" sulla dock
Cita messaggio
Grazie da:
#33
ho fatto un'altra prova, non sò perchè non ci avevo pensato subito, senza fare tutto quello che ti ho scritto sopra, basta che segui il percorso radice/usr/share/applications e trascina sulla dock l'icona di pclinuxos-drakconf.desktop
Cita messaggio
Grazie da:
#34
La seconda soluzione va benissimo.
Peccato però che quando il programma è in esecuzione si vede sulla dock la doppia icona, invece non succede per le gli altri programmi.
Chissà se c'è una soluzione, ma voi comunque siete bravissimi. Complimenti.
Cita messaggio
Grazie da:
#35
Non so, quando posso vedo se riesco a capirci qualcosa, ora sono da smartphone e comunque anche io sono un novello di pclinuxos, lo uso da pochissimo tempo.

Intanto vediamo se dxgiusti che è il guru di pclos ha qualche idea
Cita messaggio
Grazie da:
#36
Va bene
Cita messaggio
Grazie da:
#37
niente, ho fatto qualche prova, ma l'icona rimane doppia quando è in esecuzione

EDIT: allora ho provato a modificare il file settings di plank

Codice:
kwrite ~/.config/plank/dock1/settings

e a questa riga

Citazione:#Whether to show only pinned applications. Useful for running more then one dock.
PinnedOnly=false
 metti true

Citazione:#Whether to show only pinned applications. Useful for running more then one dock.
PinnedOnly=true

salva il file e chiudilo e se lanci "configure your computer" dovresti avere solo un'icona, vedi screenshot, il programma è avviato e cè solo un'icona sulla dock, però cè il problema che in questo modo tutti gli altri programmi, se li lanci non comapiono automaticamente sulla dock e quindi per metterceli devi fare come per "configure your computer", cioè trascinare l'icona da /usr/share/applications
[Immagine: http://s1.postimg.org/fw6knqbu7/schermata8.png]

upload
Cita messaggio
Grazie da:
#38
Perfetto.
Grazie mille.
Metterò RISOLTO
Cita messaggio
Grazie da:
#39
Ciao ho aggiunto gestore pacchetto synaptic sulla dock. Ho usato il percorso che mi hai indicato, ma quando lo aprivo direttamente dalla dock cercava i permessi di root.
Così ho fatto lo stesso percorso, questa volta come root, ma ho trovato due file simile: synaptic-kde.desktop e synaptic.deskotp, ho scelto il secondo ed ha funzionato. Però poi ho cancellato il secondo file synaptic-desktop pensando che era ripetuto. A questo punto l'icona sulla dock non ha funzionato più, forse non dovevo cancellare il file, se è così come faccio ad aggiungere questo file?
Cita messaggio
Grazie da:
#40
Gestore pacchetti chiede sempre il login come root sia da menù che da dock quindi il comportamento era normale.

Per il problema del file rimosso prova a reinstallare il pacchetto, sono da smartphone e non posso verificare il nome, prova così
Codice:
su -

Codice:
apt-get install --reinstall synaptic-kde
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: