Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Libreoffice 5 errore query
#1
[Buongiorno a tutti
ho uno strano problema, ho due pc su uno ho installato ubuntu 14.04 con la vecchia versione di libreoffice e su uno ho da poco installato il 16.04 con libreoffice 5.
Ho un database fatto da me che funziona benissimo su libreoffice 4.1 e invece mi da problemi su libreoffice 5.
Alcune query mi danno errore, posto un esempio:
Stato SQL: HY000
Codice di errore: 1000

SELECT "havemc" || ' ' || "provincia" "provmc", "tbselezprovincia"."idcliente" FROM "tbprovincie", "tbselezprovincia" WHERE ( "tbprovincie"."idprovincia" = "tbselezprovincia"."provincliente" ) AND ( ( ""havemc" || ' ' || "provincia"" = :link_from_provmc ) )

capisco che l'errore sta in "link_from_provmc" in quanto non esiste nel database ma non riesco a trovarlo perche' se controllo il tutto, la sintassi del database e' giusta e ripeto funziona benissimo sulla versione precedente di libreoffice.

Se qualcuno ha dei suggerimenti o idee grazie.
Cita messaggio
Grazie da:
#2
Ciao
Azzardo un'ipotesi su ubuntu 16.04 di default è installata la versione libreoffice fresh che da quanto mi risulta sembra essere una versione "unstable", dovresti provare a sostituirla con libreoffice still che è quella più stabile e viene aggiornata con più revisioni.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Cita messaggio
Grazie da:
#3
Ciao,
controlla che versione di LO stai usando. Sembra infatti che la 5.1 abbia un problema che genera quel tipo di errore
http://www.imaccanici.org/it.libreoffice...13105.html
Chi sa capire tutto è molto infelice (Maksim Gor'kij)
[Immagine: http://www.istitutomajorana.it/forum2/at...p?aid=7740]
Cita messaggio
Grazie da:
#4
Grazie delle risposte e scusate il ritardo della mia.
Metto risolto per chiudere la discussione anche se dopo avere provato sia la 5.1 che la 5.2 e quindi di nuovo la 4.1 dove funziona perfettamente ma giusto per essere sicuro non ho trovato di meglio che modificare il database in modo che adesso funzioni anche sulle nuove versioni.
Grazie della solita disponibilita'
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)