Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Mancata configurazione di rete all'avvio
#1
Salve a tutti, non ho mai approfondito più di tanto la cosa perchè alla fine l'unico problema è che Mint mi avvia in 2 minuti e mezzo invece di 20 secondi, però se mi avviasse in 20 secondi sarei più contento, quindi vi sottopongo il problema.
All'avvio il sistema non riesce a caricarmi le impostazioni di rete, quindi mi appare la scritta "waiting for network configuration", passa un minuto e appare "wainting 60 more seconds for network configuration", finchè alla fine rinuncia e dice "starting system without network configuration". E avvia senza problemi. Considerando che poi il sistema di rete va bene perchè si collega e naviga senza problemi, mi era stato suggerito che dipendesse dal fatto che all'avvio, il mio router cablato che si accende insieme al pc ancora non ha fatto il login ad internet e quindi il sistema non riesce a configurarlo. "Prova ad avviare prima il router", mi hanno consigliato. Però se non avvio il sistema il router non si allinea, mentre se lo lascio acceso quando faccio un riavvio rimane allineato ma il problema si presenta identico.
Su cosa posso intervenire?
grazie.
Cita messaggio
Grazie da:
#2
questi che dicono?

Codice:
cat /etc/network/interfaces

Codice:
cat /etc/init/failsafe.conf
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#3
Codice:
cat /etc/network/interfaces

dà in risposta
Codice:
auto lo
iface lo inet loopback



iface ppp0 inet ppp
provider ppp0

auto ppp0

iface eth0 inet dhcp

auto eth0


mentre questo
Codice:
cat /etc/init/failsafe.conf

risponde:

Codice:
# failsafe

description "Failsafe Boot Delay"
author "Clint Byrum <clint@ubuntu.com>"

start on filesystem and net-device-up IFACE=lo
stop on static-network-up or starting rc-sysinit

emits failsafe-boot

console output

script
# Determine if plymouth is available
if [ -x /bin/plymouth ] && /bin/plymouth --ping ; then
PLYMOUTH=/bin/plymouth
else
PLYMOUTH=":"
fi

   # The point here is to wait for 2 minutes before forcibly booting
   # the system. Anything that is in an "or" condition with 'started
   # failsafe' in rc-sysinit deserves consideration for mentioning in
   # these messages. currently only static-network-up counts for that.

sleep 20

   # Plymouth errors should not stop the script because we *must* reach
   # the end of this script to avoid letting the system spin forever
   # waiting on it to start.
$PLYMOUTH message --text="Waiting for network configuration..." || :
sleep 40

$PLYMOUTH message --text="Waiting up to 60 more seconds for network configuration..." || :
sleep 59
$PLYMOUTH message --text="Booting system without full network configuration..." || :

   # give user 1 second to see this message since plymouth will go
   # away as soon as failsafe starts.
sleep 1
   exec initctl emit --no-wait failsafe-boot
end script

post-start exec logger -t 'failsafe' -p daemon.warning "Failsafe of 120 seconds reached."
Cita messaggio
Grazie da:
#4
prova queste coe, edita il file /etc/network/interfaces, dai

Codice:
sudo gedit /etc/network/interfaces
e lascia solo queste
Codice:
auto lo
iface lo inet loopback

cancellate le righe in più, salva il file e chiudilo.

Poi edita /etc/init/failsafe.conf, dai

Codice:
sudo gedit /etc/init/failsafe.conf
e metti il cancelletto # davanti a tutte le righe "sleep numero" (ce ne sono varie sleep 1, sleep 20 etc..etc..) , anche qui, fatta la modifica, salva il file e chiudilo, e poi riavvia e vedi se cambia qualcosa.

Se non hai gedit come editor di testo , metti il tuo editor al posto di gedit nei comandi
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
se modifico il file interfaces come hai detto una volta avviato fa svariati tentativi di connessione ma non si collega, se lo riporto allo stato originario modificando solo il file failsafe, avvia alla velocità della luce e si collega. Risolto, grazie Tuxino Smile
Cita messaggio
Grazie da:
#6
ok, ottimo, erano due tentativi da provare anche separati, ma te li ho scritti insieme, il passaggio che ti avrei suggerito, in caso, era proprio ripristinare il primo file come in origine e lasciare solo le modifiche sul secondo, ma hai verificato da solo....bravo
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)