Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Mint Mate 17.1 Errore nell'Abilitare i repository di GetDeb
#1
Seguendo l'articolo  http://www.istitutomajorana.it/informati...ovi-getdeb   ho provato ad abilitare getdeb nella Mint Mate Remix del Prof Cantaro, aggiornata alla 17.1 (Rebecca). Penso sia colpa di guest'aggiornamento se al sudo apt-get update ottengo sul terminale, alla fine

N: Viene ignorato il file "getdeb.list.bck" nella directory "/etc/apt/sources.list.d/" poiché ha un'estensione non valida
W: Impossibile recuperare "http://archive.getdeb.net/ubuntu/dists/rebecca-getdeb/apps/binary-amd64/Packages 404  Not Found [IP: 104.28.24.125 80]"

W: Impossibile recuperare "http://archive.getdeb.net/ubuntu/dists/rebecca-getdeb/apps/binary-i386/Packages  404  Not Found [IP: 104.28.24.125 80]"

E: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.

pero' tra i repositories aggiuntivi trovo getdeb; tuttavia cercando di installare jdiskreport non lo trovo in Synaptic.
Che cosa e' successo e come si puo' risolvere?
Grazie in anticipo

P.S. adesso anche il gestore aggiornamenti mi da' quelle voci di errore: devo disinstallare i repositories?
Cita messaggio
Grazie da:
#2
prova cosi, rimuovi il primo
Codice:
sudo rm /etc/apt/sources.list.d/getdeb.list.bck
non da output

e poi modifica il file del PPA getdeb, mettendo trusty al posto di Rebecca
Codice:
sudo gedit /etc/apt/sources.list.d/getdeb.list
e cambia la parte di riga con rebecca-getdeb in trusty-getdeb fatta la modifica, salva il file e chiudilo e riprova
Codice:
sudo apt-get update
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#3
Ti ringrazio, la tua procedura ha funzionato: il gestore aggiornamenti ha ripreso a funzionare, e ho potuto istallare jdiskreport da getdeb.
Solo ti prego di un attimo di paziena e spiegami cosa e' successo.
Per quello che ho capito io la 17.1 non contemplava i repositories di getdeb, per cui a Synaptic abbiamo aggiunto quelli della Mint 17, o di Ubuntu 14.04. E' cosi?

Ed in tal caso bisognerebbe dire al Prof. Cantaro di aggiornare l'articolo su getdeb con la precisazione sulle Mint 17.1 e 17.2
Cita messaggio
Grazie da:
#4
la questione non è mint17 o mint17.1 etc.. ma proprio che quei PPA sono realizzati per ubuntu 14.04 (da cui le varie versioni di mint17 derivano) e come del resto tutti gli altri PPA che come hai visto puntano ad un indirizzo per trusty, non so il motivo preciso, ma evidentemente nella distro (forse anche le ufficiali, non solo questa remix) nel file che indirizza al PPA viene usato il codename di mint, anziché quello giusto di ubuntu

comunque se ti ricapitasse con altri PPA il rimedio è abbastanza semplice.

ricordati il [RISOLTO] al titolo del primo post, ciao
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: dante5351
#5
Nella Mint 17.1 per abilitare i repositories di getdeb bastava andare su Synaptic e mettere la spunta su getdeb, che va a modificare il sources.list decommentando l'url
Cita messaggio
Grazie da:
#6
si, lo so come abilitare un ppa, però li problema è proprio che l'indirizzo a cui punta è sbagliato, se non lo abiliti non hai problemi, ovviamente, perchè non viene ricercato nell'update, ma una volta abilitato ha quel problema, che punta a un indirizzo sbagliato.
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
comunque ho fatto ora la prova su una installazione di mint 17.2 Mate (ufficiale) che ho su una partizione

Codice:
tuxino@tuxino ~ $ lsb_release -ds && echo $DESKTOP_SESSION && uname -m
Linux Mint 17.2 Rafaela
mate
i686

e il ppa abilitato punta all'indirizzo giusto, per trusty

Codice:
tuxino@tuxino ~ $ cat /etc/apt/sources.list.d/getdeb.list

deb http://archive.getdeb.net/ubuntu trusty-getdeb apps
  boh, forse è un problema della remix, comunque come hai visto facilmente risolvibile, ciao
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#8
(12-09-2015,09:50 )tuxino Ha scritto: e il ppa abilitato punta all'indirizzo giusto, per trusty

E' quello che dicevo: abilitando da Synaptic non da' errore, che nasce quando si prova ad abilitarli dal link sull'articolo: cliccando sul file.deb scaricato, questo aggiunge l'indirizzo sbagliato.
Io la prova l'ho fatta da una remix, aggiornata alla 17.1 che ho in Virtualbox sotto Windows; quindi il problema non e' della remix.
Aggiungo l'ipotesi che forse proprio perche' gli sviluppatori della Mint sapevano del comportamento del file.deb, una volta scaricato, che hanno aggiunto getdeb ai repository
Cita messaggio
Grazie da:
#9
sai che ero partito in quarta e non avevo nemmeno visto il link? Cool Cool 

probabilmente quel deb ha problemi con mint e visto che su mint il ppa cè già di default non ha senso seguire quel link.

comunque anche per aggiungerlo a ubuntu 14.04, senza scaricare e installare il .deb basta aggiungerlo al sources.list.d creando il file getdeb.list che contenga l'indirizzo del ppa, come spiegato al tuo link

HOW TO INSTALL

Codice:
echo "deb http://archive.getdeb.net/ubuntu trusty-getdeb apps" | sudo tee -a /etc/apt/sources.list.d/getdeb.list
e la chiave

Codice:
wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

e poi fare un update
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)