Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Non mi si installa Shutter
#1
Cari amici,

Non mi funziona il Software Center del mio nuovo Ubuntu 14.04.
Ho scaricato il file tar.gz di Shutter da Internet e l'ho estratto.
Adesso cosa faccio?
Grazie mille e cordiali saluti
Cita messaggio
Grazie da:
#2
shutter è nei repo di ubuntu, ti basta dare un 
Codice:
sudo apt-get install shutter
Cita messaggio
Grazie da:
#3
Magari, caro eu66. Ci ho provato ma non funziona neanche quello. Non voglio pasticciare troppo il mio Ubuntu perché è quasi nuovo e siccome sono poco pratico rischio di rovinare tutto. Grazie
Cita messaggio
Grazie da:
#4
beh, qui dice che il pacchetto è nei repo di trusty, come diceva eu66

http://packages.ubuntu.com/trusty/shutter

quindi se il comando di eu66 non lo installa, non basta dire non funziona per capire come mai, devi postare l'output , ridai il comando e posta l'output intero del terminale
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
Scusate.
Qui vi posto il risultato:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kodi-bin : Dipende: libsdl2-2.0-0 (>= 2.0.0) ma non sta per essere installato
shutter : Dipende: gnome-web-photo ma non sta per essere installato
Dipende: libgnome2-perl ma non sta per essere installato
Dipende: libgnome2-vfs-perl ma non sta per essere installato
Dipende: libgnome2-wnck-perl ma non sta per essere installato
Dipende: libgoo-canvas-perl ma non sta per essere installato
Dipende: libgtk2-appindicator-perl ma non sta per essere installato
Dipende: libgtk2-imageview-perl ma non sta per essere installato
Dipende: libgtk2-trayicon-perl ma non sta per essere installato
Dipende: libgtk2-unique-perl ma non sta per essere installato
Dipende: libnet-dbus-perl ma non sta per essere installato
Dipende: libnet-oauth-perl ma non sta per essere installato
Dipende: libproc-processtable-perl ma non sta per essere installato
Dipende: libwww-mechanize-perl ma non sta per essere installato
Dipende: libx11-protocol-perl ma non sta per essere installato
Dipende: libxml-simple-perl ma non sta per essere installato
Dipende: perlmagick
Dipende: libpath-class-perl ma non sta per essere installato
Dipende: libjson-perl ma non sta per essere installato
Dipende: libjson-xs-perl ma non sta per essere installato
Dipende: libfile-which-perl ma non sta per essere installato
Dipende: libproc-simple-perl ma non sta per essere installato
Dipende: libsort-naturally-perl ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
Cita messaggio
Grazie da:
#6
ma hai già fatto un update dell'indice dei pacchetti?riptova così e posta tutto se non lo installa (i comandi uno alla volta)

Codice:
sudo apt-get update
sudo apt-get install shutter
sudo apt-get install -f
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
Scusate, stavo chattando con Wendy del Wisconsin.
Sì, ho fatto tutto come dici tu. Ti posto il result:

Spoiler :
sudo apt-get update
Scaricamento di:1 http://security.ubuntu.com trusty-security InRelease [65,9 kB]
Ign http://extras.ubuntu.com trusty InRelease                                  
Ign http://it.archive.ubuntu.com trusty InRelease                              
Scaricamento di:2 http://extras.ubuntu.com trusty Release.gpg [72 B]          
Scaricamento di:3 http://it.archive.ubuntu.com trusty-updates InRelease [65,9 kB]
Trovato http://extras.ubuntu.com trusty Release                                
Trovato http://extras.ubuntu.com trusty/main Sources                          
Ign http://archive.canonical.com trusty InRelease                              
Trovato http://extras.ubuntu.com trusty/main i386 Packages                    
Trovato http://archive.canonical.com trusty Release.gpg                        
Scaricamento di:4 http://security.ubuntu.com trusty-security/main Sources [117 kB]
Trovato http://archive.canonical.com trusty Release                            
Trovato http://archive.canonical.com trusty/partner Sources                    
Trovato http://archive.canonical.com trusty/partner i386 Packages              
Trovato http://archive.canonical.com trusty/partner Translation-en            
Ign http://extras.ubuntu.com trusty/main Translation-it_IT                    
Ign http://extras.ubuntu.com trusty/main Translation-it                        
Ign http://extras.ubuntu.com trusty/main Translation-en                        
Ign http://ppa.launchpad.net trusty InRelease                                  
Trovato http://ppa.launchpad.net trusty InRelease                              
Scaricamento di:5 http://it.archive.ubuntu.com trusty-backports InRelease [65,9 kB]
Trovato http://ppa.launchpad.net trusty Release.gpg                            
Scaricamento di:6 http://security.ubuntu.com trusty-security/restricted Sources [4.035 B]
Trovato http://ppa.launchpad.net trusty/main i386 Packages                    
Trovato http://ppa.launchpad.net trusty/main Translation-en                    
Scaricamento di:7 http://security.ubuntu.com trusty-security/universe Sources [37,3 kB]
Trovato http://ppa.launchpad.net trusty Release                                
Trovato http://ppa.launchpad.net trusty/main i386 Packages                    
Trovato http://ppa.launchpad.net trusty/main Translation-en                    
Scaricamento di:8 http://security.ubuntu.com trusty-security/multiverse Sources [2.760 B]
Trovato http://it.archive.ubuntu.com trusty Release.gpg                        
Scaricamento di:9 http://security.ubuntu.com trusty-security/main i386 Packages [457 kB]
Scaricamento di:10 http://it.archive.ubuntu.com trusty-updates/main Sources [277 kB]
Scaricamento di:11 http://it.archive.ubuntu.com trusty-updates/restricted Sources [5.352 B]
Scaricamento di:12 http://it.archive.ubuntu.com trusty-updates/universe Sources [156 kB]
Scaricamento di:13 http://it.archive.ubuntu.com trusty-updates/multiverse Sources [5.939 B]
Scaricamento di:14 http://it.archive.ubuntu.com trusty-updates/main i386 Packages [741 kB]
Scaricamento di:15 http://security.ubuntu.com trusty-security/restricted i386 Packages [12,7 kB]
Scaricamento di:16 http://security.ubuntu.com trusty-security/universe i386 Packages [130 kB]
Scaricamento di:17 http://security.ubuntu.com trusty-security/multiverse i386 Packages [5.168 B]
Scaricamento di:18 http://security.ubuntu.com trusty-security/main Translation-en [266 kB]
Scaricamento di:19 http://security.ubuntu.com trusty-security/multiverse Translation-en [2.570 B]
Scaricamento di:20 http://security.ubuntu.com trusty-security/restricted Translation-en [3.206 B]
Scaricamento di:21 http://security.ubuntu.com trusty-security/universe Translation-en [76,6 kB]
Scaricamento di:22 http://it.archive.ubuntu.com trusty-updates/restricted i386 Packages [15,6 kB]
Scaricamento di:23 http://it.archive.ubuntu.com trusty-updates/universe i386 Packages [363 kB]
Scaricamento di:24 http://it.archive.ubuntu.com trusty-updates/multiverse i386 Packages [13,6 kB]
Scaricamento di:25 http://it.archive.ubuntu.com trusty-updates/main Translation-en [386 kB]
Scaricamento di:26 http://it.archive.ubuntu.com trusty-updates/multiverse Translation-en [7.227 B]
Scaricamento di:27 http://it.archive.ubuntu.com trusty-updates/restricted Translation-en [3.699 B]
Scaricamento di:28 http://it.archive.ubuntu.com trusty-updates/universe Translation-en [189 kB]
Scaricamento di:29 http://it.archive.ubuntu.com trusty-backports/main Sources [9.551 B]
Scaricamento di:30 http://it.archive.ubuntu.com trusty-backports/restricted Sources [28 B]
Scaricamento di:31 http://it.archive.ubuntu.com trusty-backports/universe Sources [35,2 kB]
Scaricamento di:32 http://it.archive.ubuntu.com trusty-backports/multiverse Sources [1.898 B]
Scaricamento di:33 http://it.archive.ubuntu.com trusty-backports/main i386 Packages [13,3 kB]
Scaricamento di:34 http://it.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Scaricamento di:35 http://it.archive.ubuntu.com trusty-backports/universe i386 Packages [43,2 kB]
Scaricamento di:36 http://it.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1.552 B]
Trovato http://it.archive.ubuntu.com trusty-backports/main Translation-en      
Trovato http://it.archive.ubuntu.com trusty-backports/multiverse Translation-en
Trovato http://it.archive.ubuntu.com trusty-backports/restricted Translation-en
Trovato http://it.archive.ubuntu.com trusty-backports/universe Translation-en  
Trovato http://it.archive.ubuntu.com trusty Release                            
Trovato http://it.archive.ubuntu.com trusty/main Sources                      
Trovato http://it.archive.ubuntu.com trusty/restricted Sources                
Trovato http://it.archive.ubuntu.com trusty/universe Sources                  
Trovato http://it.archive.ubuntu.com trusty/multiverse Sources                
Trovato http://it.archive.ubuntu.com trusty/main i386 Packages                
Trovato http://it.archive.ubuntu.com trusty/restricted i386 Packages          
Trovato http://it.archive.ubuntu.com trusty/universe i386 Packages            
Trovato http://it.archive.ubuntu.com trusty/multiverse i386 Packages          
Trovato http://it.archive.ubuntu.com trusty/main Translation-it                
Trovato http://it.archive.ubuntu.com trusty/main Translation-en                
Trovato http://it.archive.ubuntu.com trusty/multiverse Translation-it          
Trovato http://it.archive.ubuntu.com trusty/multiverse Translation-en          
Trovato http://it.archive.ubuntu.com trusty/restricted Translation-it          
Trovato http://it.archive.ubuntu.com trusty/restricted Translation-en          
Trovato http://it.archive.ubuntu.com trusty/universe Translation-it            
Trovato http://it.archive.ubuntu.com trusty/universe Translation-en            
Ign http://it.archive.ubuntu.com trusty/main Translation-it_IT                
Ign http://it.archive.ubuntu.com trusty/multiverse Translation-it_IT          
Ign http://it.archive.ubuntu.com trusty/restricted Translation-it_IT          
Ign http://it.archive.ubuntu.com trusty/universe Translation-it_IT            
Recuperati 3.580 kB in 54s (66,3 kB/s)                                        
Lettura elenco dei pacchetti... Fatto
------------------------------------
sudo apt-get install shutter

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kodi-bin : Dipende: libsdl2-2.0-0 (>= 2.0.0) ma non sta per essere installato
shutter : Dipende: gnome-web-photo ma non sta per essere installato
          Dipende: libgnome2-perl ma non sta per essere installato
          Dipende: libgnome2-vfs-perl ma non sta per essere installato
          Dipende: libgnome2-wnck-perl ma non sta per essere installato
          Dipende: libgoo-canvas-perl ma non sta per essere installato
          Dipende: libgtk2-appindicator-perl ma non sta per essere installato
          Dipende: libgtk2-imageview-perl ma non sta per essere installato
          Dipende: libgtk2-trayicon-perl ma non sta per essere installato
          Dipende: libgtk2-unique-perl ma non sta per essere installato
          Dipende: libnet-dbus-perl ma non sta per essere installato
          Dipende: libnet-oauth-perl ma non sta per essere installato
          Dipende: libproc-processtable-perl ma non sta per essere installato
          Dipende: libwww-mechanize-perl ma non sta per essere installato
          Dipende: libx11-protocol-perl ma non sta per essere installato
          Dipende: libxml-simple-perl ma non sta per essere installato
          Dipende: perlmagick
          Dipende: libpath-class-perl ma non sta per essere installato
          Dipende: libjson-perl ma non sta per essere installato
          Dipende: libjson-xs-perl ma non sta per essere installato
          Dipende: libfile-which-perl ma non sta per essere installato
          Dipende: libproc-simple-perl ma non sta per essere installato
          Dipende: libsort-naturally-perl ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
----------------------------------------------

sudo apt-get install -f

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
 apport-hooks-medibuntu bridge-utils bzr caribou compiz-plugins-main
 firefox-locale-it g++-4.6 gir1.2-folks-0.6 gir1.2-gee-0.8 gir1.2-gee-1.0
 gir1.2-muffin-3.0 gir1.2-timezonemap-1.0 gir1.2-unique-3.0
 gnome-session-fallback html2text kvm-ipxe libafpclient0 libattica0.3
 libbabl-0.0-0 libblas3gf libboost-filesystem1.46.1 libboost-iostreams1.46.1
 libboost-regex1.46.1 libboost-system1.46.1 libcdt4 libcelt0-0
 libclucene0ldbl libclutter-gst-1.0-0 libclutter-imcontext-0.1-0
 libclutter-imcontext-0.1-bin libcluttergesture-0.0.2-0 libdb4.8 libdee-qt5-3
 libdvbpsi7 libdxflib-2.2.0.0 libebml3 libfftw3-3 libfftw3-long3
 libfparser-4.3 libgegl-0.0-0 libgrail5 libgraph4 libgvc5 libhsqldb-java
 libjpeg62 liblapack3gf libmagickcore4 libmagickcore4-extra libmagickwand4
 libmatroska5 libmicrohttpd5 libmjpegtools-1.9 libmozjs185-1.0 libmuffin0
 libmusicbrainz4-3 libmx-1.0-2 libmx-bin libmx-common libnemo-extension1
 libnepomukdatamanagement4 libnepomuksync4 libntfs10 libopencv-calib3d2.3
 libopencv-core2.3 libopencv-features2d2.3 libopencv-flann2.3
 libopencv-highgui2.3 libopencv-imgproc2.3 libopencv-objdetect2.3 libopenspc0
 libpathplan4 libpython3.2 libqapt-runtime libqapt1 librpmio2 libsdl2
 libservlet2.5-java libshairport1 libsox-fmt-ffmpeg libsox1b
 libstdc++6-4.6-dev libsvga1 libu1db-qt5-3 libxdo2 libxerces2-java
 libxine1-console libxml-commons-external-java
 libxml-commons-resolver1.1-java muffin-common nemo nemo-data nemo-fileroller
 python-bzrlib python-central python-configobj python-gpgme python-pyicu
 python3.2 python3.2-minimal qemu-common qtdeclarative5-friends0.2
 qtdeclarative5-u1db1.0 qtdeclarative5-ubuntu-settings-components
 qtdeclarative5-ubuntu-settings-components-assets realpath
 syslinux-themes-debian-squeeze transcode-utils ttf-umefont ttf-unfonts-core
 vgabios wine-gecko1.7 wine-mono0.0.4 wine1.5-i386
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
 libsdl2-2.0-0
I seguenti pacchetti NUOVI saranno installati:
 libsdl2-2.0-0
0 aggiornati, 1 installati, 0 da rimuovere e 73 non aggiornati.
2 non completamente installati o rimossi.
È necessario scaricare 0 B/321 kB di archivi.
Dopo quest'operazione, verranno occupati 1.172 kB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 312750 file e directory attualmente installati.)
Preparativi per estrarre .../libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1.1_i386.deb...
Estrazione di libsdl2-2.0-0:i386 (2.0.2+dfsg1-3ubuntu1.1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1.1_i386.deb (--unpack):
tentata sovrascrittura di "/usr/lib/i386-linux-gnu/libSDL2-2.0.so.0" presente anche nel pacchetto libsdl2:i386 2.0.3+z4~20140315-8621-1ppa1precise1
Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Cita messaggio
Grazie da:
#8
Prova a dare una ripulita con ubuntu-tweak, poi ridai



Codice:
sudo apt-get update && sudo apt-get upgrade


Codice:
sudo apt-get install -f


Codice:
sudo apt-get install shutter
Cita messaggio
Grazie da:
#9
tu hai detto che non volevi rovinare la nuova installazione, ma mi sà che hai già fatto dei casini appena installato, dall'output si vede che hai già aggiunto dei ppa esterni.....che ti creano casini, quelli se non è proprio indispensabile, è meglio non usarli.

comunque prova

Codice:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1.1_i386.deb
e poi

Codice:
sudo apt-get install -f
e posta l'output, sperando che si risolva, altrimenti mi sa che ti tocca reinstallare...e la prossima volta
evita i ppa
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#10
Faccio subito tutto.
E' vero, ho fatto dei ppa, ma è che io prima di venire sul forum cerco di cavarmela da solo. Sono andato su Internet e ho trovato determinate istruzioni "fidate" su come installare shutter. Precisamente il sito ufficiale di shutter consigliava di dare questo da terminale:
sudo add-apt-repository ppaConfusedhutter/ppa
sudo apt-get update && sudo apt-get install shutter
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)