Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Non riesco più ad installare nessun S.O.
#1
Ciao, ho ancora bisogno del vostro aiuto, un paio di settimane fa, ho chiesto i vostri consigli per il partizionamento del nuovo notebook UEFI, tutto era andato ok, ed avevo installato Pclinuxos dopo aver selezionato gpt ed aver creato la partizione FAT32 per l'avvio in boot/EFI. Dopo che avevo avuto  dei messaggi di errore al termine di un aggiornamento corposo, mi sono deciso a reinstalare Pclos Mate, la nuova uscita di novembre 2017. L'installazione non è andata a buon fine, allora ho cancellato tutto ed ho rifatto le partizioni da zero pensando di risolvere, ma il problema persiste: in pratica l'installazione procede fino all'ultimo ma dopo compare un avviso di crash e il sistema non viene installato, questo succede sia con l'installazione in manuale, sia in automatico. Praticamente a quanto mi sembra di capire non viene rilevato che il disco è in gpt o la partizione di avvio efi, ma il sistema tenta (ovviamente senza riuscire) di installare GRUB. il messaggio di crash è questo:


Codice:
The "draklive-install" program has crashed with the following error:
open2: exec of /mnt/install/bin/grub2-mkpasswd-pbkf2 failed at /usr/lib/libDrakX/bootloader.pm line 1827.
    ........propagated at /usr/lib/libDrakX/any.pm line 267.
Perl's trace:
drakbug::bug handler() called from /usr/lib/libDrakX/any.pm:267
any::installBootloader() called from /usr/lib/libDrakX/any/. pm:237klive-install:43
any::setupBootloaderUntilInstalled() called from /usr/sbin/draklive-install:340
main::setup_bootloader()called from/usr/sbin/draklive-install:71
main::install_live() called from /usr/sbin/draklive-install:43


L'unico modo che ho per poter utilizzare il notebook è con un dvd live.
Cita messaggio
Grazie da:
#2
P.S.
Le due faccine nel testo non ho idea di come ci siano finite, ho tentato di rimuoverle ma non ci riesco, fate finta che non ci siano
Cita messaggio
Grazie da:
#3
(18-11-2017,09:50 )antares Ha scritto: Le due faccine nel testo non ho idea di come ci siano finite

Le ho sistemate io per rendere il messaggio più leggibile. Basta che racchiudi il testo in blocco di codice (c'è un pulsante apposito nella barra di formattazione).
Cita messaggio
Grazie da:
#4
presta attenzione minuto 3.15 a 3.45 tu esegui questo? intendo il mount sulla partizione boot/efi

Cita messaggio
Grazie da:
#5
@dxgiusti:
Ho seguito alla lettera questo filmato, la volta scorsa, circa 2 settimane fa, ho partizionato ed installato senza problemi, quando sono andato a fare una nuova installazione qualcosa è andato storto. Ho ripartizionato da zero ed ho fatto una nuova installazione con pclos mate 11/2017, siccome mi dava errore alla fine, ho optato x l'installazione automatica il risultato è stato identico, stesso messaggio di crash a fine installazione. Ho anche provato ad inibire legacy entrando nelle impostazioni del pc, non cambia nulla stesso messaggio.
L'installazione secondo me riesce ma è l'avvio che non per qualche motivo non viene trovato o scritto in modo errato infatti non vedo il perchè qualsiasi distro si vada ad installare (ho provato anche con mint e con una mylivecd di pclinuxos KDE che avevo installato e che ho utilizzato per una settimana), il sistema cerca di farla partire con GRUB anzichè con EFi.
Cita messaggio
Grazie da:
#6
Ciao
Puoi postare un'immagine di gparted?
Se hai formattato tutto hai ricreato anche la partizione boot/efi?
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Un giorno senza rischio è non vissuto.....

PCLinuxOS Mate - Manjaro Mate/Xfce - Uplos32 Mate/Trinity - Kali Linux Mate64
Cita messaggio
Grazie da:
#7
io ripartirei dall'inizio. da live, avviare gparted, ricreare la tabella GPT, crare le partizioni, installare.
comunque ora provo anche io a fare una istallazione "nuova".
Cita messaggio
Grazie da:
#8
quando fai la partizione in fat32 per EFI, con gparted dagli il flag di boot. poi all'installazione montala come boot/efi.
Cita messaggio
Grazie da:
#9
Mi scuso se non ho potuto rispondere prima, ma questo weekend ho pochissimo tempo.
@D-BARTO questo il disco com'è partizionato attualmente:

   

@dxgiusti ho provato a ripartizionare il disco innumerevoli volte seguendo la tua guida che ormai conosco a memoria, scelgo gpt poi fat 32 e poi /boot/EFI ma il sistema come detto sembra ignorare queste impostazioni. Devo dire che nelle prime installazioni che ho provato a fare, il processo si bloccava quasi subito e mi usciva l'avviso:

 You must have a ESP FAT 32 partition mounted in /boot/EFI

Dopo questo avviso avevo flaggato la partizione FAT 32 in boot/ESP e credevo di aver risolto in quanto l'installazione procede fino in fondo chiedendomi la password e facendomi terminare il processo, ma subito compare l'avviso di crash che ho postato ad inizio discussione. Quello che non capisco è perchè quando ho piallato il disco e fatto la prima installazione due settimane fa, ho seguito il filmato e tutto ha funzionato senza bisogno di flaggare la partizione FAT 32, il sistema aveva montato la partizione in automatico.
Cita messaggio
Grazie da:
#10
la tua installazione/prova in live, inizia con la schermata >>>

   


oppure con >>>

   

ho visto una discussione simile alla tua sul forum PCLinuxOS.com , vedremo gli sviluppi.........
http://www.pclinuxos.com/forum/index.php...msg1233114
Cita messaggio
Grazie da:


Vai al forum: