Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] PCLinuxOS non parte più
#1
Qualche giorno fa ho installato Debian 8 e oggi mi sono accorto che PCLinuxOS non parte più, nonostante venga correttamente listato nel menu del Grub. Nello specifico si blocca alla schermata di caricamento (l'anello che gira).

E' possibile che PCLinuxOS voglia il suo Grub? Cosa mi consigliate? Vorrei evitare di reinstallarlo...
Cita messaggio
Grazie da:
#2
Non è che istallando debian 8 hai combinato qualche guaio, con gparted ci sono le partizioni di pclinuxos?
Pace e Serenità a tutti voi per un mondo migliore Tongue  Heart
Cita messaggio
Grazie da:
#3
No, le partizioni sono le medesime, non ho toccato nulla, perché ho installato Debian 8 in una partizione pre-esistente. L'unica cosa che può aver fatto l'installer di Debian è aver formattato la partizione di Swap, ma credo sia ininfluente...
Cita messaggio
Grazie da:
#4
che distribuzione è che gestisce il grub. da quella aggiornalo con un update.
Cita messaggio
Grazie da:
#5
Se non hai scelto di installare il bootloader nella medesima partizione di debian, ora dovrebbe essere questa che comanda il grub, in automatico l'ultima distro che si installa piazza il suo bootloader in sda.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#6
debian 8 che grub usa? se non usa grub2 pclos non partirà più.
Cita messaggio
Grazie da:
#7
Mi sa [Immagine: http://www.istitutomajorana.it/forum2/im...if/huh.gif]  che praticamente tutte le distro sono passate a grub2 compresa debian, a parte pclinuxos.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da: Ubunter
#8
(12-05-2015,22:41 )bilodiego Ha scritto: Mi sa Undecided  che praticamente tutte le distro sono passate a grub2 compresa debian, a parte pclinuxos.

Comunque anche su pclinuxos si può installare grub 2 :  http://pclinuxos.it/node/2537
spiegato bene da dxgiusti , se ubunter ha lasciato il grub di pclinuxos allora è un guaio.
Pace e Serenità a tutti voi per un mondo migliore Tongue  Heart
Cita messaggio
Grazie da:
#9
(12-05-2015,18:53 )Ubunter Ha scritto: E' possibile che PCLinuxOS voglia il suo Grub? Cosa mi consigliate? Vorrei evitare di reinstallarlo...

non credo sia questo il problema, anche io ho pclinuxos con altri sistemi, il grub che comanda è quello di Kubuntu, ma pclinuxos si avvia normalmente.
inoltre mi pare più un problema di file system, visto che nel grub lo vedi e lo avvii anche, ma poi si ferma sul plymouth a caricare.

potresti provare un check del file system, da live  o da debian con partizione di pclinuxos smontata, dalla live di ubuntu ti direi di provare così

Codice:
sudo fdisk -l
per individuare la partizione di pclinuxos e poi un
Codice:
sudo fsck -yv /dev/sdaX

dove X è il numero di partizione di pclinuxos però non so se la cosa può andare bene, vediamo che ne dicono gli esperti....

EDIT: stavo postando e visto l'intervento di max deal boh anche quello potrebbe essere un problema? cioè se ha lasciato pclinuxos come di default con grub1
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: Ubunter
#10
Allora, prima che installassi Debian 8 col suo rispettivo Grub (il 2) utilizzavo il Grub 2 di PCLinuxOS senza alcun problema. Il grub di Debian mi ha visto TUTTI i sistemi attualmente installati immediatamente dopo l'installazione.

Quanto al mancato avvio di PCLinuxOS, che si blocca alla schermata di caricamento (quando compare il logo e l'anello che gira), ho pensato che potesse essere un problema di Grub perché ad esempio ci sono distro come Antergos o Manjaro che vogliono il loro Grub, altrimenti non partono (esperienza personale). Detto questo, ho provato a ripristinare il Grub di PCLinuxOS ma non è cambiato nulla. Al che, pensando che potesse aver influito la formattazione della partizione di swap ad opera dell'installer di Debian 8, ho ricompilato il file fstab di PCLinuxOS (editandolo da un'altra distro), ho riavviato il PC e magicamente PCLinuxOS è partito! Assurdo ma vero. Evidentemente PCLinuxOS non trovava più la partizione di swap e il caricamento rimaneva in loop, credo sia così. Buono a sapersi, dai XD

Ringrazio tutti per la sempre pronta disponibilità, siete davvero impareggiabili.
Cita messaggio
Grazie da: bilodiego


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)