SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Passare dalla 10:04 di Ubuntu a...
#51
lo xorg riporta che c'è qualche problema visto che ti permette solo una singola risoluzione.

Comunque se hai rimesso i noveau se non ci fosse lo xorg.conf segui il tutorial per generarlo e testarlo:

http://wiki.ubuntu-it.org/Hardware/Video...7fa6be6b93

Poi prosegui con il primo tutorial.

Prova a seguire anche questo altro topic:

http://www.istitutomajorana.it/forum2/Th...Plus-14-04

Se le risoluzioni che hai nella ubuntu 10.04 non sono presenti nella 14.04 non possono venire utilizzate dal sistema.
Cita messaggio
Grazie da:
#52
Ciao @supertuxkart,domani provo a seguire la guida che mi hai indicato ieri anche se qui:
Citazione:Pertanto procuriamoci una copia in formato .tar.gz relativo alla versione ed all'architettura del nostro sistema operativo:

Ubuntu 14.04 32 bit
non ho ben capito cosa e dove me la devo procurare. Perdonami ma a me tante cose proprio sfuggono.

Ed anche dove dice:
Citazione:Scarichiamo nella nostra Home l'archivio xorg.conf.tar.gz ed estrarlo in essa.
da dove lo prendo non c'è scritto.E nella cartella /etc/x11 ovviamente come ho letto non c'è!

Intanto ho letto l'altra pagina che mi hai segnalato e questi sono tutti i risultati:
Codice:
klaudiomi@klaudiomi:~$ lspci | grep VGA
00:10.0 VGA compatible controller: NVIDIA Corporation C73 [GeForce 7100 / nForce 620i] (rev a2)
klaudiomi@klaudiomi:~$ sudo lshw -c display
[sudo] password for klaudiomi:
  *-display              
       description: VGA compatible controller
       product: C73 [GeForce 7100 / nForce 620i]
       vendor: NVIDIA Corporation
       physical id: 10
       bus info: pci@0000:00:10.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:34 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:fc000000-fcffffff memory:fea40000-fea5ffff
klaudiomi@klaudiomi:~$ lshw -c display | grep driver
WARNING: you should run this program as super-user.
       configuration: driver=nvidia latency=0
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
klaudiomi@klaudiomi:~$ sudo lshw -c display | grep driver
       configuration: driver=nvidia latency=0
klaudiomi@klaudiomi:~$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce 7050 / nForce 620i/integrated/SSE2
    GL_KTX_buffer_region, GL_NVX_conditional_render,
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer,
klaudiomi@klaudiomi:~$ glxinfo|grep "OpenGL version"
OpenGL version string: 2.1.2 NVIDIA 304.125
klaudiomi@klaudiomi:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce 7050 / nForce 620i/integrated/SSE2
OpenGL version string:  2.1.2 NVIDIA 304.125

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
klaudiomi@klaudiomi:~$
Cita messaggio
Grazie da:
#53
In quel topic si riferiva al fatto che Lubuntu non aveva nel repo il driver video per quella versione, ma ne esistevano in formato compresso dal produttore o da qualche altra parte, di cui poi lui ha estratto nella home e in cui era presente uno xorg.conf.
Il tuo è un caso diverso, tu devi prima creare il file xorg,conf dato che non esiste.

il file xorg.conf si crea così, come descritto sul wiki di ubuntu:

1) copiare uno xorg.conf di sicurezza, per eventuale ripristino in caso di difficoltà, se esistente :
Codice:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

a) Per ripristinare eventualmente una versione precedente funzionante dello xorg.conf:
Codice:
mv /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

2) Per creare e riconfiguare lo xorg.conf.new nella directory home.

a) Entrare nel terminale con CTRL+ALT+F1 (vale per Mint mate, quindi trovate il comando secondo la vostra distribuzione)oppure entrare in modalità recovery e scegliere il terminale.
b) Inserire il proprio nome utente e password.
c) Arrestare il server grafico X con:
Codice:
sudo service mdm stop
* mettere il proprio gestore dei desktop. ( da non confondere con il DE stesso - Gnome, Mate, Unity 2-3D, Kde, Xfce etc ).
A seconda delle distribuzioni è diverso - lightdm, kdm, gdm, mdm, xdm, lxdm, wdm etc
Per sapere quale avete basta accedere da gestore pacchetti e nell'apposita casella di ricerca, digitare display manager.
Quello marcato nella casella sarà il vostro gestore.
Indi mettere quello che avete trovato al posto di "mdm".
   
d) Per riconfigurare il server grafico X digitare il seguente comando:
Codice:
sudo X -configure
Questo genererà il file xorg.conf.new nella cartella Home
Se necessario editare il file xorg.conf.new.
   
e) È possibile testare il file di configurazione generato digitando:
Codice:
sudo X -config $HOME/xorg.conf.new

f) Se la risoluzione è soddisfacente, digitare il seguente comando:
Codice:
sudo cp $HOME/xorg.conf.new /etc/X11/xorg.conf

g) Riavviare il server grafico con :
Codice:
sudo service mdm start
* mettere il proprio gestore dei desktop. ( da non confondere con il DE stesso - Gnome, Mate, Unity 2-3D, Kde, Xfce etc ).
A seconda delle distribuzioni è diverso - lightdm, kdm, gdm, mdm, xdm, lxdm, wdm etc
Per sapere quale avete basta accedere da gestore pacchetti e nell'apposita casella di ricerca, digitare display manager.
Quello marcato nella casella sarà il vostro gestore.
Indi mettere quello che avete trovato al posto di "mdm".

Questo lo devi fare prima per crearlo e testare le eventuali risoluzioni possibili.
Se poi non è sufficiente bisogna trovare le risoluzioni, da inserire in un punto specifico dello xorg.conf di cui in quel topic che ti ho postato c'era un fac-simile di esempio di come doveva essere impostato all'incirca, ma con i parametri trovati da questo tuttorial.
Cita messaggio
Grazie da:
#54
Ciao, non capisco cosa sbaglio:
1)cntr alt F1
2)inserisco username e password
3)sudo service mdm stop  ed ottengo come errore : ERR:mdm unreognized service

ok,forse devo specificare che è Gnome che devo fermare ed allora riprovo:
3)sudo stop gdm ed ottengo stop unknow instance
idem sudo service gdm stop

e sto xorg non riesco a crearlo Disperato
Cita messaggio
Grazie da:
#55
Il tutorial l'ho fatto con base Mint Mate che ha come gestore desktop mate desktop manager=mdm, ma su ubuntu il gestore desktop di default se il Prof. Cantaro non l'ha cambiato è lighdm, altrimenti potrebbe essere gdm. C'è specificato sotto al comando.

Quindi invece di :
sudo service mdm stop
devi scrivere:
sudo service lightdm stop
o
sudo service gdm stop.

Per il riavvio devi mettere di nuovo il tuo gestore desktop.
Cita messaggio
Grazie da:
#56
Ecco,mannaggia,avevo provato sudo service gdm stop credendo che se stavo su Gnome quello era il comando per fermarlo invece ci voleva lightdm!

Comunque lo xorg.conf.new l'ha creato ma dopo il comando sudo X -config $HOME/xorg.conf.new per provare tutto è andato a nero.Per cui ho spento e riavviato.
Lo xorg che ha creato è questo:
Codice:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    BusID       "PCI:0:16:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

che è molto diverso dall'esempio della discussione che mi avevi mostrato per cui non saprei cosa cambiare.
Cita messaggio
Grazie da:
#57
Questo l'hai fatto con il driver libero xserver-xorg-video-noveau o con driver nVidia 304.125 ?

Chiaramente se il monitor è diventato nero quando l'hai provato, significa che non supporta nessuna risoluzione e quindi non ne mette nessuna.

Se l'hai fatto con lo nVidia devi prima disinstallarlo ed eventualmente rimettere il noveau e poi riprovare.
Cita messaggio
Grazie da:
#58
Lo avevo fatto con il driver nVidia 304.125 mentre poco fa ho rimesso il driver libero xorg ed ho rifatto tutta la procedura ma anche così su "sudo X -config $HOME/xorg.conf.new" tutto nero e nessuna possibilità di far nulla se non spegnere il pc o riacciare.
Cita messaggio
Grazie da:
#59
Va bene facciamola più semplice, tra virgolette.
Prova così, prima con i noveau.

Per sapere tutte le eventuali risoluzioni in uso:
Codice:
xrandr
o
Codice:
xrandr -q

Sulla 10.04 ti dovrebbe dare qualcosa del genere:

Codice:
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 8192 x 8192
VGA-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
  1440x900       59.9*+   75.0  
  1280x1024      75.0     60.0  
  1280x960       60.0  
  1280x800       74.9     59.8  
  1152x864       75.0  
  1024x768       75.1     70.1     60.0  
  832x624        74.6  
  800x600        72.2     75.0     60.3     56.2  
  640x480        75.0     72.8     66.7     60.0  
  720x400        70.1  

Sulla 14.04 non so che cosa ti darà, prova lo stesso, ma dalla 10.04 fatti una tabella in un file, perchè se li supporta vuol dire che sono utilizzabili dal monitor.

Usa xrandr al terminale per sapere nome uscita video del monitor, per essere sicuro, anche se l'hai già postato e il risultato era VGA-0:
Codice:
xrandr | grep connected
Esempio :
Codice:
VGA-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
HDMI-0 disconnected (normal left inverted right x axis y axis)
In questo caso l'uscita attiva (connected) si chiama VGA-0.

Usa da terminale il comando cvt per ottenere tutti i dettagli necessari per configurare una singola risoluzione, come da esempio sopra, con la tabella ottenuta dalla 10.04.

Questo è sempre un esempio:
Codice:
cvt 1280 1024 75
Codice:
cvt 1280 960 60
Codice:
cvt 800 600 75
e così via.

Il comando cvt restituisce un risultato tipo questo :

Codice:
# 1280x1024 74.90 Hz (CVT 1.31M4) hsync: 80.30 kHz; pclk: 138.75 MHz
Modeline "1280x1024_75.00"  138.75  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync
la riga modeline è quella che ci interessa.

Poi testi la risoluzione trovata con questi tre comandi diversi, cui devi aggiungere quello che c'è dopo modeline, con copia e incolla:

Esempio:
Codice:
xrandr --newmode "1280x1024_75.00"  138.75  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync
Codice:
xrandr --addmode VGA-0 "1280x1024_75.00"
Codice:
xrandr --output VGA-0 --mode "1280x1024_75.00"

Ripeto alla prima riga, dopo il comando - xrandr --newmode - aggiungi con il copia e incolla, quanto trovato dopo modeline.
Alla seconda e alla terza solo la parte tra gli apici.
In questo modo se una qualche risoluzione funzionasse te la dovrebbe dare provvisoriamente.
Al riavvio tutto torna come prima, se non gli ridai nuovamente questi comandi.
Se non ci fosse output, non si può fare niente.

Al limite, se li supporta potremmo usare uno script, al posto di modificare lo xorg.conf.

Spero di essere stato chiaro.
Cita messaggio
Grazie da:
#60
Allora dalla 10.04:
Codice:
klaudiomi@klaudiomi-desktop:~$ xrandr
Screen 0: minimum 8 x 8, current 1440 x 900, maximum 4096 x 4096
VGA-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 256mm
   1440x900       59.9*+   75.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
klaudiomi@klaudiomi-desktop:~$ ~$ xrandr | grep connected
VGA-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 256mm

sulla 14.04 usando il driver xorg neveau:
Codice:
xrandr | grep connected
xrandr: Failed to get size of gamma for output default
default connected primary 800x600+0+0 0mm x 0mm
klaudiomi@klaudiomi:~$  xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected primary 800x600+0+0 0mm x 0mm
   800x600        75.0*
  1440x900_59.90 (0x194)  106.2MHz
        h: width  1440 start 1528 end 1672 total 1904 skew    0 clock   55.8KHz
        v: height  900 start  903 end  909 total  934           clock   59.7Hz
  1280x1024_75.00 (0x195)  138.8MHz
        h: width  1280 start 1368 end 1504 total 1728 skew    0 clock   80.3KHz
        v: height 1024 start 1027 end 1034 total 1072           clock   74.9Hz
  1152x864_75.00 (0x196)  104.0MHz
        h: width  1152 start 1224 end 1344 total 1536 skew    0 clock   67.7KHz
        v: height  864 start  867 end  871 total  905           clock   74.8Hz
  1280x960_60.00 (0x198)  101.2MHz
        h: width  1280 start 1360 end 1488 total 1696 skew    0 clock   59.7KHz
        v: height  960 start  963 end  967 total  996           clock   59.9Hz

comunque ho continuato in base alla tabella della 10.04 seguendo quello che mi hai detto:
Codice:
klaudiomi@klaudiomi:~$ cvt 1440 900 59.9
# 1440x900 59.75 Hz (CVT) hsync: 55.80 kHz; pclk: 106.25 MHz
Modeline "1440x900_59.90"  106.25  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
klaudiomi@klaudiomi:~$ cvt 1280 1024 75
# 1280x1024 74.90 Hz (CVT 1.31M4) hsync: 80.30 kHz; pclk: 138.75 MHz
Modeline "1280x1024_75.00"  138.75  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync
klaudiomi@klaudiomi:~$ cvt 1280 960 60
# 1280x960 59.94 Hz (CVT 1.23M3) hsync: 59.70 kHz; pclk: 101.25 MHz
Modeline "1280x960_60.00"  101.25  1280 1360 1488 1696  960 963 967 996 -hsync +vsync
klaudiomi@klaudiomi:~$cvt 1152 864 75
# 1152x864 74.82 Hz (CVT 1.00M3) hsync: 67.71 kHz; pclk: 104.00 MHz
Modeline "1152x864_75.00"  104.00  1152 1224 1344 1536  864 867 871 905 -hsync +vsync

klaudiomi@klaudiomi:~$ xrandr --newmode "1440x900_59.90"  106.25  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
xrandr: Failed to get size of gamma for output default
klaudiomi@klaudiomi:~$ xrandr --addmode VGA-0 "1440x900_59.90"
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "VGA-0"
klaudiomi@klaudiomi:~$ xrandr --output VGA-0 --mode "1440x900_59.90"
xrandr: Failed to get size of gamma for output default
warning: output VGA-0 not found; ignoring
ho ripetuto per le risoluzioni 1280x1024,1280x960 e 1152x864 tutte con i medesimi risultati.

Infine ho rimesso nvidia 304.125 e qui si ha di nuovo VGA=0.
Codice:
xrandr | grep connected
VGA-0 connected primary 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 256mm
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: