Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]Problema: come installare driver proprietario AMD per scheda video
#1
Salve,amici del forum.

Sto aprendo più discussioni per problemi diversi, dopo l'installazione di Ubuntu 14.04 remix su un portatile Acer di un mio caro amico, che avrebbe voluto sostituire Windows 8 con Ubuntu, ma la cosa appare quasi insormontabile: sui vecchi pc Ubuntu riconosce quasi tutto l'hardware e le periferiche, mentre sui pc più recenti ci sono problemi con il touchpad, con la scheda video, etc.
Problemi che per utenti semplici e non esperti informatici come me diventano montagne da scalare; sinceramente sono molto demoralizzato, spero di risolvere, per non dover ritornare a Windows.

Per risolvere il problema di compatibilità con la scheda video Amd Radeon R7 M265 con 2 gb di ram, ho scaricato il driver dal sito AMD:
http://support.amd.com/it-it/download/de...=Linux+x86

Però, una volta scaricato il file, non so come installarlo.
Potreste aiutarmi? Disperato
Grazie per la vostra disponibilità, Francesco


Allegati Anteprime
   
Cita messaggio
Grazie da:
#2
Apri il terminale nella posizione in cui si trova il driver e lo esegui con il comando

sudo ./amd-driver-installer-14.501.1003-x86.x86_64.run

e parte l'installer grafico
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
Grazie da:
#3
(25-01-2015,12:10 )Dukko Ha scritto: Apri il terminale nella posizione in cui si trova il driver e lo esegui con il comando

sudo ./amd-driver-installer-14.501.1003-x86.x86_64.run

e parte l'installer grafico

Grazie, Dukko, ho provato, ma nulla... Disperato


Allegati Anteprime
   
Cita messaggio
Grazie da:
#4
non ho AMD, ma devi andare nel percorso dov'è il file, dalla schermata si vede che ce l'hai in home, ma prima devi entrare nella cartella che lo contiene
Codice:
cd fglrx-14.501.1003
non so se il file ha gia i permessi di esecuzione,  daglieli
Codice:
chmod +x amd-driver-installer-14.501.1003-x86.x86_64.run
e poi
Codice:
sudo ./amd-driver-installer-14.501.1003-x86.x86_64.run
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
Immagino tu debba spostarti col terminale nella cartella dove risiede il driver, quindi
Codice:
cd /home
e poi
Codice:
cd fglrx-14.501.1003
che mi pare di vedere che è la cartella dove risiede il driver,
poi dai il comando di Dukko e vedrai che parte
Cita messaggio
Grazie da:
#6
ciao pabform, non dovrebbe servire il cd /home, il terminale si apre di default in ~/ a meno di modifiche, quindi va bene direttamente
Codice:
cd fglrx-14.501.1003
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
Grande tuxino!

sembra andato tutto bene, ti sono grato!

Puoi controllare anche tu, sembra che l'installazione sia andata a buon fine!

Grazie, amico mio!


Allegati Anteprime
       
Cita messaggio
Grazie da:
#8
come dicevo, non ho schede AMD però mi pare che sia andata bene, dovresti avere da qualche parte nel menu il tool per tutte le impostazioni AMD, vedi
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#9
In coda a quanto sopra due consigli:

se il driver funziona bene, controllare se sono disattivati gli aggiornamenti livello 4-5, unstable e backports, nel caso levare la spunta.
Di solito sono disattivati di default, ma non si sa mai.

nel caso di aggiornamento del kernel, è tassativo fare prima la routine di dinstallazione di questi driver proprietari, perchè vanno ricompilati e reinstallati successivamente, altrimenti ti ritrovi con lo schermo nero ed è più complicato farlo da terminale.
Cita messaggio
Grazie da:
#10
(25-01-2015,13:36 )tuxino Ha scritto: come dicevo, non ho schede AMD però mi pare che sia andata bene, dovresti avere da qualche parte nel menu il tool per tutte le impostazioni AMD, vedi

Grazie, Tuxino, egrazie anche a Dukko, ora non sono a casa, appena posso cercherò il menu delle impostazioni AMD, però posso dirti che dopo aver riavviato il computer, il puntatore del mouse è tornato normale, ed inoltre non c'è più neppure quell'ombra rettangolare fastidiosa che si muoveva insieme alla freccia del mouse stesso.

Quindi il problema appare risolto.  Big Grin

Inoltre, sono andato in Impostazioni-Software e aggiornamenti-Driver e, a differenza delle altra volte, Ubuntu ha selezionato non più il primo campo, Xorg con driver open-source, bensì la terza opzione, con driver proprietari, quindi presuppongo siano quelli che ho installato  con il tuo aiuto, e che il sistema ha selezionato in automatico

A questo punto penso proprio che posso scrivere "risolto"

Grazie, mi ero un pò demoralizzato, sinceramente stavo per "mollare", senza il vostro aiuto non ce l'avrei mai fatta.
Questo è il grande potere del forum,ognuno può contare sull'aiuto degli altri...

Wink



P.s. trovato anche il menu AMD Catalist control (come amministratore) per configurare la sk video. tutto ok!
Cita messaggio
Grazie da:


Vai al forum: