Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Problema installazione samba
#1
Ciao a tutti ho debian 8 jessie e dovrei installare samba ma seguendo la guida e dando il comando sudo apt-get install samba cifs-utils ho il seguente risultato
Codice:
pino-deb@debian:~$ sudo apt-get install samba cifs-utils
[sudo] password for pino-deb:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Package cifs-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
se provo con samba
Codice:
pino-deb@debian:~$ sudo apt-get install samba
[sudo] password for pino-deb:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
samba : Dipende: heimdal-hdb-api-8 ma non è installabile
Dipende: python-dnspython ma non è installabile
Dipende: python-ntdb ma non è installabile
Dipende: python-samba ma non sta per essere installato
Dipende: samba-common-bin (= 2:4.2.10+dfsg-0+deb8u3) ma non sta per essere installato
Raccomanda: attr ma non è installabile
Raccomanda: samba-vfs-modules ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
pino-deb@debian:~$
Tra l'altro ho provato dal gestore pacchetti ma mi dice che non si possono installare perchè ci sono dipendenze non risolte di abilitare tutti i repository cosa che mi sembra di aver fatto dalle preferenze, non so più cosa fare qualcuno mi aiuta per favore?
mi sa che cambierò il SO con uno più "facile" accetto consigli, venendo da ubuntu e mint che erano più immediati qui mi trovo un po' spaesato.
Ciao

edit esabatad: discussione spostata in Reti
Cita messaggio
Grazie da:
#2
Prova cosi:

sudo apt-get install libcups2 samba samba-common cups
Cita messaggio
Grazie da:
#3
Ciao e grazie per l'attenzione
Codice:
pino-deb@debian:~$ sudo apt-get install libcups2 samba samba-common cups
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
cups è già alla versione più recente.
libcups2 è già alla versione più recente.
È stato impostato libcups2 per l'installazione manuale.
samba-common è già alla versione più recente.
È stato impostato samba-common per l'installazione manuale.
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
samba : Dipende: heimdal-hdb-api-8 ma non è installabile
         Dipende: python-dnspython ma non è installabile
         Dipende: python-ntdb ma non è installabile
         Dipende: python-samba ma non sta per essere installato
         Dipende: samba-common-bin (= 2:4.2.10+dfsg-0+deb8u3) ma non sta per essere installato
         Raccomanda: attr ma non è installabile
         Raccomanda: samba-vfs-modules ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
pino-deb@debian:~$
appena prima avevo provato con
Codice:
pino-deb@debian:~$ sudo apt-get -f install samba
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
samba : Dipende: heimdal-hdb-api-8 ma non è installabile
         Dipende: python-dnspython ma non è installabile
         Dipende: python-ntdb ma non è installabile
         Dipende: python-samba ma non sta per essere installato
         Dipende: samba-common-bin (= 2:4.2.10+dfsg-0+deb8u3) ma non sta per essere installato
         Raccomanda: attr ma non è installabile
         Raccomanda: samba-vfs-modules ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
pino-deb@debian:~$
Cita messaggio
Grazie da:
#4
Se può interessare ho risolto cosi grazie all'aiuto su un altro forum (spero non siate gelosi e non sia vietato il cossposting)
Citazione:Ciao, forse c'è un problema nel file sources.list. Se stai usando Debian Jessie il file dovrebbe essere piu' o meno simile a questo:

#

deb http://ftp.it.debian.org/debian/ jessie main contrib non-free
#deb-src http://ftp.it.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.it.debian.org/debian/ jessie-updates main

Quindi apri il file in questione con # gedit /etc/apt/sources.list e fai copia e incolla. Se non ti interessa installare software non libero, puoi cancellare contrib non-free alla fine delle linee. Dopocchè salva, fai # apt-get update e procedi con l'installazione come hai fatto tu prima. Nel caso tu stessi usando Debian testing o Debian Sid e il file sources.list è stato impostato in modo corretto per queste versioni di Debian puo' essere che le dipendenze relative a Samba siano momentaneamente non soddisfatte, puo' succedere nelle versioni diverse dalla versione stable (Debian Jessie) quindi si tratta di aspettare che risolvano i problemi relativi alle dipendenze.
Cita messaggio
Grazie da:
#5
però per essere utile, devi mettere il [RISOLTO] alla discussione, ciao
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#6
Giusto! Mi ero dimenticato
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)