Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Riconoscimento partizione swap
#1
Sono afflitto dal ben noto problema del riconoscimento della Swap. In pratica, se vado in monitor di sistema>risorse, risulta "swap non disponibile". Questo mi crea una serie di problemi, tra cui l'impossibilità della funzione di ibernazione e il malfunzionamento della funzione di sospensione (anche se a quel che ho capito forse la sospensione sia un problema diverso legato più ai driver video).

Premetto che:
Ho già seguito varie guide, ottenendo qualche risultato (prima la parzione swap non veniva riconsciuta da gparted, ora la vede)
Ho la home criptata (accidenti a me, è una dannazione)
Utilizzo linux mint 17 Cinnamon

Questi sono gli output di alcuni comandi che ho capito essere importanti

Codice:
# sudo gedit /etc/fstab
/etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=e214ef12-388d-410d-a206-1da0fc835f5b /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=a07d421c-186e-4c03-b234-4173f2f6dac8 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
#UUID=7476ad70-8142-4b35-a109-a31057701fee none            swap    sw              0       0
/dev/mapper/cryptswap1

sudo gedit /etc/crypttab
Codice:
cryptswap1 UUID=7476ad70-8142-4b35-a109-a31057701fee /dev/urandom swap,cipher=aes-cbc-essiv:sha256,offset=8

sudo blkid
Codice:
/dev/sda1: LABEL="SYSTEM" UUID="9A043F4A043F28A1" TYPE="ntfs"
/dev/sda2: UUID="3080DE8B80DE5746" TYPE="ntfs"
/dev/sda3: UUID="e214ef12-388d-410d-a206-1da0fc835f5b" TYPE="ext4"
/dev/sda5: UUID="dfbdda56-0c98-499b-aad6-8b6fecd1bc17" TYPE="swap"
/dev/sda6: UUID="a07d421c-186e-4c03-b234-4173f2f6dac8" TYPE="ext4"

sudo fdisk -l
Codice:
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 testine, 63 settori/tracce, 60801 cilindri, totale 976773168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x1d2064ac

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      409599      203776    7  HPFS/NTFS/exFAT
/dev/sda2          409600   205209599   102400000    7  HPFS/NTFS/exFAT
/dev/sda3       205209600   225689599    10240000   83  Linux
/dev/sda4       225691646   976773119   375540737    5  Esteso
/dev/sda5       225691648   228763647     1536000   82  Linux swap / Solaris
/dev/sda6       228765696   976773119   374003712   83  Linux


Così ad occhio, da ignorante che ha letto qua e là tutta la faccenda, sembra che ci sia un problema di coincidenza di UUID...cioè lo UUID della cryptswap sia diverso da quello della swap trovata in /dev7sda5.
Capisco che sia tutto un po' incasinato, anche perchè ho già smanettato parecchio  Blush spero di aver fornito tutte le informazioni necessarie. Grazie in anticipo per l'aiuto!

p.s. potrò riconsultare il forum solo in serata, quindi non c'è fretta  Smile
Cita messaggio
Grazie da:
#2
quella correta è la risposta di blkid.
correggi le altre. salva prima di chiudere.
Cita messaggio
Grazie da:
#3
Cioè in pratica correggo lo UUID di etc/fstab e di etc/cryptswap usando come riferimento l'output di blkid...ok, adesso provo e vi faccio sapere.
Cita messaggio
Grazie da:
#4
Niente, purtroppo ancora la swap non è disponibile. Ricapitolando tutti i passaggi che ho fatto

- all'inizio da gparted la partizione swap era segnata sconosciuta. Dato il comando blkid, la partizione dedicata alla swap non appariva proprio. Per cui ho riformattato la swap da gparted, e adesso la swap è riconosciuta sia da gparted sia dal comando blkid.
- Appurato che gli UUID non corrispondevano, li ho modificati usando come parametro quello risultante dal comando blkid, sia in ect//fstab che in ect/cyptswap

Tuttavia la partizione swap continua a risultare "non disponibile" da monitor di sistema. Potrebbe essere utile tentare il comando sudo swapon -a, tentare cioè di "accendere" la swap (perdonate la terminologia grossolana)?
Cita messaggio
Grazie da:
#5
Ma poi in fstab hai tolto il "#" dalla linea che identifica la swap?

Bye,
Token
Cita messaggio
Grazie da:
#6
Finalmente! Grazie Token, era proprio quello il problema...non avevo rimosso l'asterisco dalla linea che identifica la swap!

Metto "risolto" nel titolo, spero per chi avrà il mio stesso problema che i passaggi di risoluzione siano abbastanza chiari!

Grazie a tutti!
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)