Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] SWAP non disponibile
#1
Scusate reinvio

Ho da alcuni giorn1 installato Ubuntu 14.04 Plus Remix LTS  al posto della versione 12.10 ed ho notato un notevole rallentamento fino al blocco quando usavo uno dei due  Browser preinstallati. Analizzando il Monitor di Sistema ho visto che la Swap non risulta disponibile,
mentre la situazione della partizione del disco è allegata in cui si nota la presenza della swap in un file esteso.

Mi potreste aiutare a riattivare l'utilizzo della Swap che presumo sia la causa di tutto oppure il problema è di altro tipo.

Grazie a tutti coloro che vorranno aiutarmi


Allegati Anteprime
       
Cita messaggio
Grazie da:
#2
In un terminale scrivi
free
invio
e posta il risultato .
Con questo comando vedi se è disponibile al sistema..
Cita messaggio
Grazie da:
#3
Non è attiva la swap, se lo fosse mostrerebbe il simbolo del lucchetto in gparted.
Qui indica come risolvere.

Poi hai un avviso di errore nella partizione sda1, in window fagli un scandisk.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#4
con quel processore e quella RAM è meglio che installi Lubuntu se vuoi rimanere nella famiglia *ubuntu
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#5
Anzitutto grazie a tutti
X Bilodiego
ho fatto secondo le indicazioni trovate al link da te indicato solo che non so dove inserire l'indirizzo UUID visto che il file /etc/fstab mi da la seguente situazione :
____________________________________________________________________________________
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# /
UUID=d9b72ff5-c987-40d7-a641-a88bf22fb626 / ext4 defaults,errors=remount-ro 0 1
_____________________________________________________________________________________
dove la partizione di swap ne la estesa sono presenti .....?

x Tuxino
probabilmente hai ragione ma con la precedente versione 12.10 ubunto andava benissimo.

grazie
Cita messaggio
Grazie da:
#6
12.10 era 12.10 probabilmente il tuo hardware non ce la fa a supportare 14.04 e secondo me la swap c'entra poco, anzi peggiora la situazione perché con quella RAM swappa sicuro e la swap e moooolto più lenta della RAM.

comunque se vuoi provare posta l'output di
Codice:
sudo blkid

che vediamo la riga giusta da aggiingere a fstab
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
Fermo restando che è bene che la swap sia attivata, giusto nel qual caso non bastasse la ram, concordo con tuxino è troppo pesante ubuntu 14.04 ,se poi hai anche degli effetti grafici attivati peggio ancora, cmq non migliori la situazione, decisamente è meglio che passi a lubuntu o almeno a xubuntu, o se se proprio vuoi usare ubuntu passa alla versione 12.04, che è supportata fini al 2017.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#8
Grazie ancora
dunque voglio seguire il vostro consiglio e passare ad una versione più leggera,
quale mi consigliate in ragione anche della documentazione che posso reperire su questo fantastico sito del prof. Cantaro, che non posso non citare per ringraziarlo insieme a tutti voi,?

Inoltre questa partizione di swap è comunque necessario che venga attivata prima di caricare il nuovo SW ? Nel caso questa è la situazione:

________________________________________________________________________________
/dev/sda1: LABEL="446119" UUID="8C30F69230F6830E" TYPE="ntfs"
/dev/sda2: UUID="d9b72ff5-c987-40d7-a641-a88bf22fb626" TYPE="ext4"
/dev/sda5: LABEL="Dati" UUID="4719C5A07FFB737D" TYPE="ntfs"
/dev/sda6: UUID="b0bf835b-ee54-496c-8b79-c2324de76033" TYPE="swap"
________________________________________________________________________________

solo che volendo sostituire l' UUID non trovo dove possa farlo in quanto il file fstab mi da questo:

__________________________________________________________________________
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# /
UUID=d9b72ff5-c987-40d7-a641-a88bf22fb626 / ext4 defaults,errors=remount-ro 0 1
______________________________________________________________________________

buona giornata
Cita messaggio
Grazie da:
#9
intanto apri il tuo file fstab come amministratore, nel terminale:

Citazione:sudo gedit /etc/fstab

invio, pswd che non vedrai scritta, invio. ora nella finestra che si apre incolla la riga:

Citazione:UUID= b0bf835b-ee54-496c-8b79-c2324de76033 none            swap    sw              0       0
il tuo fstab diventerà cosi:


Citazione:# /etc/fstab: static file system information.

#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# /
UUID=d9b72ff5-c987-40d7-a641-a88bf22fb626 / ext4 defaults,errors=remount-ro 0 1
UUID=b0bf835b-ee54-496c-8b79-c2324de76033 none            swap    sw              0       0

salva prima di chiudere il file. ora riavvia il computer e dovresti vedere rilevata la tua memoria virtuale. se ti interessa provare una distribuzione che richiede meno risorse, tra le molte che avrai a disposizione guarda:


http://www.istitutomajorana.it/index.php...&Itemid=33
Cita messaggio
Grazie da:
#10
x dxgiusti
intanto ti ringrazio e ti dico di aver fatto come da te indicato, compresi gli intervalli degli spazi, allego la schermata del file fstab salvato.
Al riavvio  mi è comparsa la scritta S per omettere oppure M per Manuale, ho lasciato fare ed alla fine si è spento. Fatto ripartire e data l'opzione S il programma si è aperto normalmente consentendomi di inviare il comando free dal terminale (sotto la schermata).

Quindi ho cancellato le modifiche apportate ed il programma riparte normalmente. In sostanza la swap tuttora risulta non disponibile.

Quindi volendo installare Xubuntu come da te suggerito, chiederei anche a bilodiego, che ho scoperto che ne ha curato la realizzazione, di darmi opportuni suggerimenti data la situazione della partizione del mio disco.

Grazie ancora e saluti


Allegati Anteprime
       
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)