Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO} Sistema pacchetti danneggiato in Ubuntu 16.04
#1
Buongiorno,

Scaricando degli aggiornamenti il sistema mi da questo avviso: qualcuno può suggerirmi come procedere o qualche guida per risolvere ? Grazie

Il sistema di pacchetti è danneggiato

Verificare se sono in uso repository di terze parti. Qualora così fosse, disabilitarli, poiché questi sono talvolta causa di problemi.
Inoltre eseguire il seguente comando in un terminale: apt-get install -f

I seguenti pacchetti presentano dipendenze non soddisfatte:

grub-pc: Depends: grub-common (= 2.02~beta2-36ubuntu3.11) ma 2.02~beta2-36ubuntu3.9 è installato
         Depends: grub2-common (= 2.02~beta2-36ubuntu3.11) ma 2.02~beta2-36ubuntu3.11 è installato
         Depends: grub-pc-bin (= 2.02~beta2-36ubuntu3.11) ma 2.02~beta2-36ubuntu3.11 è installato
grub-pc-bin: Depends: libc6 (>= 2.7) ma 2.23-0ubuntu7 è installato
             Depends: libdevmapper1.02.1 (>= 2:1.02.36) ma 2:1.02.110-1ubuntu10 è installato
             Depends: grub-common (= 2.02~beta2-36ubuntu3.11) ma 2.02~beta2-36ubuntu3.9 è installato
grub2-common: Depends: grub-common (= 2.02~beta2-36ubuntu3.11) ma 2.02~beta2-36ubuntu3.9 è installato
              Depends: libc6 (>= 2.7) ma 2.23-0ubuntu7 è installato
              Depends: libdevmapper1.02.1 (>= 2:1.02.36) ma 2:1.02.110-1ubuntu10 è installato
              Depends: liblzma5 (>= 5.1.1alpha+20120614) ma 5.1.1alpha+20120614-2ubuntu2 è installato
Cita messaggio
Grazie da:
#2
qualche casino con ppa esterni o proposed attivati, hai dei pacchetti installati che sono a versioni diverse di quelle richieste dal sistema, intanto hai provato a dare il comando suggerito? dopo aver disabilitato i ppa esterni?

prova a fare quello che ti dice, disabilita i ppa

Codice:
sudo software-properties-gtk

e alla scheda altro software, togli tutte le spunte che vedi, poi chiudi e dai 

Codice:
sudo apt update

e poi posta tutto  l'output di 

Codice:
sudo apt install -f

quando lo incolli qui, usa il tag codice
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#3
Ok faccio tutto poi posto.
Grazie mille i tanto !
Cita messaggio
Grazie da:
#4
Ciao,

Ecco l'output del comando da te fornitomi...grazie !

Codice:
mandelli@mandellipc:~$ sudo apt install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
 abiword-common ant ant-optional aspectj cups-browsed cups-core-drivers
 cups-daemon cups-filters-core-drivers cups-server-common default-jdk
 default-jdk-headless eclipse-platform-data eclipse-rcp fairymax fastjar
 fonts-horai-umefont fonts-noto fonts-noto-hinted fonts-noto-mono
 fonts-noto-unhinted fonts-unfonts-core geany-common geoclue-2.0
 geoip-database-extra gimp-help-common gimp-help-it gir1.2-gdesktopenums-3.0
 gir1.2-geocodeglib-1.0 gir1.2-gnomedesktop-3.0 gir1.2-gweather-3.0 gjs
 hoichess hplip-data ioquake3 ioquake3-server jarwrapper jmapviewer josm-l10n
 junit junit4 kde-l10n-it libabiword-3.0 libaec0 libamd2.4.1
 libapache-pom-java libarmadillo6 libarpack2 libasm3-java libasm4-java
 libaspectj-java libasyncns0:i386 libbabl-0.1-0 libc-ares2 libcamd2.4.1
 libccolamd2.9.1 libcglib3-java libchamplain-0.12-0 libchamplain-gtk-0.12-0
 libcholmod3.0.6 libclanapp-1.0v5 libcoin80v5 libcommons-beanutils-java
 libcommons-cli-java libcommons-codec-java libcommons-collections3-java
 libcommons-compress-java libcommons-dbcp-java libcommons-digester-java
 libcommons-httpclient-java libcommons-logging-java libcommons-parent-java
 libcommons-pool-java libcupscgi1 libcupsmime1 libdap17v5 libdapclient6v5
 libdb-java libdb-je-java libdb5.3-java libdb5.3-java-jni libeasymock-java
 libecj-java libenet7 libepsilon1 libequinox-osgi-java libexif12:i386
 libfelix-bundlerepository-java libfelix-gogo-command-java
 libfelix-gogo-runtime-java libfelix-gogo-shell-java libfelix-osgi-obr-java
 libfelix-shell-java libfelix-utils-java libflickcurl0 libfontembed1
 libfreexl1 libgdal1i libgegl-0.3-0 libgeoclue-2-0 libgeos-3.5.0 libgeos-c1v5
 libgeronimo-jpa-2.0-spec-java libgeronimo-osgi-support-java
 libgettext-commons-java libgjs0e libgles1-mesa libgoffice-0.10-10
 libgoffice-0.10-10-common libgpm2:i386 libgraphicsmagick-q16-3
 libgtkmm-3.0-1v5 libgutenprint2 libhamcrest-java libhdf4-0-alt libhdf5-10
 libhpmud0 libhttpclient-java libhttpcore-java libice-dev libice6:i386
 libicu4j-49-java libicu4j-java libidl-2-0 libieee1284-3:i386 libjetty8-java
 libjgraph-java libjgrapht0.8-java libjline-java libjpeg-turbo8:i386
 libjs-openlayers libjs-prototype libjs-scriptaculous libjsch-java
 libjson-c2:i386 libjtidy-java libkeybinder-3.0-0 libkeybinder0 libkmlbase1
 libkmldom1 libkmlengine1 libkxml2-java liblcms2-2:i386 liblensfun-data
 liblensfun0 liblink-grammar4 liblog4j1.2-java libloudmouth1-0 liblouis-data
 liblouis9 liblouisutdml-bin liblouisutdml-data liblouisutdml6
 liblucene2-java libmetadata-extractor-java libmikmod3 libminizip1
 libmozjs-24-0v5 libnetcdf11 libnghttp2-14 liboauth-signpost-java
 libobjenesis-java libodbc1 libogdi3.2 libogg0:i386 libopenjp2-7
 libopenscenegraph100v5 libopenthreads20 libopusfile0 liborbit2
 libosgi-annotation-java libosgi-compendium-java libosgi-core-java
 libosgi-foundation-ee-java libosmgpsmap-1.0-1 libots0
 libp11-kit-gnome-keyring:i386 libpaps0 libpq5 libproj9 libpthread-stubs0-dev
 libqgsttools-p1 libqpdf17 libqt4-help libqt4-scripttools libqt4-test
 libqt5multimedia5-plugins libqt5multimediawidgets5 libqt5serialport5
 libqtassistantclient4 libregexp-java libsamplerate0:i386 libsane-hpaio
 libsdl2-2.0-0 libservlet3.0-java libsm-dev libsm6:i386 libsmi2ldbl
 libsndio6.1 libspatialite7 libsuperlu4 libsvgsalamander-java
 libswt-cairo-gtk-3-jni libswt-glx-gtk-3-jni libswt-gnome-gtk-3-jni
 libswt-gtk-3-java libswt-gtk-3-jni libswt-webkit-gtk-3-jni libsz2
 libtidy-0.99-0 libtomcat7-java libumfpack5.7.1 liburiparser1
 libwireshark-data libwireshark6 libwireshark8 libwiretap5 libwiretap6
 libwrap0:i386 libwscodecs1 libwsutil6 libwsutil7 libwv-1.2-4 libx11-6:i386
 libx11-dev libx11-doc libxau-dev libxau6:i386 libxcb1:i386 libxcb1-dev
 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp-dev
 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxine2 libxine2-bin
 libxine2-doc libxine2-ffmpeg libxine2-misc-plugins libxine2-plugins
 libxinerama1:i386 libxmpcore-java libxrender1:i386 libxshmfence1:i386
 libxt-dev libxxf86vm1:i386 link-grammar-dictionaries-en
 linux-headers-4.4.0-24 linux-headers-4.4.0-24-generic linux-headers-4.4.0-28
 linux-headers-4.4.0-28-generic linux-headers-4.4.0-31
 linux-headers-4.4.0-31-generic linux-headers-4.4.0-34
 linux-headers-4.4.0-34-generic linux-headers-4.4.0-36
 linux-headers-4.4.0-36-generic linux-headers-4.4.0-38
 linux-headers-4.4.0-38-generic linux-headers-4.4.0-47
 linux-headers-4.4.0-47-generic linux-headers-4.4.0-51
 linux-headers-4.4.0-51-generic linux-headers-4.4.0-53
 linux-headers-4.4.0-53-generic linux-headers-4.4.0-57
 linux-headers-4.4.0-57-generic linux-headers-4.4.0-59
 linux-headers-4.4.0-59-generic linux-headers-4.4.0-62
 linux-headers-4.4.0-62-generic linux-headers-4.4.0-64
 linux-headers-4.4.0-64-generic linux-headers-4.4.0-66
 linux-headers-4.4.0-66-generic linux-headers-4.4.0-67
 linux-headers-4.4.0-67-generic linux-headers-4.4.0-72
 linux-headers-4.4.0-72-generic linux-headers-4.4.0-75
 linux-headers-4.4.0-75-generic linux-headers-4.4.0-77
 linux-headers-4.4.0-77-generic linux-image-4.4.0-24-generic
 linux-image-4.4.0-28-generic linux-image-4.4.0-31-generic
 linux-image-4.4.0-34-generic linux-image-4.4.0-36-generic
 linux-image-4.4.0-38-generic linux-image-4.4.0-47-generic
 linux-image-4.4.0-51-generic linux-image-4.4.0-53-generic
 linux-image-4.4.0-57-generic linux-image-4.4.0-59-generic
 linux-image-4.4.0-62-generic linux-image-4.4.0-64-generic
 linux-image-4.4.0-66-generic linux-image-4.4.0-67-generic
 linux-image-4.4.0-72-generic linux-image-4.4.0-75-generic
 linux-image-4.4.0-77-generic linux-image-extra-4.4.0-24-generic
 linux-image-extra-4.4.0-28-generic linux-image-extra-4.4.0-31-generic
 linux-image-extra-4.4.0-34-generic linux-image-extra-4.4.0-36-generic
 linux-image-extra-4.4.0-38-generic linux-image-extra-4.4.0-47-generic
 linux-image-extra-4.4.0-51-generic linux-image-extra-4.4.0-53-generic
 linux-image-extra-4.4.0-57-generic linux-image-extra-4.4.0-59-generic
 linux-image-extra-4.4.0-62-generic linux-image-extra-4.4.0-64-generic
 linux-image-extra-4.4.0-66-generic linux-image-extra-4.4.0-67-generic
 linux-image-extra-4.4.0-72-generic linux-image-extra-4.4.0-75-generic
 linux-image-extra-4.4.0-77-generic odbcinst odbcinst1debian2
 openarena-081-maps openarena-081-misc openarena-081-players
 openarena-081-players-mature openarena-081-textures openarena-085-data
 openarena-088-data openarena-data openarena-oacmp1 openjdk-8-jdk
 openjdk-8-jdk-headless openstreetmap-map-icons-classic
 openstreetmap-map-icons-square paps pastebinit proj-bin proj-data
 python-bluez python-configobj python-dbus python-elib.intl python-gconf
 python-gi python-gnome2 python-gobject python-keybinder python-liblarch
 python-notify python-pyorbit python-simplejson python-webkit python-yaml
 python3-notify2 python3-pexpect python3-pil python3-ptyprocess python3-pyqt4
 python3-renderpm python3-reportlab python3-reportlab-accel python3-sip qpdf
 sat4j scribus-trunk-data snap-confine ssl-cert stellarium-data
 supertuxkart-data tagainijisho-common tagainijisho-dic-en trophy-data
 ubuntu-core-launcher webkit-image-gtk wireshark-common x11proto-core-dev
 x11proto-input-dev x11proto-kb-dev xorg-sgml-doctools xtrans-dev
Usare "sudo apt autoremove" per rimuoverli.
The following additional packages will be installed:
 grub-common
Pacchetti suggeriti:
 multiboot-doc grub-emu xorriso desktop-base
I seguenti pacchetti saranno aggiornati:
 grub-common
1 aggiornati, 0 installati, 0 da rimuovere e 48 non aggiornati.
3 non completamente installati o rimossi.
È necessario scaricare 0 B/1.707 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 942125 file e directory attualmente installati.)
Preparativi per estrarre .../grub-common_2.02~beta2-36ubuntu3.11_amd64.deb...
Estrazione di grub-common (2.02~beta2-36ubuntu3.11) su (2.02~beta2-36ubuntu3.9)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Elaborazione dei trigger per systemd (229-4ubuntu17)...
Elaborazione dei trigger per ureadahead (0.100.0-19)...
ureadahead will be reprofiled on next reboot
Configurazione di grub-common (2.02~beta2-36ubuntu3.11)...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Configurazione di grub2-common (2.02~beta2-36ubuntu3.11)...
Configurazione di grub-pc-bin (2.02~beta2-36ubuntu3.11)...
Configurazione di grub-pc (2.02~beta2-36ubuntu3.11)...
Installing for i386-pc platform.
grub-install: avviso: Il settore 18 è già in uso dal programma "Acer registration utility (?)", viene saltato. Questo software potrebbe causare problemi di avvio, o altri, nel futuro. Informare gli autori e avvisarli di non archiviare dati nell'intervallo del MBR..
Installazione completata, nessun errore segnalato.
Generating grub configuration file ...
Trovata immagine linux: /boot/vmlinuz-4.4.0-79-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-79-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-78-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-78-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-77-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-77-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-75-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-75-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-72-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-72-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-71-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-71-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-67-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-67-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-66-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-66-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-64-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-64-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-62-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-62-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-59-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-59-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-57-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-57-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-53-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-53-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-51-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-51-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-47-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-47-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-42-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-42-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-38-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-38-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-36-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-36-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-34-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-34-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-31-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-31-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-28-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-28-generic
Trovata immagine linux: /boot/vmlinuz-4.4.0-24-generic
Trovata immagine initrd: /boot/initrd.img-4.4.0-24-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Trovato Windows Recovery Environment (loader) su /dev/sda1
Trovato Windows 7 (loader) su /dev/sda2
fatto
mandelli@mandellipc:~$ ^C
mandelli@mandellipc:~$
Cita messaggio
Grazie da:
#5
Pare che sia a posto.

Dai anche un
Codice:
sudo apt update && sudo apt dist-upgrade
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da: masunaga , masunaga
#6
Ciao tuxino,

Tutto a posto sembra, grazie mille per la consulenza professionale e veloce !
Cita messaggio
Grazie da:
#7
bene, ciao
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)