SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]Sistemi Operativi da hd interno ad esterno si può fare?
#1
Ciao a tutti
Sono qui ad esporvi un problema che non riesco a risolvere da solo, quindi vediamo se in gruppo riusciamo.
Ho un portatile che si è rotto, tastiera e touchpad morti irrecuperabili, ma l'hard disk è in buone condizioni, quindi l'ho tolto da pc e trasformato in hard disk esterno usb.
Fin qui tutto bene vedo il contenuto e posso intervenire come voglio.
In questo hd ci sono tre sistemi operativi manjaro pclinuxos e windows 8 c è modo di utilizzarli cosi come sono?
ho fatto varie prove fra le quali:
-Inserito a computer spento lo vedo e posso farlo partire al boot, solo che una volta avviato mi da schermata nera con scritto Grub e trattino lampeggiante(posso solo riavviare)
- se dal sistema che ho nel pc  faccio un sudo update-grub con il disco inserito al riavvio nel grub mi trovo anche i sistemi che sono nell'hard disk esteno ma se provo a farli partire escono fuori

Citazione:no such device uid del hd
you need to kernel device
avete idee, prima di spianare tutto.
            La vita è come uno specchio:ti sorride se la guardi sorridendo.
                                                    Un giorno senza rischio è non vissuto.....                  
PCLinuxOS Mate - Manjaro Mate/Xfce
Cita messaggio
Grazie da:
#2
Posso portare la mia esperienza, anche a me si e' rotta la tastiera del portatile, l'ho ordinata in internet e con pochi soldi l'ho sostituta, nulla di difficile.
Per quanto riguarda l'HD anch'io l'ho messo come esterno e mi parte il suo grub senza problemi da bios selezionando usb.
Per partire da bios, lo saprai gia', comunque, si preme esc o F10 o altro F a seconda del portatile.
Il messaggio dice che non trova l'indirizzo uid per avviarlo, tempo fa lo inserii manualmente ma la procedura e' impegnativa. Inoltre installai un so su chiavetta usb e il grub in mbr lo rilevo' .
"Il software libero con sorgenti aperte e' parte del futuro dell'umanita'. Permette alle menti piu' brillanti presenti sul pianeta, grazie al web, di perseguire i piu' alti obiettivi di progresso"
Cita messaggio
Grazie da:
#3
Grazie
Ho gia fatto con il bios ma non ottengo niente come detto sopra mi fa schermata nera con scritto grub e trattino lampeggiante.
Ulteriori info.
Pensavo che il problema fosse che sul pc fisso dove l'ho provato la prima volta, li ho un sistema senza efi quindi mdr mentre l'hard disk esterno ha tabelle gpt e sistemi installati in efi.
Poi però ho fatto la stessa prova su un portatile recente con efi e tabelle gpt e il risultato è il medesimo.
HD come sopra viene visto i sistemi vengono visti ma non si avvia.
            La vita è come uno specchio:ti sorride se la guardi sorridendo.
                                                    Un giorno senza rischio è non vissuto.....                  
PCLinuxOS Mate - Manjaro Mate/Xfce
Cita messaggio
Grazie da:
#4
Proverei ad installare il grub sul HD esterno usando il comando:
Codice:
grub-install /dev/sdx
al posto di sdx metti ovviamente il device corrispondente al tuo hd esterno.
in seguito aggiorna il grub.
all'avvio, selezionando l'hd usb dovrebbe partire la schermata di grub per l'avvio dei SO.
Linux User # 207701 - Non ho particolari talenti. Sono soltanto appassionatamente curioso - Albert Einstein
Cita messaggio
Grazie da:
#5
alcune considerazioni:
avviare un sistema win installato su un determinato hardware in altro hardware è pazzesco. non farlo mai!
il tuo computer ha l'avvio da mbr. non avvierai mai i sistemi con grub efi.
però è possibile farlo.
elimina la partizione efi su disco. crea all'inizio del disco una partizione di cica 128 mb "non formattata", dagli il flag >>> boot-bios.
avvia i tuoi sistemi ( non win ) con supergrubdisk, installa grub in dev/sddisco_esterno, senza specificare la partizione.
riavvia. se al boot farai partire il disco interno, devi aggiornare il grub.
la partizione di win la puoi cestinare.
buon lavoro
Cita messaggio
Grazie da:
#6
Si una delle cose che ho fatto è stata anche quella l'ho ripetuta adesso e il risultato è questo

Codice:
sudo grub-install /dev/sdb
Installazione per la piattaforma i386-pc.
grub-install: avviso: questa etichetta della partizione GPT non contiene BIOS Boot Partition, l'embed non è possibile.
grub-install: errore: L'embed non è possibile, ma è richiesto per l'installazione su più dischi.
e in effetti il problema sembra legato al sistema di partizionamento mbr e gpt credo che non possano comunicare o è tutto mbr o è tutto gpt.

PS. adesso provo su portatile con stesso tabella partizioni e efi.
------------------------------
Grazie dxgiusti  in effetti windows non mi interessa però linux se posso vorrei tenerlo quindi provo a fare come come dici At
            La vita è come uno specchio:ti sorride se la guardi sorridendo.
                                                    Un giorno senza rischio è non vissuto.....                  
PCLinuxOS Mate - Manjaro Mate/Xfce
Cita messaggio
Grazie da:
#7
Devi creare a inizio disco una partizione EFI dove posizionare il grub se hai avvio in Uefi.

O MBR o EFI, devi scegliere, come hai detto tu non possono coesistere.
Non fornisco supporto per XP, lasciatelo andare.......Ha fatto il suo lavoro Confused
Cita messaggio
Grazie da:
#8
no, non devi creare una partizione efi ma eliminare quella che hai e creare una partizione non formattata quelle che gparted visualizza con il contorno nero e dargli il flag bios-grub
Cita messaggio
Grazie da:
#9
(01-05-2019,13:57 )dxgiusti Ha scritto: elimina la partizione efi su disco. crea all'inizio del disco una partizione di cica 128 mb "non formattata", dagli il flag >>> boot-bios.
avvia i tuoi sistemi ( non win ) con supergrubdisk, installa grub in dev/sddisco_esterno, senza specificare la partizione.
riavvia. se al boot farai partire il disco interno, devi aggiornare il grub.
la partizione di win la puoi cestinare.
buon lavoro

Come sempre grazie in effetti quello che mi premeva era linux.
Come hai detto non ho fatto altro che eliminare la partizione con efi e poi fare con supergrubdisk.
I sistemi linux si avviano la/le partizioni win lo già eliminate.
Problema risolto Grazie a tutti per gli interventi fatti.
Un plauso particolare a DXGiusti At
            La vita è come uno specchio:ti sorride se la guardi sorridendo.
                                                    Un giorno senza rischio è non vissuto.....                  
PCLinuxOS Mate - Manjaro Mate/Xfce
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)