Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Spostare o Disinstallare Grub
#1
Buona sera a tutti!
ho istallato ubuntu 16.4 in dual boot con windows 8 preinstallato in EFI
la procedura è andata a buon fine.
Ma purtroppo durante la formatazione delle partizioni necessarie alla installazione di ubuntu, invece di lasciare come luogo per la installazione del boot manager la posizione data in automatico dell'installer (dev/sda "nome hard disk"), come credo dovesse fare;
ho inserito dev/sda2, che è la partizione EFI dove si trova il boot di windows 8.

Non e Gravissimo, riesco ad accedere a windows modificando l'ordine del bios.
invece se faccio partire grub, riesco solo ad accedere a ubuntu, se tento di entrare in windows, mi da un qualche errore e torna alla home di grub.

ora la domanda è:
ho sbagliato l'installazione?
si può correggere spostando grub?
sono un po arrugginito di ubuntu...
non saprei da dove ricominciare, potete suggerirmi qualche soluzione?

grazie
Cita messaggio
Grazie da:
#2
se vuoi installare il grub nella posizione predefinita al momento dell'installazione du Ubuntu puoi dare da terminale:
Codice:
sudo grub-install /dev/sda
dai invio, immetti la password anche se non si vede e dai invio.
a questo punto il bootloader è installato nell'MBR dl primo disco.
Per aggiornare le opzioni dai:
Codice:
sudo update-grub
Per altre info guarda:
http://wiki.ubuntu-it.org/AmministrazioneSistema/Grub
Linux User # 207701 - L'intelligenza non è non commettere errori, ma scoprire subito il modo di trarne profitto.
Cita messaggio
Grazie da:
#3
non credo che quanto sopra detto possa funzionare. Daniel parla di EFI, quindi installazione del grub in quella partizione.
installando ubuntu con EFI in automatico lui segnala la partizione in fat32 per il grub. penso vada messo il punto di mount boot/efi.
windows otto per impostazione predefinita ha attivato il fastboot, va disattivato.
Cita messaggio
Grazie da:
#4
(06-11-2016,11:11 )dxgiusti Ha scritto: non credo che quanto sopra detto possa funzionare. Daniel parla di EFI, quindi installazione del grub in quella partizione.
installando ubuntu con EFI in automatico lui segnala la partizione in fat32 per il grub. penso vada messo il punto di mount boot/efi.
windows otto per impostazione predefinita ha attivato il fastboot, va disattivato.
Vero. Blush Nella pagina che ho linkato precedentemente c'è un rimando a UEFI ed al bootloader qui a fondo pagina:
http://wiki.ubuntu-it.org/Amministrazion...one%2FUEFI
Linux User # 207701 - L'intelligenza non è non commettere errori, ma scoprire subito il modo di trarne profitto.
Cita messaggio
Grazie da:
#5
infatti ho risolto.. anche se non so di preciso adesso dove sta il grub, visto che prima di risolvere ho provato la soluzione di "m3nhir"...
dopo di che ho scoperto che dovevo da bios, oltre a disattivare secure boot (che era gia su DISABLED) ma rimaneva comunque attivo....
dovevo settare "BOOT LEGACY",invece di UEFI, e impostare Come primo punto di boot EFI FIRT...

scusate ma sono andato a memoria se riesco vi faccio uno sreenshot del prima e dopo se può essere utile ad altri
adesso funziona alla perfezione..
Grazie
Cita messaggio
Grazie da:
#6
come inserisco RISOLTO???
Grazie
Cita messaggio
Grazie da:
#7
http://www.istitutomajorana.it/forum2/Th...nel-Titolo


Grazie
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)