Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Ubuntu 14.04. Sni avvia solamente con "sudo startx"!
#1
Tre giorni fa ho spento il pc e al riavvio è comparsa una schermata nera. Ho atteso oltre 30 minuti e stante il perdurare delle medesima schermata ho premuto CTR-ALT-F3. Ho digitato "startx" e è iniziato lo scorrere delle informazioni sullo schermo.
Ho riavviato ed è stato ancora peggio che andar di notte! Nessun segno di vita.
Ho rimosso .Xauthority ( con ubuntu 12.10 ha sempre funzionato!), macchè!
L'ennesima grande "pensata": CTRL-ALT-F2 poi "sudo startx".
Miracolo? si è avviato, naturalmente in modalità root.
Ho recuperato dei dati che mi servivano urgentemente.
Ho spento. Ho riacceso e Ubunto si è avviato! fermandosi però alla richiesta di Login, mentre prima c'era lo start automatico.
Pazienza. Inserisco la password. Una breve attesa e poi torna alla schermata di login.
Verifico la password inserendone una errata e il sistema mi avvisa che la password è errata.
Credo di avere combinato qualche -grosso- guaio nei permessi nel dare "sudo startx" .
Chi mi può dare un suggerimento per ripristinare il sistema -senza formattare!- è recuperare la totalità delle funzioni?
Intanto ho recuperato i dati "importanti" ma non posso perdere i programmi installati.
Aiutatemi...
Cita messaggio
Grazie da:
#2
Ciao,
non so se funzioni ma potrestii provare a assegnare una nuova password al tuo account o in alternativa creare un nuovo utente.

Qui c'è una spiegazione più dettagliata: http://wiki.ubuntu-it.org/Sicurezza/Gest...d/Recupero
Chi sa capire tutto è molto infelice (Maksim Gor'kij)
[Immagine: http://www.istitutomajorana.it/forum2/at...p?aid=7740]
Cita messaggio
Grazie da:
#3
prova a seguire questo e se non funziona il link al messaggio successivo
http://www.istitutomajorana.it/forum2/Th...8#pid48108
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#4
Aggiungo ai consigli dei nostri 2 amici, di fare un backup di TUTTI i dati che hai nella cartella Home o da altre parti, non solo dei dati importanti.
Tanto per non dover piangere dopo. Spero vivamente di no.
Buon lavoro.
Cita messaggio
Grazie da:
#5
E' probabile che qualche configurazine Unity/Compiz sia saltata per qualche motivo.

Dopo essere passata ad un diverso terminale (CTRL+ALT+F2) ed entrata con l'utente "sballato", se non è installato dconf-tools provvedi
Codice:
$ sudo apt-get install dconf-tools
quindi
Codice:
$ dconf reset -f /org/compiz/
$ setsid unity
$ unity --reset-icons
se il comando con il dconf restituisce strani errori provvedi a rimuovere la configurazione con
Codice:
$ mv ~/.config/dconf/ ~/.config/dconf.bak
e ripeti.
Alla fine vedi se l'ambiente desktop dell'utente funziona con
Codice:
$ sudo service ligthdm restart
Ricordati eventualmente (ma non è strettamente necessario) di tornare nel terminale prima aperto (CTRL+ALT+F2) e dare
Codice:
$ exit
quindi (CTRL+ALT+F7).

Spero funzioni.

Bye,
Token
Cita messaggio
Grazie da:
#6
A volte succede anche a me. Piange
Risolvo in due modi. Questo è un modo:
dalla schermata di login premo CTR-ALT-F1 alla richiesta inserisco nome utente e quindi password poi faccio una copia di .Xauthority digitando
sudo mv .Xauthority Xauthority.bak
quindi digito
sudo chmod 775 .Xauthority
Riavvio e spero. A volte funziona al primo colpo. A volte invece... Disperato
Cita messaggio
Grazie da:
#7
Grazie a tutti!
Ho risolto con il suggerimento di felix.
Gli comunico che al primo tentativo e' andato tutto a posto.
Come si mette Risolto?
Cita messaggio
Grazie da:
#8
In questo modo:

http://www.istitutomajorana.it/forum/Ann...nel-Titolo
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)