Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] VIRTUAL BOX 5 E PERIFERICHE USB
#1
Salve,
lavoro con mint 17 e utilizzo virtualbox per le applicazioni windows quando servono.
Da quando ho installato la versione 5 continuo ad avere problemi con le periferiche usb
Se attivo usb 2 la macchina virtuale non parte e mi da un errore
Naturalmente ho  l'extension pack installato ma è lo stesso
Ho provato anche la versione virtualbox-nonfree ma niente le macchine virtuali mi partono solo se disabilito usb

Qualcuno sa come risolvere il problema?
Cita messaggio
Grazie da:
#2
Ti sei accertato che extension pack/ guest addiction siano della stessa versione ?In tal caso non dovrebbe nemmeno installarsi,ma un controllo lo farei comunque.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#3
Leggi QUESTA guida, io ho risolto così. Smile
Distro: Ubuntu 16.04 LTS x86_64 -- DE: MATE 1.12.1
Cita messaggio
Grazie da: bilodiego
#4
Uso virtual box da anni e non mi ha mai dato problemi.
Il problema dell'aggiunta al gruppo lo aveva un paio di versioni fa, adesso aggiunge l'utente al gruppo automaticamente con l'installazione.
La 4.3 funzionava perfettamente, potrei anche retrocedere tentando di reinstallare la versione precedete ma non so se poi mi apre la VM sulla quale ho installato l'extension della 5.0.

Comunque il messaggio è il seguente:

The device helper structure version has changed.
If you have upgraded VirtualBox recently, please make sure you have terminated all VMs and upgraded any extension packs. If this error persists, try re-installing VirtualBox. (VERR_PDM_DEVHLPR3_VERSION_MISMATCH).
Codice 'uscita:
NS_ERROR_FAILURE (0x80004005)
Componente:
ConsoleWrap
Interfaccia:
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Naturalmente può essere che abbia installato la nuova versione con la VM salvata e non chiusa, ma non penso sia questo il problema.
Cita messaggio
Grazie da:
#5
Dalla traduzione del messaggio sembra essere propio quello il problema.

Codice:
La versione della struttura di supporto del dispositivo è cambiato.
Se si è aggiornato VirtualBox di recente, si prega di assicurarsi di aver terminato tutte le macchine virtuali e aggiornato eventuali pacchetti di estensione. Se l'errore persiste, provare a reinstallare VirtualBox.
La vita è come uno specchio:ti sorride se la guardi sorridendo.
Cita messaggio
Grazie da:
#6
Dopo vari tentativi ho trovato il problema:

dopo aver rimosso tutte le installazioni da codice
sudo apt-get remove virtualbox virtualbox-4.* virtualbox-5.0
sudo apt-get install -f

ho scaricato ed installato la versione
virtualbox-5.0_5.0.16-105871-Ubuntu-trusty_amd64.deb

quindi sbagliavo a scaricare l'ultima

poi l'extension pack

e adesso funziona tutto bene
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)