Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] WIFI e cose strane
#1
Salve, cercherò di essere breve,
ho cambiato gestore, prima avevo Vodafone con la Station1 e adesso sono passato a Fastweb e, da qualche giorno (venerdi 28/11/2014) mi è stata attivato.
Dunque, ho due computer un Desktop e un portatile, ambedue collegati al modem tramite Wifi;
il portatile con scheda interna 802.11 e il PC con chiavetta USB adattatore di rete TP-LINK  TL-WN723N; con Vodafone tranne i primi travagliati tempi tutto ha poi funzionato senza problemi anche quando sul PC desktop con Windows 7 ho installato in dual boot Ubuntu 14.04 plus remix 64 bit, il Wifi non mi ha dato mai problemi nè con Win nè con Ubuntu.
Ora, passando a Fastweb la velocità è raddoppiata e tutto funziona tranne che per un particolare che considero strano:

premetto che il portatile (Win XP, Xubuntu 14.04) va benissimo;
invece con il PC mi capita questo:
quando lavoro in windows il Wifi funziona alla grande e, da quando l'ho connesso la prima volta al modem (Fastweb Technicolor) non mi ha dato nessun problema mentre, quando passo ad Ubuntu, nei primi minuti va tutto molto bene (come Win) ma, con il passare del tempo incomincia a rallentare sempre di più fino al bloccaggio nel senso che gli indicatori di caricamento incominciano a girare girare girare... fino all'avviso di errore di impossibilità di connettersi a Internet, da questo momento in poi non apre più niente, sembra che il computer sia disconnesso pur essendo connesso; il tutto, dal funzionamento completo al bloccaggio si svolge nell'arco di 5/6 minuti rendendo di fatto Internet inutilizzabile, infatti vi scrivo da Windows perchè con Ubuntu non farei in tempo.
Strano no? che ne dite? Avrei capito se non funzionava proprio, ma così...

Ho nel frattempo fatto queste esperienze:
1) se stacco la chiavetta USB e la rimetto il tutto ricomincia da capo - va bene poi, pian piano si blocca -;
2) se disconnetto da computer e poi riconnetto - come sopra -;
3) se sul modem chiudo il wifi e poi, lo riattivo - come sopra -.
Se siete arrivati a leggere fino a questo punto Vi ringrazio per la pazienza, spero vivamente che mi possiate dare la dritta giusta.

Cordialmente...
Cita messaggio
Grazie da:
#2
Collega la usb wireless poi da terminale dai lsusb posta il risultato


Cita messaggio
Grazie da:
#3
Ciao brunik,
Codice:
alfredo@alfredo:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 056a:0022 Wacom Co., Ltd Intuos 9x12
Bus 003 Device 002: ID 046d:c52e Logitech, Inc.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
alfredo@alfredo:~$
Ecco qua!
Cita messaggio
Grazie da:
#4
Copia incolla nel terminale
Codice:
wget -N -t 5 -T 10 https://dl.dropbox.com/s/qjc87hzk1z5x6z0/wireless_script && chmod +x wireless_script && ./wireless_script
Aggiungi la password quando la richiede,quando finisce il lavoro nella home sarà presente un file wireless info.txt
che puoi allegare sul forum.


Cita messaggio
Grazie da:
#5
Ho eseguito il comando,
ti allego il file wireless-info.txt;
ti informo che contemporaneamente si è generato anche un file wireless_script.


Allegati
.txt   wireless-info.txt (Dimensione: 13,02 KB / Download: 7)
Cita messaggio
Grazie da:
#6
Lo script nella home è quello che abbiamo scaricato e usato per generare il file txt,se vuoi ora lo puoi cancellare.
Il problema sembra molto comune, la cosa strana è a quanto pare che prima non capitava usando la vodafone station.
Da terminale prova ad installare questo fix ai driver dando un comando per volta
Codice:
sudo apt-get install linux-headers-generic build-essential dkms git
Continua
Codice:
git clone https://github.com/pvaret/rtl8192cu-fixes.git
E a seguire con
Codice:
sudo dkms add ./rtl8192cu-fixes
Poi
Codice:
sudo dkms install 8192cu/1.9
Ricarica i moduli dando
Codice:
sudo depmod -a
Metti in blacklist i driver nativi del kernel che non vanno bene dando
Codice:
sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/
Riavvia


Cita messaggio
Grazie da:
#7
P E R F E T T O ! ! !,

brunik sei un mago del terminale, non posso dire altro, ho immesso i comandi con la sequenza che mi hai indicato (non senza difficoltà, lo disconnettevo e lo riconnettevo ad ogni comando per impedire il bloccaggio), terminata la sequenza ho riavviato e... udite udite Ubuntu va come una scheggia, anche meglio di Windows;
adesso nel momento che scrivo è più di un'ora che va alla perfezione.
Ti volevo pure dire che nella mia home adesso è presente la cartella rtl8192cu-fixes che credo sia il risultato della procedura fatta (quello è il suo posto?).
Per quel che riguarda Vodafone fin dal primo momento quando ho incominciato a strimpellare con la live non ho mai avuto problemi né di connessione né di Internet e così è continuato anche dopo l'installazione definitiva fino a quando ho staccato la Vodafone Station ed ho attaccato il modem Fastweb, da quel momento è iniziato il problema, che tu dici essere molto comune, ma in definitiva qual'era questo problema?

A proposito della procedura che mi hai fatto eseguire mi piacerebbe proprio sapere che cosa ho fatto, una stringata spiegazione sarebbe bene accetta.

Ti sono debitore, ancora grazie per avermi aiutato a risolvere e, se non ci dovessimo risentire ti lascio i miei sinceri auguri di Buon Natale e Happy new year!

Alfredo
Cita messaggio
Grazie da:
#8
Ottimo che hai risolto Tongue
A quanto pare tutte le chiavette usb wireless che utilizzano il chip realtek RTL8188CUS possono avere questo tipo
di problema quando utlizzano i driver caritati dal kernel rtl8192cu.L'ipotesi è che in realtà con la vodafon station
la usb viaggiasse a velocità inferiori della sua reale capacità e non vi erano disconnessioni,mentre con fastweb viene sfruttata la capacità wi-fi n mode della pennetta e i driver non vanno più bene .Per questo abbiamo scaricato e installato una versione adatta al kernel in uso ottimizzata per superare il problema.La cartella rtl8192cu-fixes non dovrebbe più servire,ma comunque lasciala
nella home.Ricambio gli auguri di buon natale e buon anno.


Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)