Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Webcam con ubuntu 12.04 plus
#1
Exclamation 
Ciao a tutti.

Ritorno con un vecchio problema riguardante la webcam del mio portatile ASUS f5r con ubuntu 12.04 plus LTS.
Il problema era che ad ogni aggiornamento del kernel la webcam non funzionava.
Tempo fa era stata trovata una soluzione con righe di comando da terminale, dalla quale ho ricavato una procedura che ha funzionato fino ad oggi:

Codice:
svn co https://svn.code.sf.net/p/syntekdriver/code/trunk/driver
cd syntek/driver
make -f Makefile.standalone clean
make -f Makefile.standalone
sudo modprobe videodev
sudo insmod stk11xx.ko

basta farlo una sola volta.
Qui la webcam dovrebbe funzionare ma non è stabile.Nel senso che al riavvio non funzionerà.

Quindi ho proceduto digitando:

ls /lib/modules/(inserire il codice del nuovo kernel. Per esempio: 3.2.0-76-generic-pae)/

Poi creazione della directory 'extra' nel kernel (se non è già presente):

sudo mkdir /lib/modules/`uname -r`/extra/
sudo chmod -R 644 /lib/modules/`uname -r`/extra/


Infine caricamento del driver nel kernel, in modo che al riavvio successivo del pc la webcam sia funzionante:


sudo cp ~/syntek/driver/stk11xx.ko /lib/modules/`uname -r`/extra/
sudo chmod 744 /lib/modules/`uname -r`/extra/stk11xx.ko
sudo depmod -a

e anche in questo caso l'operazione va fatta soltanto una volta (ovviamente va ripetuto ogni volta che aggiorni il kernel).

Oggi, appunto, ho effettuato degli aggiornamenti tra cui il nuovo kernel 3.2.0-101-generc-pae.
Seguendo la procedura per ripristinare la webcam, ad un certo punto esce un errore mai apparso con i precedenti aggiornamenti:

Codice:
gigi@gigi-F5R:~$ cd syntek/driver
gigi@gigi-F5R:~/syntek/driver$ make -f Makefile.standalone clean
make -C /lib/modules/3.2.0-101-generic-pae/build SUBDIRS=/home/gigi/syntek/driver clean
make[1]: ingresso nella directory "/usr/src/linux-headers-3.2.0-101-generic-pae"
 CLEAN   /home/gigi/syntek/driver/.tmp_versions
 CLEAN   /home/gigi/syntek/driver/Module.symvers
make[1]: uscita dalla directory "/usr/src/linux-headers-3.2.0-101-generic-pae"
gigi@gigi-F5R:~/syntek/driver$ make -f Makefile.standalone
make -C /lib/modules/3.2.0-101-generic-pae/build SUBDIRS=/home/gigi/syntek/driver modules
make[1]: ingresso nella directory "/usr/src/linux-headers-3.2.0-101-generic-pae"
 CC [M]  /home/gigi/syntek/driver/stk11xx-usb.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-v4l.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-sysfs.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-buf.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-bayer.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-0408.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-0500.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-a311.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-a821.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-6a31.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-6a33.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-6a51.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-6a54.o
 CC [M]  /home/gigi/syntek/driver/stk11xx-dev-6d51.o
 LD [M]  /home/gigi/syntek/driver/stk11xx.o
 Building modules, stage 2.
 MODPOST 1 modules
 CC      /home/gigi/syntek/driver/stk11xx.mod.o
 LD [M]  /home/gigi/syntek/driver/stk11xx.ko
make[1]: uscita dalla directory "/usr/src/linux-headers-3.2.0-101-generic-pae"
gigi@gigi-F5R:~/syntek/driver$ sudo modprobe videodev
[sudo] password for gigi:
gigi@gigi-F5R:~/syntek/driver$ sudo insmod stk11xx.ko
insmod: error inserting 'stk11xx.ko': -1 File exists
gigi@gigi-F5R:~/syntek/driver$

Cosa devo fare a questo punto?

Grazie.
Cita messaggio
Grazie da:
#2
Non so come ne perchè ma la webcam ha ripreso a funzionare co camorama.
Grazie comunque.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)