Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Wi-fi usb D-Link Ubuntu
#1
Buonasera, un amico ha installato Ubuntu 17.04 32bit su un vecchio Desktop, funziona tutto ma anche se vede il Wi-fi non si connette.
La chiavetta è una  D-Link USB Adapter Wireless 802.11b/g Via Technologies VT8235. 
In impostazioni, rete il Wi-fi è attivo e se va su connetti la rete prova a connettersi e dopo gli da: Disconnesso ora si è fuori rete.

Mi ha mandato questa foto, si vede male, domani mi faccio mandare il testo che restituisce il terminale a: sudo lshw -C network

Qualcuno sa risolvere? Vi chiedo pazienza in quanto è lontano da me e comunichiamo via E-mail, quindi chiedete pure più cose e comandi contemporaneamente per accorciare i tempi. Smile

ecco qua:

silvio@silvio-PC:~$ sudo lspci

[sudo] password di silvio:

00:00.0 Host bridge: VIA Technologies, Inc. VT8375 [KM266/KL266] Host Bridge

00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]

00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)

00:10.0 USB controller: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller (rev 80)

00:10.1 USB controller: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller (rev 80)

00:10.2 USB controller: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller (rev 80)

00:10.3 USB controller: VIA Technologies, Inc. USB 2.0 (rev 82)

00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge

00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV350 [Radeon 9550]

01:00.1 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] RV350 [Radeon 9550] (Secondary)



silvio@silvio-PC:~$ sudo lshw -C network

[sudo] password di silvio:

  *-network                

       description: Ethernet interface

       product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

       vendor: Realtek Semiconductor Co., Ltd.

       physical id: b

       bus info: pci@0000:00:0b.0

       logical name: enp0s11

       version: 10

       serial: 00:40:ca:54:56:47

       size: 10Mbit/s

       capacity: 100Mbit/s

       width: 32 bits

       clock: 33MHz

       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation

       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s

       resources: irq:18 ioport:d000(size=256) memory:e7000000-e70000ff memory:80000000-8000ffff

  *-network

       description: Wireless interface

       physical id: 1

       bus info: usb@1:1

       logical name: wlx001346ea6d52

       serial: fe:1e:f3:58:b1:c3

       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ar5523 driverversion=4.10.0-19-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11
Cita messaggio
Grazie da:
#2
Pensavo anche di fargli cambiare Network Manager con Wicd, con me su Ubuntu ha funzionato... Che ne dite?
Cita messaggio
Grazie da:
#3
Prova non si sa mai,ho notato che ha un protocollo vecchio,controlla sul router o modem che ci sia abilitato wireless b g e magari cambia password con un WEP al posto del sicuro WPA 2
Cita messaggio
Grazie da:
#4
Premetto che con Windows funziona ovviamente il Wi-Fi... Quindi non é un problema del Router ma di Ubuntu.
Cita messaggio
Grazie da:
#5
(27-07-2017,22:45 )rage75 Ha scritto: La chiavetta è una D-Link USB Adapter Wireless 802.11b/g Via Technologies VT8235.

Le chiavette D-Link hanno nomi di modello tipo DWG xxxx, DWA xxxx e simili (la parte VIA Technologies VT8235 credo proprio non c'entri nulla) vedi se riesci a recuperare quello esatto.
Sarebbe opportuno poi vedere quali moduli sono caricati, output di
Codice:
$ lsmod
e assicurati che via soft nulla sia bloccato
Codice:
$ sudo rfkill list
se  del caso (INDNUM è il corrispondente numero dato dall'output precedente)
Codice:
$ sudo rfkill unblock INDNUM
Cita messaggio
Grazie da:
#6
Ecco il modello......ha trovato la confezione.
D-Link AirPlus Xtreme GTM DWL-G132 2.4 GHz Wireless G USB 2.0 adapter
Per i comandi bisogna aspettare, è uscito di casa per il week-end.
Intanto grazie
Cita messaggio
Grazie da:
#7
Ed ecco i moduli, niente di bloccato

silvio@silvio-PC:~$ lsmod
Module Size Used by
nls_utf8 16384 1
isofs 40960 1
usblp 20480 0
arc4 16384 2
ar5523 40960 0
mac80211 700416 1 ar5523
snd_via82xx 24576 2
snd_mpu401_uart 16384 1 snd_via82xx
snd_ac97_codec 106496 1 snd_via82xx
gameport 16384 1 snd_via82xx
ac97_bus 16384 1 snd_ac97_codec
snd_pcm 94208 2 snd_via82xx,snd_ac97_codec
cfg80211 532480 2 mac80211,ar5523
snd_seq_midi 16384 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 28672 2 snd_mpu401_uart,snd_seq_midi
snd_seq 57344 2 snd_seq_midi_event,snd_seq_midi
input_leds 16384 0
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
serio_raw 16384 0
snd_timer 28672 2 snd_seq,snd_pcm
i2c_viapro 16384 0
via_ircc 28672 0
snd 65536 12 snd_seq,snd_via82xx,snd_ac97_codec,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm
irda 180224 1 via_ircc
soundcore 16384 1 snd
shpchp 32768 0
mac_hid 16384 0
parport_pc 32768 1
ppdev 20480 0
lp 20480 0
parport 45056 3 lp,parport_pc,ppdev
ip_tables 20480 0
x_tables 24576 1 ip_tables
autofs4 40960 2
hid_generic 16384 0
usbhid 49152 0
hid 98304 2 hid_generic,usbhid
pata_acpi 16384 0
radeon 1466368 3
i2c_algo_bit 16384 1 radeon
ttm 90112 1 radeon
drm_kms_helper 139264 1 radeon
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
fb_sys_fops 16384 1 drm_kms_helper
drm 303104 6 radeon,ttm,drm_kms_helper
8139too 32768 0
8139cp 28672 0
pata_via 16384 2
mii 16384 2 8139cp,8139too
fjes 61440 0
floppy 61440 0



silvio@silvio-PC:~$ sudo rfkill list
[sudo] password di silvio:
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no




Provato con Wicd ma niente da fare, la chiavetta vede la rete Wi-Fi, ma non si connette.

Mi ha detto che ha anche il cd di installazione di Windows nella confezione della chiavetta, ma con Ubuntu 17 ha installato ndiswrapper ma gli dà "file non valido"

Idee?
Cita messaggio
Grazie da:
#8
Il modulo ar5523 dovrebbe essere quello corretto (il dispositivo da lsusb è 2001:3A03 ?).
Si può provare a vedere se scaricandolo e ricaricandolo la scheda funziona meglio
Codice:
$ sudo rmmod ar5523
$ sudo modprobe ar5523
Se così è allora con uno script d'avvio si può far fare il ricaricamento.

Eventualmente per i driver con ndiswrapper vedere qui.
Cita messaggio
Grazie da:
#9
Ecco la risposta dal mio amico, la copio cosi com'è.

ricaricare il modulo da modprobe con i due comandi non ha prodotto risultati, sempre disconnesso "ora si é fuori rete", ndiswrapper nemmeno e questi sono i risultati che mi da:

silvio@silvio-PC:~$ sudo cp a55523.bin /usr/local/bin/
[sudo] password di silvio:
silvio@silvio-PC:~$ sudo cp ar5523.bin /usr/local/bin/
silvio@silvio-PC:~$ sudo cp NetA5AGU.inf /usr/local/bin/
cp: impossibile eseguire stat di 'NetA5AGU.inf': File o directory non esistente
silvio@silvio-PC:~$ sudo cp athfmdl.inf /usr/local/bin/
cp: impossibile eseguire stat di 'athfmdl.inf': File o directory non esistente
silvio@silvio-PC:~$ sudo cp NetA5AGU.inf/usr/local/bin/
cp: manca l'operando per il file di destinazione dopo 'NetA5AGU.inf/usr/local/bin/'
Try 'cp --help' for more information.

Ho cambiato a55523.bin in ar5523.bin perché ho pensato ci sia un errore nella guida e inoltre perché non esiste.
Cita messaggio
Grazie da:
#10
Allego screen dei driver

[Immagine: https://s3.postimg.org/dejmf73lr/Scherma...-27-18.png]
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)