Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Wicd non funziona
#1
Circa 6 mesi fa ho fatto l'aggiornamento di Ubuntu  dalla versione 13.04 alla versione 14.04 e si è ripresentata , puntuale, la necessità sostituire network manager con  wicd ( non ho mai capito perchè network manager non riesca a trovare la mia rete wireless fastweb )

Con Ubuntu 13.04  dopo aver installato wicd , al suo avvio mi veniva richiesta la password. Inserita la mia password compariva il seguente messaggio:
Impossibile connettere l'interfaccia D-Bus di wicd

Grazie al Forum, con l'aiuto di Brunik che mi aveva consigliato di seguire la procedura indicata al post 22 del sito : ttps://bugs.launchpad.net/ubuntu/+source/wicd/+bug/1132529
rm /etc/resolv.conf
   ln -s /run/resolvconf/resolv.conf
   rm /var/lib/wicd/resolv.conf.orig
   ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig
sudo service wicd start
ero riuscito a risolvere il problema. ( rif. Forum 1 “wicd non funziona – utente Paco)

 Sulla  versione 14.04  dopo aver istallato wicd come da manuale:

Open up a Terminal and execute the following commands:
   First, we download the latest NetworkManager, in case we need to reinstall if WICD doesn't works:
       sudo apt-get install -d --reinstall network-manager network-manager-gnome
   Then we install WICD:
       sudo apt-get install wicd-gtk
   And only then do we uninstall NetworkManager:
       sudo apt-get remove network-manager-gnome network-manager
   After everything is confirmed working (best to check after rebooting), you can remove config files for NetworkManager:
       sudo dpkg --purge network-manager-gnome network-manager


si  ripresentava  il solito problema :  dopo aver scollegato il cavo eth. nella finestra del gestore wicd il messaggio era : nessuna rete wireless trovata.

Come risposta al comando -  sudo wicd  si otteneva:
dipacofb@dipacofb:~$ sudo wicd
It seems like the daemon is already running.
If it is not, please remove /var/run/wicd/wicd.pid and try again.
dipacofb@dipacofb:~$

Pensando di aver già la soluzione in tasca provavo quindi a seguire la stessa procedura del post 22 sopra citato ma senza risultato. Dopo il primo comando questo è quello che compariva:
dipacofb@dipacofb:~$  rm /etc/resolv.conf
rm: impossibile rimuovere "/etc/resolv.conf": Permesso negato
dipacofb@dipacofb:~$

Mi sono messo quindi a rovistare nei vari blog   riscontrando che anche  altri, dopo l'installazione di wicd ottenevano lo stesso tipo di messaggio “It seems like the daemon is already running.
If it is not, please remove /var/run/wicd/wicd.pid and try again. “

Qualcuno sembra essere  è riuscito a risolvere il problema seguendo la procedura descritta al post 36 sempre del sito succitato ( quello indicatomi a suo tempo da Brinik):
$ sudo add-apt-repository ppa:chilicuil/proposed-fixes
$ sudo apt-get update
$ sudo apt-get install wicd-daemon
$ sudo rm -rf /etc/apt/sources.list.d/chilicuil-proposed-fixes*
$ sudo apt-get update

Ho provato anch'io senza alcun risultato.

A questo punto decidevo di gettare la spugna.
Non è possibile tribolare in questo modo ogni volta che si fa l'aggiornamento della versione di ubuntu.!

Dopo sei mesi  in  cui, con disagio ( il mio router fastweb si trova in altra stanza rispetto al computer)  mi sono sempre connesso con il cavo eth. , ho deciso di ritentare chiedendo aiuto al Forum.

Grazie  per i suggerimenti.
Cita messaggio
Grazie da:
#2
e si un altro punto per le distribuzioni rolling.
direi di aspettare brunik, ti indicherà certamente.
Cita messaggio
Grazie da:
#3
Io utilizzo wicd sulla 14.04 perchè lo preferisco a network manager, credo che tu debba solamente impostare il nome esatto della periferica wireless nelle impostazioni di Wicd, altrimenti non scansiona nulla Per trovare il nome esatto devi dare il solito comando sudo ifconfig o sudo iwconfig, di solito su Ubuntu è wlan0 o wlan1. Assicurati che sia riportato il nome esatto nelle impostazioni di Wicd. Come puoi vedere dall'allegato io devo utilizzare wlan2 perchè wlan0 e wlan1 sono associati a periferiche wireless non più collegate.


Allegati Anteprime
   
[Immagine: http://i61.tinypic.com/migwsz.jpg]  [Immagine: http://i65.tinypic.com/2rp9u80.jpgGrazie al cielo esiste Linux
Cita messaggio
Grazie da:
#4
Grazie mille Teo. Magnifico !
Era più seplice di quello che immaginavo.
Ho imparato la lezione.
Invece di impazzire da solo ( è stato un peccato di presunzione) per poi gettare la spugna è sempre meglio chiedere a chi sa.
Cita messaggio
Grazie da:
#5
Di nulla At
[Immagine: http://i61.tinypic.com/migwsz.jpg]  [Immagine: http://i65.tinypic.com/2rp9u80.jpgGrazie al cielo esiste Linux
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)