Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Windows 8.1 e mint 17 64 bit in dual boot su hp15-r209nl
#1
buon giorno a tutta la comunità,
sono in palese difficoltà a causa di uefi! help-aiuto-s.o.s.
ora vi racconto:
(già installato sul mio vecchio hp a fianco di windows xp la MajoNix 2.0.1 e anche sul notebook di mia figlia a fianco di w7, funzionanti egregiamente.)
ho sostituito l'hp x rottura schermo con un hp15-r209nl 1 tb 8gb ram windows 8.1 preso a media world in promozione.
operazioni fatte: (seguendo le varie fonti del sito del Majorana e la guida Installare Ubuntu 14.04 con Windows 8.1 Update)
disabilitato fast boot
disabilitato secure boot nel bios
cambio delle priorità all'avvio dei dispositivi
ridotto la partizione di Windows con gestione del disco di Windows
preparato una chiavetta usb con Linux Mint 17 Mate Plus Remix a 64 bit (usato Rufus)
(ho provato anche con Ubuntu 14.04 Mate Classic Plus Remix a 64 bit, con gli stessi risultati)
partizionato con gparted (una ext (/)e una di swap(swap)) con la live Linux Mint 17
in live funziona, lanciando l'installazione mi viene caricata in ext4 ma al ravvio parte sempre Windows, andando nel boot options del bios alla voce os boot manager trovo in sequenza Windows e ubuntu, provo a invertire l'ordine e al riavvio mi dà errore (riavvio, rientro nel bios e li rigiro x partire con Windows) 
allego 2 schermate fatte con la live (spero che si vedano).
una particolarità che ho notato a differenza della video guida del professore che nel mentre dell'istallazione alla finestra system install la voce "instal grub 2 bootloader" mi compare disabilitato e non posso variarlo.
forse non ho ben chiaro cosa fare col boot.
ora la grande domanda: chi ha un'idea di dove sbaglio?


Allegati Anteprime
       
Cita messaggio
Grazie da:
#2
Prova a dare un'occhiata qui
http://www.istitutomajorana.it/index.php...&Itemid=33
Cita messaggio
Grazie da:
#3
eu66
ti ringrazio per l'interessamento, è la guida che ho consultato cercando di installare ubuntu ma seguendola a un certo punto (da pag 21 in poi) mi fa vedere il partizionamento del disco e la possibilità di evidenziare senza modificarla e formattarla ma confermandola sda2 efi di Windows, invece, facendo la mia installazione trovo il partizionamento del disco come dalla prima immagine che ho postato come da videoguida del professore con la variante citata nel primo messaggio.
ti ringrazio in attesa di help
Cita messaggio
Grazie da:
#4
Purtroppo non ho esperienza diretta, io sono fermo a Vista per quanto riguarda win, comunque nella guida c'è un riferimento a boot-repair per sistemare l'avvio. Se il problema è entrare nel SO potresti provare con super grub disck e una volta dentro avviare boot-repair che è già installato.
http://www.istitutomajorana.it/index.php...&Itemid=33
Cita messaggio
Grazie da:
#5
eu66
sono riuscito a installare ubuntu-mate-15.04-desktop-amd64, ho letto un pò di discussioni e mi sono fatto uno specchietto che è qui di seguito.
vedi se è chiaro, se mi sono espresso in modo abbastanza comprensibile, spero che l'esperienza possa servire ad altri.
poi scrivimi se devo mettere [RISOLTO] o fare prima delle correzioni-puntualizzazioni nel testo.

Modello notebook kp15-r209nl
intel core i5, 1 Tb disco fisso, 8 gb ram, nvidia geforce 2 gb dedicati come sheda video.

sequenza delle operazioni:

1 (sembra banale) ho acceso il pc e magicamente appare windows, lo provo un po' e vedo che tutto quello che uso funziona.

2 comincio con l'entrare nella gestione disco di windows per partizionare il disco fisso riducendo C di quanto mi permette il software ( dopo, con gparted, l'ho dimensionato fino a 100 gb “102400”).

3 disabilito fast boot sempre in windows.

4 riavvio ed pigio esc e dopo f10 ed entro nel bios: subito disabilito secure boot ( questo bios lo permette) e cambio la sequenza di avvio mettendo davanti al disco fisso sia il dvd che la chiavetta (key usb).

5 ritorno in windows e vado in http://www.ubuntu-it.org/ sito di ubuntu italia e scarico sia
ubuntu-14.04.3-desktop-amd64 che ubuntu-mate-15.04-desktop-amd64 (quest'ultima è quella che ho ora, le ho provate a installare tutte e due con esito positivo).

6 scarico rufus e MD5 Sum x windows (MD5 Sum non la considero a causa dell'impronta che non corrisponde).
preparo il file iso sulla chiavetta usb con rufus che gestisce uefi:
inserisco prima la chiavetta usb e dopo lancio rufus, si apre e preparo
device: ti fa vedere la chiavetta
partition scheme for bios or uefi: ho scelto ( selezione a tendina) la terza cioè gpt uefi
file system: fat32
cluster size: 4096 bytes
new volume label: ci pensa il programma
trovo spuntato quick format e create a bootable disk using e li lascio cosi
inserire iso image e caricare (dove c'è il simbolino del disco) la distribuzione che si è scaricato
lasciare il pallino su standard windows installation e la spunta su create extended label and icon files
pigio start e confermo quello che compare
quando ha finito chiudo.

7 riavvio e parte la live, la provo e lancio gparted: setto le varie partizioni
per ubuntu ne preparo una col file system ext4 e punto di mount / e una in swap

8 riavvio il pc e parte la live, faccio partire l'installazione e compilo le varie maschere fino alla finestra del partizionamento:
partizione di swap: riconfermo swap
partizione di ext4: spunto formatta,gli dico di nuovo punto di mount / e mettere grub nella partizione di boot cosi: (evidenziare la partizione ext4 dove si vuole caricare ubuntu che si setta come punto di mount  /)in basso c'è una riga col titolo “device per l'installazione del boot loader” bisogna selezionare il nome del device di dove si mette ubuntu.

Es: se sda6 è ext4 con dentro ubuntu  in device per l'installazione del boot loader selezionare /dev/sda6

cerco la partizione di efi di windows ( la mia è /dev/sda2 in fat32) la evidenzio, seleziono change e quando si apre il dettaglio la confermo senza modificarla. (non so se non facendo questa sequenza cosa avviene, l'ho letta nella guida nel sito majorana alla guida Come installare Ubuntu 13.04/13.10/14.04 con Windows 8/8.1, GPT, UEFI e Secure Boot La mia esperienza)

Vado avanti nell'installazione con fuso orario nella finestra successiva e via cosi fino a installazione avvenuta.

9 riavvio ed rientro nel bios, vado di nuovo in boot options, mi posiziono sulla riga di os boot manager pigio enter e si apre la lista dei sistemi operativi installati, bisogna mettere ubuntu sopra windovs (con i tasti f5-f6).
Riavvio e …..tutto ok…...per il momento!
Cita messaggio
Grazie da:
#6
Ottimo! grazie di aver riportato la tua esperienza, sarà di sicuro d'aiuto anche per altri. At
Cita messaggio
Grazie da:
#7
Grazie molto gentile aver condiviso, gentilmente non mi è chiaro il punto 8:

"partizione di ext4: spunto formatta,gli dico di nuovo punto di mount / e mettere grub nella partizione di boot cosi: (evidenziare la partizione ext4 dove si vuole caricare ubuntu che si setta come punto di mount  /)in basso c'è una riga col titolo “device per l'installazione del boot loader” bisogna selezionare il nome del device di dove si mette ubuntu.""
"Es: se sda6 è ext4 con dentro ubuntu  in device per l'installazione del boot loader selezionare /dev/sda6"

Solitamente per partizione di grub dove si mette il bootloader(il grub)si intende sda,e non la partizione medesima dov'è c'è il sistema(appunto come da es. sda6) ,questo può creare un equivoco perchè mi sembra Undecided che sia una contraddizione su dove mettere il bootloader di ubuntu, mi scuso nel qual caso interpretassi male, non esperienza su questo tipo di installazione.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:
#8
Bilodiego e comunità
scusate del ritardo con cui vi do riscontro
Spiegazione del punto 8:
seguendo la video guida del professore http://www.istitutomajorana.it/index.php...&Itemid=33 il “devie per l'installazione del boot loader” viene settato a /dev/sda, ma (una particolarità che ho notato a differenza della video guida è che nel mentre dell'istallazione nella finestra “system install” alla voce "instal grub 2 bootloader" mi compare disabilitato e non posso variarlo, vedi immagine iniziale e provando a installare Ubuntu 14.04 Mate Classic Plus Remix 64 bit) dato questo particolare ho seguito la guida che ha realizzato GiuS ( http://www.istitutomajorana.it/forum/User-GiuS ) che di seguito riporto la posizione:

vai a vedere http://www.istitutomajorana.it/index.php...&Itemid=33
nella guida “Installare Ubuntu 13.04 -13.10 - 14.04 con Windows 8 - 8.1: GPT, UEFI e Secure Boot – Vers.2” a pag. 13 il “devie per l'installazione del boot loader” viene settato a /dev/sda6 ( combinazione la mia stessa) ma non cambia il principio: /dev/sdax a seconda di dove c'è ubuntu.

Ho installato il sitema operativo http://www.ubuntu-it.org/ dal sito di ubuntu italia e scaricando sia ubuntu-14.04.3-desktop-amd64 che ubuntu-mate-15.04-desktop-amd64 le ho provate a installare tutte e due con esito positivo.
Spero di essere stato esaudiente, sono alle prime armi con ubuntu e tante,tantissime cose non le conosco.
Un saluto sincero a tutti


ps: la differenza che ho notato nei sistemi operativi tra il sito del Majorana e il sito di ubuntu italia è che nel primo vedo la partition settings in un modo e nel secondo in un altro.
La domanda viene spontanea: perché?
Cita messaggio
Grazie da:
#9
devo mettere [RISOLTO] o fare prima delle correzioni-puntualizzazioni nel testo?
Cita messaggio
Grazie da:
#10
Ok, ora mi è chiaro, mi ero impallato sul"mettere grub nella partizione di boot"  davo per scontato che questa fosse sda,mentre  con l'avvento di uefi,l'ho saputo adesso(grazie alla tua breve ma efficace spiegazione) che la partizione del boot si intende e si deve mettere nella medesima del sistema, appunto nel tuo caso sda6.
A rigrazie Smile
Si Tongue  puoi mettere risolto visto che lo è.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)