Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] comando sudo service apache2 restart
#1
Salve a tutti, sono nuovo del forum.
Ho un problema che non riesco a risolvere. Premetto che sono alle prime armi con il server apache, php e mysql. Il problema è il seguente :
ho installato lamp su ubuntu 14.4 . quando da un browser digito localhost oppure 127.0.0.1 non appare la classica pagina index.html con la scritta it's work ma una pagina con questa scritta
Index of /
[ICO] Name Last modified Size Description
Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80

se poi provo a fare una richiesta con 127.0.0.1/phpmyadmin (phpmyadmin è installato ovviamente) mi fa una ricerca su internet.
Su altri pc dove ho installato lamp non ho questo problema.
Ho provato a fare ripartire il server apache con il comando sudo service apache2 restart oppure a dare il comando stop e poi start il serve riparte ma mi da la seguente scritta:
* Restarting web server apache2 AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
cosa devo fare?
grazie in anticipo per l'aiuto
Cita messaggio
Grazie da:
#2
Guarda se ti aiutano le discussioni

http://askubuntu.com/questions/329323/pr...ng-apache2

http://askubuntu.com/questions/256013/co...omain-name


Cita messaggio
Grazie da:
#3
Ho risolto solo una parte del problema. Facendo come suggerito da questo link http://askubuntu.com/questions/256013/co...omain-name
adesso se faccio ripartire il server apache non c'è più la segnalazione con l'avviso AH00558. Però non riesco a richiamare la pagina index.html digitando 127.0.0.1 ma continua ad uscire la pagina con sopra scritto
Index of /
[ICO] Name Last modified Size Description
Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80
Secondo me il server Apache, sta girando e girava anche prima. Infatti se provo a lanciare la richiesta all'IP localhost con il server apache fermo non ottengo questa pagina ma la classica risposto di pagina non raggiungibile. Però digitando sulla barra URL del browser 127.0.0.1/phpmyadmin ottengo una ricerca su internet e non entro in phpmyadmin, questo è il mio vero problema
Cita messaggio
Grazie da:
#4
Prova a leggere

http://askubuntu.com/questions/464487/ca...ing-apache


Cita messaggio
Grazie da:
#5
Verifica quale è la DocumentRoot
Codice:
sudo getit /etc/apache2/sites-available/000-default.conf
dovrebbe essere
DocumentRoot /var/www/
Dopo la modifica riavvia apache.

Bye,
Token
Cita messaggio
Grazie da:
#6
In effetti nella DocumentRoot c'era /var/www/html ho tolto html ed il problema non c'è più. Ora vedo se riesco ad aprire phpmyadmin e zoneminder. Cmq i due quesiti che avevo posto sono risolti.
grazie 1000 a tutti
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 3 Ospite(i)