SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]installare estensioni Php
#1
salve,
ho bisogno di installare sul mio server LAMP Ubuntu 17.04 le estensioni Php (dom, gd, SimpleXML, xml)
richieste da Drupal. Nonostante due guide simili trovate  In rete non riesco a caricarle.
Questa è una delle due guide: http://andypanix.com/articoli/installare...untu-linux
ma nessun comando di questa guida funziona sul mio server.

Codice:
danilo@towerdanyred:~$ sudo apt-get install php-pear php-dev php-cli
[sudo] password for danilo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Nota, viene selezionato "php7.0-cli" al posto di "php-cli"
Il pacchetto php-pear non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "php-pear" non ha candidati da installare
E: Impossibile trovare il pacchetto php-dev

danilo@towerdanyred:~$ sudo apt-get install libpcre3-dev libmagic-dev
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Il pacchetto libpcre3-dev non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "libpcre3-dev" non ha candidati da installare
E: Impossibile trovare il pacchetto libmagic-dev
 ho trovato anche questa guida: https://stackoverflow.com/questions/4224...untu-14-04

ma anche cos' non riesco a fare niente:
Codice:
danilo@towerdanyred:~$ sudo apt-get install php7.0-dom
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto php7.0-dom
E: Impossibile trovare alcun pacchetto tramite il glob "php7.0-dom"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "php7.0-dom"
danilo@towerdanyred:~$ sudo apt-get install php7.0-xml
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto php7.0-xml
E: Impossibile trovare alcun pacchetto tramite il glob "php7.0-xml"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "php7.0-xml"
danilo@towerdanyred:~$

qualcuno mi sa indicare come installare queste estensioni?  

grazie per l' attenzione

danilo
Cita messaggio
Grazie da:
#2
non ho esperienza di sistemi server ma credo che sia la stessa cosa. il tuo ubuntu 17.04 ha terminato il periodo di supporto. dai suoi repo non potrai scaricare più nulla.
cosa fare?
un tentativo con la trasformazione dei repo in EOL https://wiki.ubuntu-it.org/Repository/SourcesList/EOL
al termine ricordarsi di abilitare i sorgenti patner di canonical

la soluzione più radicale, installare una nuova versione ancora supportata.
Cita messaggio
Grazie da:
#3
grazie per la risposta.  ora sono riuscito a installare tutte le estensioni richieste. Peccato che drupal continua a non vederli.
"la soluzione più radicale, installare una nuova versione ancora supportata"peccato che il mio server è a 32 bit e le versioni dopo alla mia sono tutte per i 64 bit.
ancora grazie
danilo
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)