Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] installazione di VLC 2.1.5
#1
Salve,

antefatto: dopo un aggiornamento mi sono trovato con il segnale di "senso vietato" sulla scrivania che mi invitava a fare un aggiornamento di tutti i pacchetti attraverso il Gestore Pacchetti.
Dopo questo mi e' scomparso il VLC che fino ad allora mi funzionava benissimo anche se non era l'ultima versione 2.1.5

Adesso sto cercando di installarlo di nuovo ma mi da' i seguenti errori da terminale:
===================================
barbamoto@UB1404:~$ sudo apt-get install vlc
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
vlc : Dipende: vlc-nox (= 3.0.0~~git20150104+r59099+31~ubuntu14.04.1) ma non sta per essere installato
      Dipende: libavcodec55 (>= 6:9.1-1) ma non è installabile oppure
               libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) ma non è installabile
      Dipende: libavutil53 (>= 6:9.1-1) ma non è installabile
      Raccomanda: vlc-plugin-notify (= 3.0.0~~git20150104+r59099+31~ubuntu14.04.1) ma non sta per essere installato
      Raccomanda: vlc-plugin-samba (= 3.0.0~~git20150104+r59099+31~ubuntu14.04.1) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
=================================================

come posso risolvere?

Grazie per l'immancabile aiuto
Cita messaggio
Grazie da:
#2
prova ad aprire il gestore pacchetti e riparare i pacchetti danneggiati dopo aver cliccato su aggiorna.
Cita messaggio
Grazie da: Barbuntu
#3
(04-01-2015,20:03 )giuseppemos Ha scritto: prova ad aprire il gestore pacchetti e riparare i pacchetti danneggiati dopo aver cliccato su aggiorna.

provato a farlo ma non ci sono riuscito. Quando vado ad aplicare le modifiche mi dice di riparare i pacchetti prima.
Cita messaggio
Grazie da:
#4
Se volessi provare a rimuovere tutti i componenti che danno fastidio, come dovrei fare?
Cita messaggio
Grazie da:
#5
toc toc toc

c'e' nessuno per aiutoooooo?
Cita messaggio
Grazie da:
#6
Apri un terminale e scrivi questi comandi, una riga per volta:
Codice:
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get upgrade
il primo ti chiederà la password (che a terminale va digitata senza vedere nulla, nemmeno gli asterischi) mentre per gli altri dovrebbe evitare, ma nel caso preparati a digitarla nuovamente

Se ti da problemi, posta i risultati dei comandi.
Il sentimento più forte e più antico dell'animo umano è la paura, e la paura più grande è quella dell'ignoto.
Howard Phillips Lovecraft - L'Orrore Soprannaturale nella Letteratura
Cita messaggio
Grazie da: Barbuntu
#7
(05-01-2015,20:09 )mk66 Ha scritto: Apri un terminale e scrivi questi comandi, una riga per volta:

Codice:
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get upgrade
il primo ti chiederà la password (che a terminale va digitata senza vedere nulla, nemmeno gli asterischi) mentre per gli altri dovrebbe evitare, ma nel caso preparati a digitarla nuovamente

Se ti da problemi, posta i risultati dei comandi.

Grazie.
Ho eseguito senza errori, poi ho dato "sudo apt-get install vlc" e mi ha dato di nuovo gli stessi errori
Cita messaggio
Grazie da:
#8
Avevi aggiunto tu dei ppa per installare la versione 2.1.5, ? o non hai fatto nulla e stai usando i repo di ubuntu? Ti faccio questa domanda perchè mi risulta che quelli di ubuntu 14.04 sono fermi alla 2.1.4.
Se li hai aggiunti, proverei di nuovo a disinstallare e ripulire tutto, togliere i ppa aggiunti che dovrebbero essere:ppa:videolan/stable-daily, cmq controlla per scrupolo che non ci siano.
e rifare l'installazione della 2.1.4.che è compatibile con i repo delle dipendenze di ubuntu 14.04.

p.s. se non sai la procedura chiedi pure.
Non richiedermi l'amicizia, siamo già amici  Big Grin il mio blog LinuxEasy  Tux

Cita messaggio
Grazie da: Barbuntu
#9
(05-01-2015,23:44 )bilodiego Ha scritto: Avevi aggiunto tu dei ppa per installare la versione 2.1.5, ? o non hai fatto nulla e stai usando i repo di ubuntu? Ti faccio questa domanda perchè mi risulta che quelli di ubuntu 14.04 sono fermi alla 2.1.4.
Se li hai aggiunti, proverei di nuovo a disinstallare e ripulire tutto, togliere i ppa aggiunti che dovrebbero essere:ppa:videolan/stable-daily, cmq controlla per scrupolo che non ci siano.
e rifare l'installazione della 2.1.4.che è compatibile con i repo delle dipendenze di ubuntu 14.04.

p.s. se non sai la procedura chiedi pure.

Grazie per la risposta.
Ecco, in realta' mi sembra di aver pasticciato con delle ppa ma non sono sicuro.
Dopo il tuo messaggio sono andato nel gestore degli aggiornamenti ed ho cancellato la ppa videolan come suggerito da te. Poi ho tentato di installare VLC dal repo dell'Ubuntu software centre ma con il medesimo risultato di sempre.

cmq vorrei postarti la finestra dei dettagli del VLC che sembrerebbe essere una versione 3.0.0 compatibile con 14.04.1
mentre nel sito VLC sembrerebbe che l'ultima versione sia la 2.1.5

Chi ci capisce niente????

Comunque se sei cosi' gentile da perdere un po' di tempo con me per ripulire il tutto e spiegarmi come tornare alla versione 2.1.4 che funzionava benissimo, ti ringrazio.
Per favore ho bisogno di istruzioni passo passo.
Cita messaggio
Grazie da:
#10
apri il terminale e scrivi:
sudo apt-get --purge remove vlc
invio, pswd che non vedrai ma lui scrive, invio.
al termine apri la tua home, ctrl+h per visualizzare i file nascosti quelli con il punto davanti. cerca .config, controlla se al suo interno la cartella vlc, nel caso eliminala selezionandola quindi maius sx+canc.
apri adesso sorgenti software, nella finestra dei PPA verifica di non avere nulla relativo a videolan oppure vlc, nel caso rimuovi completamente.
per ultimo, nel terminale:
sudo nautilus /etc/apt/sources.list.d
invio ( ho scritto nautilus immaginando tu abbia ubuntu )
nella finestra che appare, verifica di non avere nulla riguardante vlc oppure videolan, nel caso cancella come prima.
chiudi tutto ed uno alla volta i quattro comandi come ti ha postato mk66.
tutto si deve risolvere senza errori ( nel caso posta ). alla fine, apri il terminale e scrivi:
sudo apt-get install vlc
invio ecc.ecc. dovresti aver finito.
Cita messaggio
Grazie da: Barbuntu


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)