Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] problema Libreoffice con Vector Linux7
#1
Salve a tutti Voi del Forum!
Sono un genitore che da' una mano alla scuola elementare a rimettere in piedi l'aula di informatica sia dal punto di vista hardware che software. Per motivi di budget sono stato costretto ad orientarmi verso un sistema operativo free, pur non conoscendo per nulla il mondo Linux dopo varie prove con varie distro mi sono fatto un po di ossa e ho optato per Vector Linux7 standard Edition 32bit. Tenete presente che i PC nell'aula sono prettamente del 2003 e montano sempron o celeron quindi stiamo alla preistoria...
La cosa bella e' che dalla fine l'aula e' ripartita, Vector si comporta discretamente, il problema e' arrivato con LibreOffice che ho installato tramite Gslapt dalle repository ufficiale di Vector. Bene Funziona ma l'interfaccia utente e' in INGLESE! ok niente panico mi metto a cercare il famigerato pacchetto libreoffice-l10n-it ma Gslapt non me lo trova. Ok allora provo a spuntare qualche sources in Gslapt->Edit->Preferenes->Sources ma vacci a prendere... infine leggo tra i vari forum che il pacchetto ce l'ha Slachy?!? Boh disorientato penso prima che sia il nome di un cane poi guardando tra tutti i package sources in fondo ne trovo questo "http://www.slachy.eu/repostory/skackware-14.0/" bingo! penso lo spunto e aggiorno... messaggino:
"This package source failed or is not available." 
Slaky mi dice male.
Ma tanto che importa si puo' sempre installare manualmente un pacchetto no?!? quindi vado in giro per il web e trovo questo "https://pkgs.org/download/libreoffice-l10n-it". Qua' dentro ne trovi a iosa dei l10n ma mica li puoi prendere a caso quindi guardo un po' che tipo di distro posseggo e wikia mi dice che e' una variante di Slackware (cosi' elimino le altre) poi guardo il mio libreoffice riporta ver. 5.0.0-i586-1vl71 quindi verifico sul sito che ver. 5.0.0 per slackware non c'e' ma non mi arrendo prendo la ver 5.0.1 poi da terminale la installo (non chiedetemi come ho fatto perche' non lo so) comunque il terminale mi dice che il pacchetto e' installato e Gslapt controllando lo status me lo riporta installato. 
Pero' libreoffice rimane in inglese. 

Ho provato anche a scaricarmi i pacchetti rpm dal sito ufficiale di libreoffice ver. 5.2.6 + relativa interfaccia utente tradotta ma quando la vado ad installare (dopo aver rimosso la 5.0.0) da terminale mi dice che gli mancano un sacco di dipendenze? e' normale? me le devo cercare io e aggiungere al pacchetto? Boh!  

Alla fine piglio un PC gli installo peppermint6 e mi trovo sia il pacchetto libreoffice sia il pachetto interfaccia italiana direttamente nel gestore dei pacchetti! installo entrambi et voila' libreoffice in italiano!

Allora hai risolto? No.
Questo e' aggirare l'ostacolo non risolverlo. Fra l'altro ho fatto gia' 8 h di formazione a tutto il corpo docenti della scuola dove "ho provato" a far famigliarizzare gli insegnanti con Vector Linux adesso chi glielo dice che passiamo a peppermint? Quelli mi sparano... 

Grazie in anticipo per qualsiasi tipo di aiuto/sostegno  Confused
Cita messaggio
Grazie da:
#2
non hai la possibilità di installare openoffice? io non conosco vector, oggi la provo poi ti dirò.
Cita messaggio
Grazie da:
#3
Come dxgiusti anch'io ti consiglierei OpenOffice che se ricordo bene era nei repository di Vector in passato e funziona bane su slackware e derivate.

Dato che tu stesso hai detto di essere nuovo di Linux permettimi una considerazione. Non ho nulla contro Vector ma penso che per un neofita di Linux ci siano scelte più semplici. Se hai circa 512 MB di ram ad esempio puoi provare Xubuntu 16.04 LTS che ti da accesso a tutto il software per Ubuntu per essenso più leggera. Dico Xubuntu perché c'è molto software già impacchettato ma anche perché c'è molta più documentazione in italiano.
Cita messaggio
Grazie da:
#4
eccomi dopo aver provato. ho installato openoffice e tutto ok. a quel punto  avevo installato prima libreoffice da gslapt mi sono chiesto, se eseguo la stessa procedura magari funziona ed infatti

   

ho seguito questo percorso per recuperare il pacchetto della lingua>
http://downloadarchive.documentfoundatio...5/rpm/x86/
in quanto la versione di vector che ho installato e la 5.0.0.5 ed ho scaricato > http://downloadarchive.documentfoundatio..._it.tar.gz
a questo punto nella cartella download ho scompattato il file. sono entrato nella cartella RPMS e li dentro col dx ho aperto il terminale. sono diventato amministratore con > su , invio, pswd , invio. ora dopo il cancelletto ho scritto >
Citazione:rpm2tgz *.rpm
invio. al termine sempre li >
Citazione:installpkg *.tgz
invio. terminato > exit, chiuso e riavviato. tutto hk. la stessa procedura se vuoi installare HELP in italiano.
le indicazioni per i comandi le ho trovate qui
Cita messaggio
Grazie da:
#5
(23-04-2017,13:46 )Blackstar Ha scritto: Come dxgiusti anch'io ti consiglierei OpenOffice che se ricordo bene era nei repository di Vector in passato e funziona bane su slackware e derivate.

Dato che tu stesso hai detto di essere nuovo di Linux permettimi una considerazione. Non ho nulla contro Vector ma penso che per un neofita di Linux ci siano scelte più semplici. Se hai circa 512 MB di ram ad esempio puoi provare Xubuntu 16.04 LTS che ti da accesso a tutto il software per Ubuntu per essenso più leggera. Dico Xubuntu perché c'è molto software già impacchettato ma anche perché c'è molta più documentazione in italiano.


Ciao! Relativamente alla mia preparazione su Linux hai ragione sono una capra. Quando mi sono trovato 30 pc in casa di cui 15 non fungevano ho dovuto fare varie valutazioni visto che il budget della scuola era praticamente nullo. Rimessi in moto circa 24 PC sono dovuto passare alla valutazione sul sistema operativo. Ovviamente ho visitato vari forum per indirizzarmi su una release di linux adatta ai miei vecchi PC che fosse Windows friendly e con potenzialita'. A quei tempi non mi ero ancora imbattuto sul vostro sito che considero uno dei migliori se non il migliore, dove ovviamente mi avreste potuto consigliare. Quindi scaricai varie release definite e le provai. Vector, Peppermint, Ubuntu, Zorin e Mint. Beh a parte che alcune si installavano solo sul mio Pc personale di casa (i7 e geforce 970) il piu' bello Mint i piu' funzionali per i pc Vector e Peppermint. Ecco perche' da natale hanno a scuola i PC con Vector e ho fatto anche lezione al corpo docenti per poter lavorare con linux dopo il panico iniziale si sono abituati.
Ma attenzione abituati a Vector... se ora gli do' Xubuntu mi uccidono.

Comunque grazie tantissimo per l'interessamento! Smile
Cita messaggio
Grazie da:
#6
(23-04-2017,16:39 )dxgiusti Ha scritto: eccomi dopo aver provato. ho installato openoffice e tutto ok. a quel punto  avevo installato prima libreoffice da gslapt mi sono chiesto, se eseguo la stessa procedura magari funziona ed infatti



ho seguito questo percorso per recuperare il pacchetto della lingua>
http://downloadarchive.documentfoundatio...5/rpm/x86/
in quanto la versione di vector che ho installato e la 5.0.0.5 ed ho scaricato > http://downloadarchive.documentfoundatio...tar.gz.asc
a questo punto nella cartella download ho scompattato il file. sono entrato nella cartella RPMS e li dentro col dx ho aperto il terminale. sono diventato amministratore con > su , invio, pswd , invio. ora dopo il cancelletto ho scritto >
Citazione:rpm2tgz *.rpm
invio. al termine sempre li >
Citazione:installpkg *.tgz
invio. terminato > exit, chiuso e riavviato. tutto hk. la stessa procedura se vuoi installare HELP in italiano.
le indicazioni per i comandi le ho trovate qui

Intanto vedere libreoffice in ita su Vector fa' si' che tu sia il mio nuovo idolo  Huh

Ovviamente siccome quasi sicuramente trascuro qualcosa che per chi Linuxxa e' ovvio non ho raggiunto lo scopo.
Ti dico cosa ho fatto.
1- Ho disinstallato la versione di Libreoffice che avevo dalle repository di Vector (la 5.0.0)
2- dal sito "http://downloadarchive.documentfoundation.org/libreoffice/old/5.0.0.5/rpm/x86/" mi sono scaricato questi tre archivi:

LibreOffice_5.0.0.5_Linux_x86_rpm.tar.gz

LibreOffice_5.0.0.5_Linux_x86_rpm_langpack_it.tar.gz


LibreOffice_5.0.0.5_Linux_x86_rpm_helppack_it.tar.gz


3- Ho scompattato tutti e tre gli archivi con xarchiver
4- Sono andato nella cartella RPMS del primo pacchetto (quella del core) e ho digitato quanto segue
$ su
inserito la password 
# rpm2tgz *.rpm
.....risposta....
Too many command line arguments.

Non mi installa libreoffice e se ripeto il comando rpm2tgz *.rpm per gli altri pacchetti "lingua e help" sempre Too many command line arguments!

Pare che i miei pc non ne vogliano sapere di TAGGIZZARE gli rpm. 


Grazie per la tua pazienza.
Cita messaggio
Grazie da:
#7
ma perchè non fai come me? installato libreoffice da gslapt.
scarica dal link postato il pacchetto del linguaggio it
scaompattalo, apri il terminale nella cartella RPMS, diventa ammministratore, installalo con i comandi postati.
Cita messaggio
Grazie da:
#8
breve riepilogo. il linguaggio italiano lo trovi:
http://downloadarchive.documentfoundatio...5/rpm/x86/
e precisamente:
http://downloadarchive.documentfoundatio..._it.tar.gz
ho fatto un video ( non sono molto bravo..... guardalo in hd720 )


sperando ti possa aiutare.
Cita messaggio
Grazie da: Nemo82
#9
(23-04-2017,23:06 )dxgiusti Ha scritto: breve riepilogo. il linguaggio italiano lo trovi:
http://downloadarchive.documentfoundatio...5/rpm/x86/
e precisamente:
http://downloadarchive.documentfoundatio..._it.tar.gz
ho fatto un video ( non sono molto bravo..... guardalo in hd720 )


sperando ti possa aiutare.

Grazie grazie grazie!!!
Ora libreoffice funziona tutto in ita! i bimbi potranno utilizzare gli applicativi con comodita' e i docenti pure (non sono tutti mostri in inglese!)
Mi vergogno che tu abbia dovuto fare addirittura un video, il mio errore era disistallare libreoffice core da gslapt e poi volerlo installare il core dal link dove tu prendi anche il pacchetto della lingua (magari si puo' e magari si riesce ma forse tu ce la faresti di certo non io)
Dopo mi dava errore tutte le volte che provavo a trasformare qualsiasi pacchetto (core lingua help) da rpm in tgz!

Ok per me' questo e' chiuso, ho ancora alcuni problemi con Wine e altri piccoli dettagli non so' se posso continuare a scrivere qui' oppure aprire un nuovo tread! 
Ancora mille grazie!!!  Huh Huh Huh
Cita messaggio
Grazie da:
#10
bene. l'importante è risolvere. nessun problema per il video, passo il tempo e mi diverto. per altre cose un post per ogni problematica. ciao
Cita messaggio
Grazie da:


Vai al forum: