Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] problema dual boot ubuntu windows7
#1
salve a tutti ho appena installato ubuntu da 5 minuti (per la prima volta) e mi serve un aiuto.
Ho installato ubuntu insieme a windows 7 in dual boot.
Come primo sistema operativo c'è ubuntu
windows 7 si trova alla riga 5
sto provando a seguire questa guida

http://www.istitutomajorana.it/index.php...&Itemid=33




ma quando provo a salvare mi esce questo errore nel terminale
** (gedit:3356): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-position non supportata

francesco@francesco-G5311it-m:~$

perpiacere aiutatemi voglio fare in modo che appena si avvi il pc devo far avviare windows 7 come primo sistema operativo e soltanto se voglio usare linux devo selezionarlo con la freccia e vorrei anche mettere un tot tempo dopo il quale il pc scelga da solo.
Ripeto sono nuovo non so neanche come far uscire quella barra dove si trova la lente d'ingrandimento quando apro il file a me non c'è quella barra.



http://www.istitutomajorana.it/immagini7...cfg_03.png
Cita messaggio
Grazie da:
#2
dopo aver abilitato i permessi di root mi esce questo errore

(gedit:3670): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Cita messaggio
Grazie da:
#3
apri il terminale e posta il risultato di questi comandi

Codice:
cat /boot/grub/grub.cfg | grep -i windows

e

Codice:
cat /etc/default/grub
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#4
ecco qui:

francesco@francesco-G5311it-m:~$ cat /boot/grub/grub.cfg | grep -i windows
menuentry 'Windows 7 (loader) (su /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-40F47B19F47B1100' {
francesco@francesco-G5311it-m:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
francesco@francesco-G5311it-m:~$
Cita messaggio
Grazie da:
#5
prima mi sono dimenticato di postare tutto il log.
Dopo aver abilitato i permessi di root esce questo errore


Codice:
francesco@francesco-G5311it-m:~$ su
Password:
root@francesco-G5311it-m:/home/francesco# sudo gedit /boot/grub/grub.cfg

(gedit:3391): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:3391): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

** (gedit:3391): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata

** (gedit:3391): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-position non supportata
root@francesco-G5311it-m:/home/francesco#
Cita messaggio
Grazie da:
#6
il su in ubuntu non esiste, l'utente root non è abilitato, devi usare il sudo, per i privilegi di root.

quelli sono warning che si verificano usando applicazioni grafiche con privilegi di root, e gedit è una applicazione grafica.

lascia stare quello che stavi facendo, fai così, copia/incolla i comandi, dai

Codice:
gksu gedit /etc/default/grub
e modifica la prima riga da così

Codice:
GRUB_DEFAULT=0
a così

Codice:
GRUB_DEFAULT='Windows 7 (loader) (su /dev/sda1)'
fatta la modifica salva il file e chiudi.
poi fai l'update di grub, dai

Codice:
sudo update-grub
e al termine riavvia dovresti avere windows7 selezionato come primo sistema ed allo scadere dei 10 secondi si avvierà automaticamente.

oppure con i tasti freccetta potrai selezionare ubuntu
Personalizzare Grub


Nu se peu sciuscià e sciurbì





Cita messaggio
Grazie da:
#7
grazie mille per l'aiuto ora finalmente quando avvio il pc in automatico viene selezionato windows7 se non spingo niente si avvia senza spingere invio (questo pc viene usato da altre persone che sanno usare pochissimo il computer quindi meglio farlo avviare con windows).
Mentre se voglio usare linux mi basta selezionare la freccia e poi spingere invio.
Ascolta visto che siamo in tema potrei farvi una domande veloce?
Ho un 'altro pc su cui voglio installare linux è un portatile con due partizioni una per il sistema operativo windows 10 e una ancora vuota però formatta da windows quando installo linux  che opzione devo usare per lasciare la partizione di windows intatta e sfruttare la seconda partizione?
Cita messaggio
Grazie da:
#8
direi di chiudere questa e di aprire un nuovo post dedicato. cordialità
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)