Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] problema scheda rete enp3s0
#1
ciao a tutti
ho cambiato la scheda madre del mio pavilion hp, funziona tutto anche il wireless, ma la scheda di rete non va;
attaccando il cavetto si accendono le luci, ma nelle impostazioni non ha il mac address;
una cosa che ho notato è che non si chiama piu eth0 ma enp3s0;

questo il risultato di ifconfig -a 

enp3s0    Link encap:Ethernet  IndirizzoHW 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:0 (0.0 B)  Byte TX:0 (0.0 B)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4014 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4014 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0 
          Byte RX:374460 (374.4 KB)  Byte TX:374460 (374.4 KB)

wlan0     Link encap:Ethernet  IndirizzoHW 00:21:5d:2c:4b:98  
          indirizzo inet:192.168.1.66  Bcast:192.168.1.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::221:5dff:fe2c:4b98/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15242 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10769 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000 
          Byte RX:12892747 (12.8 MB)  Byte TX:2656855 (2.6 MB)

se nel file /etc/network/interfaces sostituisco eth0 con enp3s0 il pc si rallenta vistosamente all'avvio e il problema comunque non è risolto

grazie per le risposte
Cita messaggio
Grazie da:
#2
Il problema dovrebbe essere legato alle nuove modalità di denominazione dei dispositivi di rete in systemd.
In alcuni casi si può ovviare in quesata maniera:
Codice:
$ sudo gedit /etc/default/grub
modifica la riga
GRUB_CMDLINE_LINUX=""
in
GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"
salva ed esci. Non dimenticare poi un
Codice:
$ sudo update-grub
Riavvia.

Bye,
Token
Cita messaggio
Grazie da: fantasy_rm , fantasy_rm
#3
grazie token;
nel frattempo ho fatto
ip link set dev enp3s0 address 00:21:5d:2c:4b:97
ho dato questo mac e pare che funzioni tutto
ifconfig ora  mi restituisce come mac address 4a:81:ab:bd:04:46
se lo sarà assegnato da solo quando ho provato a forzarlo manualmente
ho fatto anche la modifica suggerita da token successivamente.
funziona tutto, grazie

EDIT @bilodiego ho corretto nel modo appropriato la dicitura [RISOLTO] nel titolo della discussione.
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)