SITO1 -- SITO2 -- Forum1 -- CercaGlobale -- Informativa su Cookie e Privacy


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]server ubuntu 18.04.2 non viene visto da remoto
#1
salve,
sono ancora qui a disturbare.
finalmente sono riuscito a completare l'installazione del  mio server 18.04.2 , con tutte le componenti LAMP e TOMCAT8.
ho assegnato un IP statico, modificando 
Codice:
sudo nano  /etc/netplan/01-netcfg.yaml

così:
Citazione:# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
 version: 2
 renderer: networkd
 ethernets:
   enp2s0:
    dhcp4: no
    addresses: [192.168.1.24/24]
    gateway4: 192.168.1.1
    nameservers:
      addresses: [8.8.8.8,8.8.4.4]

ora se da un browser di un PC della stessa LAN in cui c'è il server, imposto l' IP del server,
ottengo le classiche videate di default per apache

Codice:
http://192.168.1.24/


e  per tomcat:

Codice:
http://192.168.1.24:8080/

mentre se da un PC esterno alla mia LAN, se cerco di collegarmi al server usando l' IP pubblico (danyred.ddns.net),
non riesco a collegarmi.

Per controllo, ho installato su un altro PC della stessa LAN un server LAMP ubuntu 16.04  e questo viene visto correttamente da remoto.

Può dipendere forse dal parametro
Citazione:enp2s0
 che non so cosa significa, e che in alcuni esempi   è diverso, come  enp3s0, enp0s2, enp0s3.

grazie per l'attenzione
danilo
Cita messaggio
Grazie da:
#2
Ho cercato differenze tra la configurazione nretwork del server 16.04  e quella per il server 18.04.

Citazione:danilo@ubuntuserverhp16:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial
danilo@ubuntuserverhp16:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 00:26:9e:71:8a:ab brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:24:d6:2b:ed:3e brd ff:ff:ff:ff:ff:ff
danilo@ubuntuserverhp16:~$
dove la configurazione network  del 16.04 è:
Citazione:danilo@ubuntuserverhp16:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp3s0
iface enp3s0 inet static
address 192.168.1.24
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.251
dns-nameserver 208.67.222.222 212.216.112.112
danilo@ubuntuserverhp16:~$ 
ora per il 18.04 ho:

Citazione:danilo@ubuntuservertwr:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic
danilo@ubuntuservertwr:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 00:1d:60:79:9c:d8 brd ff:ff:ff:ff:ff:ff
danilo@ubuntuservertwr:~$ 
 
quindi qualche differenza c'è, non so se importante o no (nel ip link  del 16 ci sono 3 punti,nel  18 solo 2)

chissà se queste informazioni possono aiutare ?

danilo
Cita messaggio
Grazie da:
#3
pensavo di aver trovato la cabola perché lanciando il comando 

Codice:
sudo netplan apply

 
ottenevo errori.
ora il nuovo .yaml senza più errori segnalati  è così:
Citazione:# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
    enp2s0:
     dhcp4: no
     dhcp6: no
     addresses: [192.168.1.24/24]
     gateway4: 192.168.1.1
     nameservers:
       addresses: [8.8.8.8,8.8.4.4]              
 
ma non funziona ancora Angry
Cita messaggio
Grazie da:
#4
se uso il comando 

Codice:
sudo netplan --debug apply


ottengo questo risultato:

Citazione:danilo@ubuntuservertwr:~$ sudo netplan --debug apply
** (generate:1829): DEBUG: 17:48:12.879: Processing input file /etc/netplan/01-netcfg.yaml..
** (generate:1829): DEBUG: 17:48:12.879: starting new processing pass
** (generate:1829): DEBUG: 17:48:12.880: enp2s0: setting default backend to 1
** (generate:1829): DEBUG: 17:48:12.880: Generating output files..
** (generate:1829): DEBUG: 17:48:12.880: NetworkManager: definition enp2s0 is not for us (backend 1)
DEBUG:netplan generated networkd configuration exists, restarting networkd
DEBUG:no netplan generated NM configuration exists
DEBUG:enp2s0 not found in {}
DEBUG:Merged config:
network:
  bonds: {}
  bridges: {}
  ethernets:
    enp2s0:
      addresses:
      - 192.168.1.24/24
      dhcp4: false
      dhcp6: false
      gateway4: 192.168.1.1
      nameservers:
        addresses:
        - 8.8.8.8
        - 8.8.4.4
  vlans: {}
  wifis: {}

DEBUG:Skipping non-physical interface: lo
DEBUG:device enp2s0 operstate is up, not changing
DEBUG:{}
DEBUG:netplan triggering .link rules for lo
DEBUG:netplan triggering .link rules for enp2s0
danilo@ubuntuservertwr:~$ 

dove non capisco se mi dice che enp2s0 non è valido
 (** (generate:1829): DEBUG: 17:48:12.880: NetworkManager: definition enp2s0 is not for us (backend 1)
(DEBUG:enp2s0 not found in {})

nel qual caso, cosa dovrei impostare al suo posto? Ho già provato con altri valori, ma è peggio: non imposta nessun IP, neanche quello da  dhcp.
Cita messaggio
Grazie da:
#5
male, ora ricomincia a non trovare i repository:
"Errore:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Risoluzione di "security.ubuntu.com" temporaneamente non riuscita
"
A questo punto abbndono il 18.04 e torno al 17 o al 16, che funzionano benissimo.
grazie per l'aiuto
danilo
Cita messaggio
Grazie da:


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)